AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi Zeos 6.1.5 und MySQL 4.1

Zeos 6.1.5 und MySQL 4.1

Ein Thema von beja7 · begonnen am 31. Mär 2005 · letzter Beitrag vom 31. Mär 2005
Antwort Antwort
beja7

Registriert seit: 31. Mär 2005
Ort: Marburg
3 Beiträge
 
#1

Zeos 6.1.5 und MySQL 4.1

  Alt 31. Mär 2005, 11:28
Datenbank: MySQL • Version: 4.1 • Zugriff über: Zeos DB 6.1.5
Ich habe das Problem, dass ich auf einen neuen Datenbank-Server zugreifen will, der unter MySQL 4.1 läuft (der alte war 4.0).
ZEOS DB 6.1.5 soll ja eigentlich auch mit 4.1 kommunizieren können, doch wundert mich, dass die mit ZEOS mitgelieferten DLLs nur libmysql320.dll, libmysql323.dll und libmysql40.dll heissen. Da scheint doch die Bibliothek für 4.1 zu fehlen, oder?

Wenn ich nämlich in die connection als Protocoll "MySQL-4.0" schreibe, kriege ich das Problem, dass die alte Clientversion nicht mit dem Passwort-Mechanismus auf dem 4.1-Server zusammenarbeiten will. Schreibe ich aber als Protokoll "MySQL-4.1" heißt es "Requested database driver was not found".

Wo liegt das Problem?
  Mit Zitat antworten Zitat
Benutzerbild von Pseudemys Nelsoni
Pseudemys Nelsoni

Registriert seit: 24. Dez 2002
Ort: Hamburg-Harburg
3.551 Beiträge
 
#2

Re: Zeos 6.1.5 und MySQL 4.1

  Alt 31. Mär 2005, 11:34
Du musst die Version 6.5.1 ziehen.

http://puzzle.dl.sourceforge.net/sou....5.1-alpha.zip
Mario
MSN: cyanide@ccode.de
  Mit Zitat antworten Zitat
beja7

Registriert seit: 31. Mär 2005
Ort: Marburg
3 Beiträge
 
#3

Re: Zeos 6.1.5 und MySQL 4.1

  Alt 31. Mär 2005, 13:05
Danke, funktioniert.

Es irritiert aber, dass in den Projektinfos von ZEOS 6.1.5 drin steht (Readme.html),
es würde MySQL 3.20 - 4.1 unterstützt. Weißt Du darüber was? Warum schreiben die, 4.1 ginge, wenn es so offensichtlich nicht geht?
  Mit Zitat antworten Zitat
Benutzerbild von Pseudemys Nelsoni
Pseudemys Nelsoni

Registriert seit: 24. Dez 2002
Ort: Hamburg-Harburg
3.551 Beiträge
 
#4

Re: Zeos 6.1.5 und MySQL 4.1

  Alt 31. Mär 2005, 13:08
Moin beja, das weiss ich leider nicht

Aber vielleicht geht das ja mit der 4.0 DLL
Mario
MSN: cyanide@ccode.de
  Mit Zitat antworten Zitat
Benutzerbild von RavenIV
RavenIV

Registriert seit: 12. Jan 2005
Ort: Waldshut-Tiengen
2.875 Beiträge
 
Delphi 2007 Enterprise
 
#5

Re: Zeos 6.1.5 und MySQL 4.1

  Alt 31. Mär 2005, 13:32
zwischen mySQL 4.0 und 4.1 wurde das protokoll ein wenig geändert.
man kann aber den trick mit "old_password" anwenden.
such mal hier danach.

gruessle
Klaus E.
Linux - das längste Text-Adventure aller Zeiten...
Wer nie Linux mit dem vi konfiguriert hat, der hat am Leben vorbei geklickt.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 23:49 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz