AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Probleme mit ZEOS

Ein Thema von TheMiller · begonnen am 1. Apr 2005 · letzter Beitrag vom 2. Apr 2005
Antwort Antwort
Benutzerbild von TheMiller
TheMiller

Registriert seit: 19. Mai 2003
Ort: Gründau
2.480 Beiträge
 
Delphi XE7 Architect
 
#1

Probleme mit ZEOS

  Alt 1. Apr 2005, 20:51
Datenbank: MySQL • Version: 4 • Zugriff über: ZEOS
Hi,

ich versuche, Datensätze mittels der ZEOS Komponente einzufügen, bekomme allerdings folgende Meldung zurück:

Can not retrieve ResultSet data Habe keine Komponente, die die Datensätze der Tabelle anzeigt. Soll auch nicht. Was bedeutet diese Fehlermeldung?

Danke im Voraus
Bisheriger Nutzername "DJ-SPM"
  Mit Zitat antworten Zitat
Benutzerbild von Sharky
Sharky

Registriert seit: 29. Mai 2002
Ort: Frankfurt
8.252 Beiträge
 
Delphi 2006 Professional
 
#2

Re: Probleme mit ZEOS

  Alt 2. Apr 2005, 04:50
Zitat von DJ-SPM:
Hi,

ich versuche, Datensätze mittels der ZEOS Komponente einzufügen, bekomme allerdings folgende Meldung zurück:...
Hai DJ-SPM,

mit was versuchst Du es denn? ZQuery? ZTable?
Und wie sieht dein Code für das Einfügen aus?
Stephan B.
"Lasst den Gänsen ihre Füßchen"
  Mit Zitat antworten Zitat
Benutzerbild von TheMiller
TheMiller

Registriert seit: 19. Mai 2003
Ort: Gründau
2.480 Beiträge
 
Delphi XE7 Architect
 
#3

Re: Probleme mit ZEOS

  Alt 2. Apr 2005, 11:11
Hallo,

versuche es mit der ZQuery-Komponente und mein Code sieht folgendermaßen aus:

Delphi-Quellcode:
Zquery1.SQL.TEXT:='INSERT INTO tabelle (name,nr) VALUES (sascha, 01);';

oder

ZQuery1.SQL.Text:='INSERT INTO tabelle (name, nr) VALUES ('''+Edit1.Text+''','''+Edit2.Text+''');';

danach immer:
Zquery1.Open;
In beiden Fällen wird in die Datenbank geschrieben, erhalte aber dennoch eine Fehlermeldung. Auch wenn ich mit ZQuery1 den Befehl UPDATE benutze, wird dieser korrekt ausgeführt. Doch die Fehlermeldung erhalte ich trotzdem...

Hoffe ihr könnt mir helfen. Danke
Bisheriger Nutzername "DJ-SPM"
  Mit Zitat antworten Zitat
Igotcha

Registriert seit: 22. Dez 2003
544 Beiträge
 
Delphi 2006 Professional
 
#4

Re: Probleme mit ZEOS

  Alt 2. Apr 2005, 11:28
Das machst du auch nicht mit "open", sondern "ExecSQL"

Open ist für Abfragen, ExecSQL für Inserts und Updates.

Gruß Igotcha
  Mit Zitat antworten Zitat
Benutzerbild von TheMiller
TheMiller

Registriert seit: 19. Mai 2003
Ort: Gründau
2.480 Beiträge
 
Delphi XE7 Architect
 
#5

Re: Probleme mit ZEOS

  Alt 2. Apr 2005, 11:31
...ich danke...

geh mich mal ein bissl hauen. So viel Blödheit muss bestraft werden. Funzt natürlich
Bisheriger Nutzername "DJ-SPM"
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 19:46 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz