Einzelnen Beitrag anzeigen

Amateurprofi

Registriert seit: 17. Nov 2005
Ort: Hamburg
1.043 Beiträge
 
Delphi XE2 Professional
 
#2

Re: Excel: Berechnung abhängig von der Farbe einer anderen Z

  Alt 2. Mär 2006, 21:43
Zitat von Helmi:
Enthält eine oder mehrere Zellen einen roten Text, dann soll die Berechnung nicht durchgeführt werden.
Helmi,
im Prinzip gilt : Alles ist machbar Herr (oder Frau?) Nachbar.

Wie man das Problem löst hängt davon ab, warum der Text in den Zellen rot ist.
Zum Beispiel könnte man ja auf die Idee kommen mit Hilfe bedingter Formatierung den Text Mittwochs rot darzustellen.

Ich vermute Du hast eine Standard-Formatierung, bei der negative Zahlen rot dargestellt werden.
Dann wäre die richtige Formulierung des Problems, daß nur dann eine Summe gebildet werden soll, wenn der zu summierende Bereich keine negativen Werte enthält.

Dann ließe sich das Problem z.B. so lösen :

=WENN(SUMMEWENN(A10:A13,"<0",A10:A13)=0,SUMME(A10: A13),"")

wobei A10:A13 der zu summierenden Bereich ist.

Hilft das ?
Gruß, Klaus
Die Titanic wurde von Profis gebaut,
die Arche Noah von einem Amateur.
... Und dieser Beitrag vom Amateurprofi....
  Mit Zitat antworten Zitat