AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Programmieren allgemein Excel: Berechnung abhängig von der Farbe einer anderen Zelle

Excel: Berechnung abhängig von der Farbe einer anderen Zelle

Ein Thema von Helmi · begonnen am 2. Mär 2006 · letzter Beitrag vom 2. Mär 2006
Antwort Antwort
Benutzerbild von Helmi
Helmi

Registriert seit: 29. Dez 2003
Ort: Erding, Republik Bayern
3.312 Beiträge
 
Delphi XE2 Professional
 
#1

Excel: Berechnung abhängig von der Farbe einer anderen Zelle

  Alt 2. Mär 2006, 19:36
Hallo,

ich möchte in Excel eine Berechnung (Summe) von mehreren Zellen durchführen, aber nur wenn keine von x Zellen einer anderen Spalte einen roten Text enthält. Enthält eine oder mehrere Zellen einen roten Text, dann soll die Berechnung nicht durchgeführt werden.

Ich hab zwar schon SummeWenn gefunden, aber ich weiss nicht wie ich das mit der Textformatierung (Farbe) hinbekommen soll.

Im Übrigen stell ich mir die Frage geht das eigentlich?
mfg
Helmi

>> Theorie ist Wissen, dass nicht funktioniert - Praxis ist, wenn alles funktioniert und keiner weiss warum! <<
  Mit Zitat antworten Zitat
Amateurprofi

Registriert seit: 17. Nov 2005
Ort: Hamburg
1.043 Beiträge
 
Delphi XE2 Professional
 
#2

Re: Excel: Berechnung abhängig von der Farbe einer anderen Z

  Alt 2. Mär 2006, 21:43
Zitat von Helmi:
Enthält eine oder mehrere Zellen einen roten Text, dann soll die Berechnung nicht durchgeführt werden.
Helmi,
im Prinzip gilt : Alles ist machbar Herr (oder Frau?) Nachbar.

Wie man das Problem löst hängt davon ab, warum der Text in den Zellen rot ist.
Zum Beispiel könnte man ja auf die Idee kommen mit Hilfe bedingter Formatierung den Text Mittwochs rot darzustellen.

Ich vermute Du hast eine Standard-Formatierung, bei der negative Zahlen rot dargestellt werden.
Dann wäre die richtige Formulierung des Problems, daß nur dann eine Summe gebildet werden soll, wenn der zu summierende Bereich keine negativen Werte enthält.

Dann ließe sich das Problem z.B. so lösen :

=WENN(SUMMEWENN(A10:A13,"<0",A10:A13)=0,SUMME(A10: A13),"")

wobei A10:A13 der zu summierenden Bereich ist.

Hilft das ?
Gruß, Klaus
Die Titanic wurde von Profis gebaut,
die Arche Noah von einem Amateur.
... Und dieser Beitrag vom Amateurprofi....
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 23:32 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz