AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

FF + XHTML + css = :(

Ein Thema von jfheins · begonnen am 20. Jan 2006 · letzter Beitrag vom 25. Jan 2006
Antwort Antwort
Benutzerbild von jfheins
jfheins

Registriert seit: 10. Jun 2004
Ort: Garching (TUM)
4.579 Beiträge
 
#1

FF + XHTML + css = :(

  Alt 20. Jan 2006, 16:32
Oder sollte ich das Thema "CSS nicht FF1.5-kompatibel " nennen

Naja, auf jeden Fall schaffe ich es gerade nicht, dem Firefox 1.5 per CSS eine einheitliche Hintergrundfarbe zu verpassen.

Das Problem tritt nur bei XHTML auf.

Folgender Source:
Code:
<?php
   header ('Content-Type: application/xhtml+xml');
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<title>CSS nicht FF1.5-kompatibel :(</title>
<meta name="generator" content="Webweaver v1.6.7 [http://webweaver.ws]" />
</head>
<body style="background-color:#00FF00;">
<div>Hallo</div>
Welt
</body>
</html>
normalerweise müsste doch eine hintergrundfarbe für den body alles ausfüllen - der FF macht den body aber nur so groß, wie nötig

(sogar mit bgcolor gehts nicht )

Es liegt definiv am XHTML-Parser, wenn ich den Content-Type auf text/html ändere, geht alles wie gewünscht ...

Kann mir jemand helfen ?

P.S. In Opera geht es, aber ich will, dass meine Site im FF nicht ganz eklig aussieht ... ^^
  Mit Zitat antworten Zitat
Skyrunner2

Registriert seit: 11. Jan 2005
Ort: Bochum
50 Beiträge
 
Delphi 2006 Architect
 
#2

Re: FF + XHTML + css = :(

  Alt 25. Jan 2006, 16:15
hast du eine beispiel datei hochgeladen?

wenn ja dann geb doch mal ein link..
  Mit Zitat antworten Zitat
Benutzerbild von jfheins
jfheins

Registriert seit: 10. Jun 2004
Ort: Garching (TUM)
4.579 Beiträge
 
#3

Re: FF + XHTML + css = :(

  Alt 25. Jan 2006, 17:28
Warum exisitiert dieser Post ??

Ich habe das Problem schon gelöst ... siehe da:
http://www.delphipraxis.net/internal...ct.php?t=73304

Der FF scheint sogar standard-konform zu sein, wenn er das body-element nicht auf die volle höhe ausdehent .... komischer Standard ...
  Mit Zitat antworten Zitat
Benutzerbild von alcaeus
alcaeus

Registriert seit: 11. Aug 2003
Ort: München
6.537 Beiträge
 
#4

Re: FF + XHTML + css = :(

  Alt 25. Jan 2006, 17:33
Zitat von jfheins:
Der FF scheint sogar standard-konform zu sein, wenn er das body-element nicht auf die volle höhe ausdehent .... komischer Standard ...
FF scheint ein Problem zu haben, wenn du bei einem Element height:100% notierst. Ich hab irgendwo mal gelesen, dass du in dem Fall bei allen umschliessenden Elementen ebenfalls height:100% notieren musst, inklusive html-Tag; sonst ist da nichts zu machen. Vielleicht willst du ja mal das versuchen

Greetz
alcaeus
Andreas B.
Die Mutter der Dummen ist immer schwanger.
Ein Portal für Informatik-Studenten: www.infler.de
  Mit Zitat antworten Zitat
Benutzerbild von jfheins
jfheins

Registriert seit: 10. Jun 2004
Ort: Garching (TUM)
4.579 Beiträge
 
#5

Re: FF + XHTML + css = :(

  Alt 25. Jan 2006, 17:47
Wie oben geschrieben: Ich habe das Problem schon gelöst

Einfach die Hintergrundfarbe für den HTML-Tag festlegen ...
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 03:25 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz