AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi (N)umerisches Feld akzeptiert keinen Punkt

(N)umerisches Feld akzeptiert keinen Punkt

Ein Thema von LOMBI · begonnen am 23. Mai 2006 · letzter Beitrag vom 28. Mai 2006
Antwort Antwort
Seite 1 von 2  1 2   
LOMBI
(Gast)

n/a Beiträge
 
#1

(N)umerisches Feld akzeptiert keinen Punkt

  Alt 23. Mai 2006, 17:23
Datenbank: Paradox • Version: 7 • Zugriff über: Query, DataSource
Guten Abend,

sobald ich in ein Edit vom Typ (n)umerisch einen Betrag mit Punkt schreibe,
erhalte ich die Fehlermeldung "kein gültiger Fließkommawert". Was muß ich
bitte tun, damit statt eines ',' ein '.' akzeptiert wird?

Vielen Dank!

Lombi
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.820 Beiträge
 
Delphi 10.4 Sydney
 
#2

Re: (N)umerisches Feld akzeptiert keinen Punkt

  Alt 23. Mai 2006, 17:53
DecimalSeparator _= '.';
Markus Kinzler
  Mit Zitat antworten Zitat
WePo

Registriert seit: 11. Jan 2006
Ort: Buttenheim
20 Beiträge
 
Delphi 6 Professional
 
#3

Re: (N)umerisches Feld akzeptiert keinen Punkt

  Alt 23. Mai 2006, 21:40
und wieder umstellen nicht vergessen?
Machen wir dem Fehlerteufel einen Knoten in den Schwanz
  Mit Zitat antworten Zitat
marabu

Registriert seit: 6. Apr 2005
10.109 Beiträge
 
#4

Re: (N)umerisches Feld akzeptiert keinen Punkt

  Alt 24. Mai 2006, 06:28
Guten Morgen.

Wir sollten immer daran denken, dass die von der Unit SysUtils importierten Systemeinstellungen (DecimalSeparator, ThousandsSeparator) das Format der interaktiven Eingaben (TEdit) diktieren. Ist nicht schön, wenn eine Anwendung von vielen, die eventuell sogar gleichzeitig geöffnet sind, sich nicht an die Systemvorgaben hält.

Ein Sonderfall ist die nicht interaktive Übernahme von Display-Daten z.B. aus Dateien. Hier würde ich (D3) die Zeichenketten vorbehandeln und dann der normalen Verarbeitung zuführen:

Delphi-Quellcode:
function Translate(const s, sOld, sNew: String): String;
var
  i, iPos, iLen: integer;
begin
  SetLength(Result, Length(s));
  iLen := 0;
  for i := 1 to Length(s) do
  begin
    iPos := Pos(s[i], sOld);
    if iPos > Length(sNew) then
      Continue;
    Inc(iLen);
    if iPos > 0
      then Result[iLen] := sNew[iPos]
      else Result[iLen] := s[i];
  end;
  SetLength(Result, iLen);
end;

procedure TDemoForm.ButtonClick(Sender: TObject);
var
  e: Extended;
begin
  e := StrToFloat(Translate('123,456.78', '.,', ',.'));
end;
In D7 ist das nicht nötig. Dort stehen GetLocaleFormatSettings() und die überladenen Konvertierungsfunktionen zur Verfügung.

Grüße vom marabu

Edit: Fehler in Translate() korrigiert...
  Mit Zitat antworten Zitat
LOMBI
(Gast)

n/a Beiträge
 
#5

Re: (N)umerisches Feld akzeptiert keinen Punkt

  Alt 24. Mai 2006, 10:08
Delphi-Quellcode:
procedure TDemoForm.ButtonClick(Sender: TObject);
var
  e: Extended;
begin
  e := StrToFloat(Translate('123,456.78', '.,', ',.'));
end;
Fehlermeldung: ''123,456.78 ist kein gültiger Fließkommawert'.
Diese Meldung erhalte ich auch mit ','.

Viele Grüße
Lombi
  Mit Zitat antworten Zitat
marabu

Registriert seit: 6. Apr 2005
10.109 Beiträge
 
#6

Re: (N)umerisches Feld akzeptiert keinen Punkt

  Alt 24. Mai 2006, 10:22
Klar - weil die Tausenderpunkte bei der Konvertierung nicht mehr drin sein dürfen. Probier mal so:

Delphi-Quellcode:
procedure TDemoForm.ButtonClick(Sender: TObject);
var
  e: Extended;
begin
  e := StrToFloat(Translate('123,456.78', '.,', DecimalSeparator));
end;
marabu
  Mit Zitat antworten Zitat
LOMBI
(Gast)

n/a Beiträge
 
#7

Re: (N)umerisches Feld akzeptiert keinen Punkt

  Alt 24. Mai 2006, 11:01
Ne, klappt leider nicht.
  Mit Zitat antworten Zitat
Ratte

Registriert seit: 12. Dez 2003
Ort: Erfurt
345 Beiträge
 
Delphi 2005 Personal
 
#8

Re: (N)umerisches Feld akzeptiert keinen Punkt

  Alt 24. Mai 2006, 11:26
dann entfern doch die Tausenderpunkte mit Pos() und delete() vorher.
mfg,
Ratte
Schiffsratte der U.S.S. Delphipraxis, Laderaum 4538
BUSH:= TTerminator.create;
  Mit Zitat antworten Zitat
marabu

Registriert seit: 6. Apr 2005
10.109 Beiträge
 
#9

Re: (N)umerisches Feld akzeptiert keinen Punkt

  Alt 24. Mai 2006, 12:07
Hallo Lombi,

da war ein Fehler in meiner Funktion. Ich habe ihn korrigiert und du müsstest dir den Code nochmal kopieren.

Sorry

marabu
  Mit Zitat antworten Zitat
LOMBI
(Gast)

n/a Beiträge
 
#10

Re: (N)umerisches Feld akzeptiert keinen Punkt

  Alt 25. Mai 2006, 17:16
Hi marabu,

danke für die Nachricht. Es gibt nur noch ein Problem und zwar mit der
Berechnung der MwSt. Bei einer Dezimalzahl mit Punkt bleibt das Edit VKbrutto leer.

Viele Grüße
Lombi
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 21:24 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf