AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke Delphi Problem mit TIdSNTP

Problem mit TIdSNTP

Ein Thema von Sourcemaker · begonnen am 8. Jun 2006 · letzter Beitrag vom 12. Jun 2006
Antwort Antwort
Benutzerbild von Sourcemaker
Sourcemaker

Registriert seit: 3. Sep 2003
Ort: Westoverledingen
256 Beiträge
 
Delphi XE5 Professional
 
#1

Problem mit TIdSNTP

  Alt 8. Jun 2006, 15:01
Hallo,

ich versuche mich gerade mit der Indy-Komponente TIdSNTP
bekomme aber trotz Connect kein Datum/Uhrzeit von einen Internetzeitserver.

Verbinde ich mich zu meinen Novell-Server bekomme ich eine Rückgabe.

Zur Verifizierung habe ich dieses Projekt getestet Einfacher SNTP-Client
und wenn ich das Programm direkt ausführe funktioniert es
wenn ich jedoch den Quellcode nehme habe ich den gleichen Effekt.

Die Indy-Version ist 10.0.52.

Irgendeine Idee ?

Grüße

Frank
Frank
  Mit Zitat antworten Zitat
Klaus01
Online

Registriert seit: 30. Nov 2005
Ort: München
5.497 Beiträge
 
Delphi 10.3 Rio
 
#2

Re: Problem mit TIdSNTP

  Alt 8. Jun 2006, 15:18
Vielleicht ist in Richtung Internet eine Firewall oder ähnliches im Weg?
SNTP läuft auf Port 123 und benutzt das UDP Protokol, ein connect sollte
da nicht möglich sein - oder meintest Du den Client active = true setzen?

Grüße
Klaus
Klaus
  Mit Zitat antworten Zitat
Benutzerbild von Sourcemaker
Sourcemaker

Registriert seit: 3. Sep 2003
Ort: Westoverledingen
256 Beiträge
 
Delphi XE5 Professional
 
#3

Re: Problem mit TIdSNTP

  Alt 8. Jun 2006, 15:48
Firewall oder andere Internetprobleme scheiden aus
da ja das genannte Testprojekt (als Exe heruntergeladen)
funktioniert.
Erst wenn ich diesen Quellcode benutzte und bei mir kompiliere
geht es nicht mehr.

Grüße

Frank
Frank
  Mit Zitat antworten Zitat
Klaus01
Online

Registriert seit: 30. Nov 2005
Ort: München
5.497 Beiträge
 
Delphi 10.3 Rio
 
#4

Re: Problem mit TIdSNTP

  Alt 8. Jun 2006, 15:52
Hallo Frank,

da das Testproject aus dem Jahre 2004 stammt,
kann es gut sein, daß dort eine Indy Version < 10
benutzt wurde.

Vielleicht ist bei Indy 10 und der NTP Komponente etwas
umgestellt worden.

Habe bei mir kein Indy 10.x installiert.

Grüße
Klaus
Klaus
  Mit Zitat antworten Zitat
Benutzerbild von Sourcemaker
Sourcemaker

Registriert seit: 3. Sep 2003
Ort: Westoverledingen
256 Beiträge
 
Delphi XE5 Professional
 
#5

Re: Problem mit TIdSNTP

  Alt 8. Jun 2006, 15:57
Hallo Klaus,

das mit der anderen Indy-Version ist anzunehmen hilft mir aber nicht wirklich.

Grüße

Frank
Frank
  Mit Zitat antworten Zitat
Benutzerbild von Sourcemaker
Sourcemaker

Registriert seit: 3. Sep 2003
Ort: Westoverledingen
256 Beiträge
 
Delphi XE5 Professional
 
#6

Re: Problem mit TIdSNTP

  Alt 12. Jun 2006, 11:15
Hi,

könnte es vielleicht jemand anhand des erwähnten Testprojektes verifizieren
ob es an der aktuellen Indy-Version oder möglicherweise an meiner Entwicklungs-
umgebung liegt ?

Grüße

Frank
Frank
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 12:48 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf