AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi ADOQuery zeigt SQL-Anfrage nicht in DBGrid an

ADOQuery zeigt SQL-Anfrage nicht in DBGrid an

Ein Thema von Moyyer · begonnen am 31. Aug 2006 · letzter Beitrag vom 3. Sep 2006
Antwort Antwort
Moyyer

Registriert seit: 31. Mai 2003
155 Beiträge
 
Delphi 7 Enterprise
 
#1

ADOQuery zeigt SQL-Anfrage nicht in DBGrid an

  Alt 31. Aug 2006, 10:25
Datenbank: MS Access • Zugriff über: ADO
Hallo

Ich arbeite gerade mit einer Access Datenbank in meinem Programm und konnte diese erfolgreich mit "ADOConnection", "ADOTable" und "DataSource" in einem DBGrid anzeigen lassen. Nun habe ich zusätzlich noch ein ADOQuery hinzugefügt um mit SQL Befehlen Datensätze zu filtern. Nur werden diese leider nicht in der DBGrid angezeigt. Alle Komponenten sind miteinander verbunden.

Mein Code ist folgender:

Delphi-Quellcode:
ADOQuery.Active := false;
ADOQuery.SQL.Text := 'SELECT * FROM DB1 WHERE ID=1;';
ADOQuery.Active := true;
Wenn ich den Code ausführe passiert gar nix (nicht mal eine Fehlermeldung).
Was muss ich machen, dass das gefilterte Ergebnis im DBGrid angezeigt wird?

Gruß Moyyer

P.S. Hab schon überall gesucht, aber nix gefunden
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.851 Beiträge
 
Delphi 11 Alexandria
 
#2

Re: ADOQuery zeigt SQL-Anfrage nicht in DBGrid an

  Alt 31. Aug 2006, 10:47
Versuch mal
ADOQuery.Open;
Markus Kinzler
  Mit Zitat antworten Zitat
Benutzerbild von rwachtel
rwachtel

Registriert seit: 26. Aug 2004
Ort: Köln
530 Beiträge
 
RAD-Studio 2010 Pro
 
#3

Re: ADOQuery zeigt SQL-Anfrage nicht in DBGrid an

  Alt 31. Aug 2006, 10:47
Gibt es überhaupt Datensätze mit der ID 1? Was bedeutet "zusätzlich" hinzugefügt und "alle" miteinander verbunden? Eine ADOQuery ist ein Äquivalent zu ADOTable, kein Zusatz.
Robert Wachtel
  Mit Zitat antworten Zitat
Benutzerbild von rwachtel
rwachtel

Registriert seit: 26. Aug 2004
Ort: Köln
530 Beiträge
 
RAD-Studio 2010 Pro
 
#4

Re: ADOQuery zeigt SQL-Anfrage nicht in DBGrid an

  Alt 31. Aug 2006, 10:53
Zitat von mkinzler:
Versuch mal
ADOQuery.Open;
Ähem, aus DB.PAS:

Code:
procedure TDataSet.Open;
begin
  Active := True;
end;
Robert Wachtel
  Mit Zitat antworten Zitat
shmia

Registriert seit: 2. Mär 2004
5.508 Beiträge
 
Delphi 5 Professional
 
#5

Re: ADOQuery zeigt SQL-Anfrage nicht in DBGrid an

  Alt 31. Aug 2006, 10:56
Zitat von Moyyer:
Nun habe ich zusätzlich noch ein ADOQuery hinzugefügt um mit SQL Befehlen Datensätze zu filtern. Nur werden diese leider nicht in der DBGrid angezeigt. Alle Komponenten sind miteinander verbunden.
wirklich 100% sicher, dass das Grid mit der Datasource und die Datasource mit deiner Query verbunden ist???
(es wäre nicht das erste Mal dass soetwas übersehen wird)
Sollte die Query eine leere Datenmange liefern, dann müsste das Grid diese leere Menge anzeigen.
Man erkennt es daran, dass bei aktiver Query die Feldnamen im Grid angezeigt werden.
Andreas
  Mit Zitat antworten Zitat
Moyyer

Registriert seit: 31. Mai 2003
155 Beiträge
 
Delphi 7 Enterprise
 
#6

Re: ADOQuery zeigt SQL-Anfrage nicht in DBGrid an

  Alt 31. Aug 2006, 10:57
Zitat:
Gibt es überhaupt Datensätze mit der ID 1? Was bedeutet "zusätzlich" hinzugefügt und "alle" miteinander verbunden? Eine ADOQuery ist ein Äquivalent zu ADOTable, kein Zusatz.
Also Datensätze mit der ID 1 gibt es (sonst hätte ich das Beispiel nicht genommen).

"Alle miteinande verbunden" bedeutet, dass ich z.B. ADOTable.Connection mit ADOConnection verbunden habe.

Aber dein Tipp mit "Aquivalent zu ADOTable" hab ich weiterverfolgt, den ich habe gedacht es ist ein Zusatz.
Und siehe da, nach ein paar Klicks funktioniert es nun.
Darauf muss man erstmal kommen.

Thx rwachtel
  Mit Zitat antworten Zitat
Moyyer

Registriert seit: 31. Mai 2003
155 Beiträge
 
Delphi 7 Enterprise
 
#7

Re: ADOQuery zeigt SQL-Anfrage nicht in DBGrid an

  Alt 31. Aug 2006, 10:59
Natürlich auch ein dickes DANKE an alle anderen.
Wiedermal hat mit Delphi-Praxis exzellent geholfen.


Gruß Moyyer
  Mit Zitat antworten Zitat
Christian Seehase
(Co-Admin)

Registriert seit: 29. Mai 2002
Ort: Hamburg
11.114 Beiträge
 
Delphi 11 Alexandria
 
#8

Re: ADOQuery zeigt SQL-Anfrage nicht in DBGrid an

  Alt 3. Sep 2006, 01:45
Moin Moyyer,

Zitat von Moyyer:
Und siehe da, nach ein paar Klicks funktioniert es nun.
Erkläre mir doch mal bitte welche Klicks das waren.

Ich stehe nämlich vor dem gleichen Problem, und kann, als Anfänger auf diesem Gebiet, mit den bisherigen Hinweisen die Lösung leider nicht finden.


[EDIT]
Jetzt hab' ich's gefunden:

Man muss nur im ADODataSource die ADOQuery auswählen, was allerdings voraussetzt, dass dort die Eigenschaft DataSource nicht zugewiesen ist.

Aber ich lern' das noch

[/EDIT]
Tschüss Chris
Die drei Feinde des Programmierers: Sonne, Frischluft und dieses unerträgliche Gebrüll der Vögel.
Der Klügere gibt solange nach bis er der Dumme ist
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 19:16 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz