AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Syntaxprobleme mit einer Methode

Ein Thema von Luckie · begonnen am 6. Nov 2006 · letzter Beitrag vom 7. Nov 2006
Antwort Antwort
Seite 1 von 2  1 2   
Benutzerbild von Luckie
Luckie

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#1

Syntaxprobleme mit einer Methode

  Alt 6. Nov 2006, 12:56
Ich will die Methode AddAlias aufrufen aus einer .NET Assembly. Im Anhang sieht man ein Screeshot aus Lutz Röders Refelctor wie das ganze aussieht.

Ich versuche die Methode wie folgt aufzurufen:
Code:
Db4o.configure.AddAlias(new Alias.TypeAlias("Demo_db4o.Person","Demo_db4o.Person, Demo_db4o"));
Allerdings unterstreicht mit VS die beiden öffnenden Klammern mit der Fehlermeldung:
Zitat:
Ungültiges Token "(" in Klasse, Struktur oder Schnittstellenmemberdeklaration.
Was ist da an der Syntax falsch?

In der Hilfe zu der Assembly steht folgendes Code-Beispiel:
Code:
Db4o.configure().addAlias(new TypeAlias("com.f1.Pilot", "com.f1.Driver"));
Allerdings scheint das Java Code zu sein, da dieser unter Java genau so funktioniert.
Miniaturansicht angehängter Grafiken
screenshot_reflector_142.jpg  
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Der_Unwissende

Registriert seit: 13. Dez 2003
Ort: Berlin
1.756 Beiträge
 
#2

Re: Syntaxprobleme mit einer Methode

  Alt 6. Nov 2006, 13:51
Hi,
ich glaube der versucht hier das new immer auf die erste "Variable" zu beziehen und wird hier Alias. als Datentyp verwenden wollen. Versuch es mal mit der (ungewohnt ausseshenden) Konstruktion

Code:
Db4o.configure.AddAlias(Alias.new TypeAlias("Demo_db4o.Person","Demo_db4o.Person, Demo_db4o"));
Unter Java ist zumindest ein ähnliches Konstrukt vorhanden.

Gruß Der Unwissende
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#3

Re: Syntaxprobleme mit einer Methode

  Alt 6. Nov 2006, 13:55
Danke für die Hilfe aber das hilft leider auch nicht. Der Einfachheit halber ein Screenshot mit den Fehlern.
Miniaturansicht angehängter Grafiken
fehler_926.jpg  
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Benutzerbild von phXql
phXql

Registriert seit: 11. Mär 2004
Ort: Mühldorf
824 Beiträge
 
#4

Re: Syntaxprobleme mit einer Methode

  Alt 6. Nov 2006, 14:38
Ist Db4o.configure eine Methode oder eine Property? Wenns eine Methode ist, dann musst du Db4o.configure().addAlias machen..
"Dunkel die andere Seite ist"
"Yoda! Halts Maul und iss deinen Toast!"
  Mit Zitat antworten Zitat
Jürgen Thomas

Registriert seit: 13. Jul 2006
Ort: Berlin
750 Beiträge
 
#5

Re: Syntaxprobleme mit einer Methode

  Alt 6. Nov 2006, 14:45
Hallo,

ist die Klasse, die Du über Db4o.configure benutzt, von ResXResourceWriter abgeleitet? Dann verstehe ich die NET-SDK-Hilfe so:
Code:
Db4o.configure.AddAlias("com.f1.Pilot", "com.f1.Driver");
Zitat von NET-SDK-Hilfe:
Parameter
aliasName
Der Name des Alias.
assemblyName
Der Name der durch aliasName dargestellten Assembly.
Hilft Dir das? Gruß Jürgen
#D mit C# für NET, dazu Firebird
früher: Delphi 5 Pro, Delphi 2005 Pro mit C# (also NET 1.1)
Bitte nicht sauer sein, wenn ich mich bei Delphi-Schreibweisen verhaue; ich bin inzwischen an C# gewöhnt.
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#6

Re: Syntaxprobleme mit einer Methode

  Alt 6. Nov 2006, 14:50
Habe ich auch schon probiert, das macht es nur noch schlimmer. In Java ist es wohl eine Methode.

Wenn ich mir den Reflektor richtig angucke, müsse es eiegntlich so heißen:
Code:
Db4o.Configuration.AddAlias(new Alias.TypeAlias("Demo_db4o.Person", "Demo_db4o.Person, Demo_db4o"));
Aber dann bekomme ich bei den öffnenden Klammern auch ein:
Zitat:
Ungültiges Token "(" in Klasse, Struktur oder Schnittstellenmemberdeklaration.
Auch das
Code:
Db4o.configure.AddAlias("com.f1.Pilot", "com.f1.Driver");
führt zu der Fehlermeldung
Zitat:
Ungültiges Token "(" in Klasse, Struktur oder Schnittstellenmemberdeklaration.
bei der ersten geöffneten Klammer.
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Benutzerbild von Khabarakh
Khabarakh

Registriert seit: 18. Aug 2004
Ort: Brackenheim VS08 Pro
2.876 Beiträge
 
#7

Re: Syntaxprobleme mit einer Methode

  Alt 6. Nov 2006, 14:55
Ich kann im Reflector nirgendwo ein "Alias.TypeAlias" finden, habe ich etwas auf dem Screenshot übersehen?
Code:
Db4o.configure.AddAlias(new TypeAlias("Demo_db4o.Person","Demo_db4o.Person, Demo_db4o"));
Falls phXqls Vermutung zutrifft, eben noch mit dem Klammerpaar, sieht auf dem zweiten Anhang aber eher nicht so aus.
Sebastian
Moderator in der EE
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#8

Re: Syntaxprobleme mit einer Methode

  Alt 6. Nov 2006, 14:59
Ich hänge die Assembly mal an. Die db40 ist Freeware.
Angehängte Dateien
Dateityp: dll db4o_182.dll (428,0 KB, 6x aufgerufen)
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Benutzerbild von Khabarakh
Khabarakh

Registriert seit: 18. Aug 2004
Ort: Brackenheim VS08 Pro
2.876 Beiträge
 
#9

Re: Syntaxprobleme mit einer Methode

  Alt 6. Nov 2006, 15:06
Code:
Db4o.Configure().AddAlias(new TypeAlias("Demo_db4o.Person","Demo_db4o.Person, Demo_db4o"));
Sollte so funktionieren. Aber kein "using com.db4o.config" vergessen oder in "new com.db4o.config.TypeAlias" ändern. Hast du den Rootnamespace com.db4o schon eingebunden, reicht auch "config.TypeAlias"
Sebastian
Moderator in der EE
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#10

Re: Syntaxprobleme mit einer Methode

  Alt 6. Nov 2006, 15:10
das funktioniert irgendwie alles nicht. Siehe Screenshot.
Miniaturansicht angehängter Grafiken
fehler_948.jpg  
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 21:56 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz