AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Multimedia Delphi Form sieht nach Programmstart anders aus

Form sieht nach Programmstart anders aus

Ein Thema von -=cats=- · begonnen am 5. Dez 2006 · letzter Beitrag vom 5. Dez 2006
Antwort Antwort
Seite 1 von 2  1 2   
Benutzerbild von -=cats=-
-=cats=-

Registriert seit: 22. Sep 2006
128 Beiträge
 
Delphi 7 Enterprise
 
#1

Form sieht nach Programmstart anders aus

  Alt 5. Dez 2006, 12:43
Hi

Jetzt hab ich ein Problem gelöst und dadurch ein
neues bekommen

Also, ich zeichne mir eine Form als Polygon.
Klappt alles wunderbar.
Das ganze mache ich im onCreate. Die Punkte
speichere ich in einem Array.

Jetzt habe ich der Form gesagt, sie soll schwarz
sein. Aber noch im Design-Modus (heißt das so ?).
Wenn ich das Programm jetzt starte, ist sie allerdings
nicht schwarz, sondern in der grauen Voreinstellung.
Meine Buttons werden auch nicht angezeigt.

Hat jemand eine Idee, woran das liegen könnte ?
Bin sehr ratlos ...

Gruß,
-=cats=-

  Mit Zitat antworten Zitat
gmc616

Registriert seit: 25. Jun 2004
Ort: Jena
613 Beiträge
 
Delphi 10.3 Rio
 
#2

Re: Form sieht nach Programmstart anders aus

  Alt 5. Dez 2006, 12:57
Nutzt du die XP-Styles (XPMan) ??
Wenn ja, dann könnte es was mit der Transparents zu tun haben.
ParentBackgroud := false; Nur ne Vermutung.
  Mit Zitat antworten Zitat
Benutzerbild von SirThornberry
SirThornberry
(Moderator)

Registriert seit: 23. Sep 2003
Ort: Bockwen
12.235 Beiträge
 
Delphi 2006 Professional
 
#3

Re: Form sieht nach Programmstart anders aus

  Alt 5. Dez 2006, 13:11
Wie erzeugst du das Form? hättest du bischen Quelltext?
Jens
Mit Source ist es wie mit Kunst - Hauptsache der Künstler versteht's
  Mit Zitat antworten Zitat
Benutzerbild von -=cats=-
-=cats=-

Registriert seit: 22. Sep 2006
128 Beiträge
 
Delphi 7 Enterprise
 
#4

Re: Form sieht nach Programmstart anders aus

  Alt 5. Dez 2006, 13:14
Hier ist mal mein gesamter Quellcode

Delphi-Quellcode:
procedure TForm1.FormCreate(Sender: TObject);
var HR : HRgn;
 n : array [0..27] of TPoint;
begin
  n[0] := Point(Width div 2, Height -20); // P1
  n[1] := Point(Width div 2 + 40, Height - 24); // P2
  n[2] := Point(Width div 2 + 40, Height - 44); // P3
  n[3] := Point(Width div 2 + 80, Height - 48); // P4
  n[4] := Point(Width div 2 + 80, Height - 68); // P5
  n[5] := Point(Width div 2 + 40, Height - 72); // P6
  n[6] := Point(Width div 2 + 40, Height - 92); // P7
  n[7] := Point(Width div 2 + 80, Height - 96); // P8
  n[8] := Point(Width div 2 + 80, Height - 116); // P9
  n[9] := Point(Width div 2 + 40, Height - 120); // P10
  n[10] := Point(Width div 2 + 40, Height - 140); // P11
  n[11] := Point(Width div 2 + 80, Height - 144); // P12
  n[12] := Point(Width div 2 + 80, Height - 164); // P13
  n[13] := Point(Width div 2 + 40, Height - 168); // P14
  n[14] := Point(Width div 2, Height - 164); // P15
  n[15] := Point(Width div 2 - 40, Height - 168); // P16
  n[16] := Point(Width div 2 - 80, Height - 164); // P17
  n[17] := Point(Width div 2 - 80, Height - 144); // P18
  n[18] := Point(Width div 2 - 40, Height - 140); // P19
  n[19] := Point(Width div 2 - 40, Height - 120); // P20
  n[20] := Point(Width div 2 - 80, Height - 116); // P21
  n[21] := Point(Width div 2 - 80, Height - 96); // P22
  n[22] := Point(Width div 2 - 40, Height - 92); // P23
  n[23] := Point(Width div 2 - 40, Height - 72); // P24
  n[24] := Point(Width div 2 - 80, Height - 68); // P25
  n[25] := Point(Width div 2 - 80, Height - 48); // P26
  n[26] := Point(Width div 2 - 40, Height - 44); // P27
  n[27] := Point(Width div 2 - 40, Height - 24); // P28

  HR := CreatePolygonRgn(n, 28, ALTERNATE);
  SetWindowRgn(Handle, HR, true);
end;
XPStyles nehme ich soweit ich weiß nicht ...
  Mit Zitat antworten Zitat
gmc616

Registriert seit: 25. Jun 2004
Ort: Jena
613 Beiträge
 
Delphi 10.3 Rio
 
#5

Re: Form sieht nach Programmstart anders aus

  Alt 5. Dez 2006, 13:21
Der Code funktioniert bei mir korrekt. Sogar mit XP-Styles.

Das Problem muß wohl wo anders liegen.
  Mit Zitat antworten Zitat
Benutzerbild von -=cats=-
-=cats=-

Registriert seit: 22. Sep 2006
128 Beiträge
 
Delphi 7 Enterprise
 
#6

Re: Form sieht nach Programmstart anders aus

  Alt 5. Dez 2006, 13:29
Echt ?
Hmm ... so ein Mist
Du hast nicht zufällig eine Idee, was das sein könnte ... ?
  Mit Zitat antworten Zitat
EDatabaseError

Registriert seit: 11. Mai 2005
Ort: Göppingen
1.238 Beiträge
 
Delphi 2007 Professional
 
#7

Re: Form sieht nach Programmstart anders aus

  Alt 5. Dez 2006, 13:29
Also bei mir funkts auch einwandfrei
Tobias
It's not a bug, it's a feature.
  Mit Zitat antworten Zitat
Benutzerbild von -=cats=-
-=cats=-

Registriert seit: 22. Sep 2006
128 Beiträge
 
Delphi 7 Enterprise
 
#8

Re: Form sieht nach Programmstart anders aus

  Alt 5. Dez 2006, 13:35
Spinne ich jetzt ...

Das kann ja nicht sein

Hab mal nen Screenshot angehängt.
Eigentlich sollte die Form schwarz sein !!!
Miniaturansicht angehängter Grafiken
poly_form_139.jpg  
  Mit Zitat antworten Zitat
EDatabaseError

Registriert seit: 11. Mai 2005
Ort: Göppingen
1.238 Beiträge
 
Delphi 2007 Professional
 
#9

Re: Form sieht nach Programmstart anders aus

  Alt 5. Dez 2006, 13:37
lad bitte mal das form und die unit hoch...

mfg
Tobias
It's not a bug, it's a feature.
  Mit Zitat antworten Zitat
Benutzerbild von -=cats=-
-=cats=-

Registriert seit: 22. Sep 2006
128 Beiträge
 
Delphi 7 Enterprise
 
#10

Re: Form sieht nach Programmstart anders aus

  Alt 5. Dez 2006, 13:41
Hier ist mal mein ganzer Ordner
Habe nen LMDShapeButton auf der Form.
Nur falls Du kein LMD hast ...

Habe es jetzt nochmal mit einem anderen Formular
gemacht und dann ging es ... komisch ...
Angehängte Dateien
Dateityp: rar 6-eckiges_fenster_215.rar (212,1 KB, 5x aufgerufen)
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 06:10 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf