AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi Locate mit zusammengesetzten Schlüssel und Nullwerten

Locate mit zusammengesetzten Schlüssel und Nullwerten

Ein Thema von needatip · begonnen am 22. Jan 2007 · letzter Beitrag vom 23. Jan 2007
Antwort Antwort
needatip

Registriert seit: 11. Jan 2004
246 Beiträge
 
Delphi 10.4 Sydney
 
#1

Locate mit zusammengesetzten Schlüssel und Nullwerten

  Alt 22. Jan 2007, 21:28
Datenbank: MS SQL Server • Version: 2000 • Zugriff über: ADO
Hallo Dpler,
ich suche in einer Tabelle mit zusammengesetzem Schlüssel die Werte PosNr und Apos.
PosNr ist ein Integer Feld und Apos ein String Feld.

PosQuery.Locate('POSNR;APOS', VarArrayOf([JvCSVDataSet1.FieldByName('POS_NR').AsInteger, JvCSVDataSet1.FieldByName('A_POS').AsString]), []); wobei das Feld APOS auch NULL Werte enthalten darf.
Leider findet locate die Datensätze mit diesen Nullwerten nicht.
Gibt es hier eine Lösung?
  Mit Zitat antworten Zitat
jbg

Registriert seit: 12. Jun 2002
3.483 Beiträge
 
Delphi 10.1 Berlin Professional
 
#2

Re: Locate mit zusammengesetzten Schlüssel und Nullwerten

  Alt 22. Jan 2007, 23:02
Probiere es doch mal mit FieldByName('A_POS').AsVariant. Das AsString macht nämlich aus NULL einen Leerstring.
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
17.174 Beiträge
 
Delphi 10.4 Sydney
 
#3

Re: Locate mit zusammengesetzten Schlüssel und Nullwerten

  Alt 23. Jan 2007, 06:09
Und wieso willst Du mit Locate vorgehen? Bau dir doch einen entsprechende Query zusammen und lass dir ein angepaßtes Suchergebnis liefern.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
needatip

Registriert seit: 11. Jan 2004
246 Beiträge
 
Delphi 10.4 Sydney
 
#4

Re: Locate mit zusammengesetzten Schlüssel und Nullwerten

  Alt 23. Jan 2007, 08:49

Ja, du hast recht. Hab es auch so gemacht.
Einziger Fehler war, dass im Feld APos Leerstrings vorhanden waren und keine Null-Werte.
Jetzt funktionierts einwandfrei.
Danke nochmal.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 20:01 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz