AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke Delphi TWebBrowser -> Verknüpfung Kopieren

TWebBrowser -> Verknüpfung Kopieren

Ein Thema von Wadim · begonnen am 19. Sep 2003 · letzter Beitrag vom 19. Sep 2003
Antwort Antwort
Wadim

Registriert seit: 31. Aug 2003
185 Beiträge
 
#1

TWebBrowser -> Verknüpfung Kopieren

  Alt 19. Sep 2003, 16:29
hi,

hab folgendes problem:

habe einen internet browser womit ich die seiten mit einem edit text öffnen kann- klapt alles aber jetzt hab ich ein kleines problem!

wenn ich z.b eine internet seite mit meinem 'TWebBrowser' öffne und dann mit rechter taste auf einen button klicken, der mich auf eine andere oder nächste seite bringen soll, und dann auf verknüpfung kopieren gehe und sie kopiere- sie danach in ein edit text oder was anderes einfügen will geht es nicht , heißt er kopiert es nicht- und wenn ich dann auch auf einen button klicke öffnet er mir die seite mir dem normalen internet explorer (standart)- woran kann es liegen?

benutze folgenden befehl:


procedure TForm1.Button1Click(Sender: TObject);
var flag : olevariant;
begin
flag := 14;
webbrowser1.navigate (edit1.text) , Flag);
end;

end.

danke für hilfe
  Mit Zitat antworten Zitat
Alexander

Registriert seit: 28. Aug 2002
Ort: Oldenburg
3.513 Beiträge
 
Turbo Delphi für .NET
 
#2

Re: TWebBrowser -> Verknüpfung Kopieren

  Alt 19. Sep 2003, 16:43
Probier mal ganz am Ende deines Quellcodes das hier zu schreiben:
Delphi-Quellcode:
initialization
  OleInitialize(nil);

finalization
  OleUninitialize;
end.
Alexander
  Mit Zitat antworten Zitat
Wadim

Registriert seit: 31. Aug 2003
185 Beiträge
 
#3

Re: TWebBrowser -> Verknüpfung Kopieren

  Alt 19. Sep 2003, 16:52
Zitat von alexander:
Probier mal ganz am Ende deines Quellcodes das hier zu schreiben:
Delphi-Quellcode:
initialization
  OleInitialize(nil);

finalization
  OleUninitialize;
end.
also erstens:

hinter end; diese anweisung?

zweitens:

hab beides probiert hinter end; und vor aber hat immer angezeigt das, dass ein undefinierter bezeichner ist (oleintilialize und oleintialize)
  Mit Zitat antworten Zitat
Alexander

Registriert seit: 28. Aug 2002
Ort: Oldenburg
3.513 Beiträge
 
Turbo Delphi für .NET
 
#4

Re: TWebBrowser -> Verknüpfung Kopieren

  Alt 19. Sep 2003, 17:03
Auch ActiveX eingebunden?
Es muss vor dem end.
Alexander
  Mit Zitat antworten Zitat
Wadim

Registriert seit: 31. Aug 2003
185 Beiträge
 
#5

Re: TWebBrowser -> Verknüpfung Kopieren

  Alt 19. Sep 2003, 17:04
Zitat von alexander:
Auch ActiveX eingebunden?
Es muss vor dem end.
nein- wie geht das?
  Mit Zitat antworten Zitat
Alexander

Registriert seit: 28. Aug 2002
Ort: Oldenburg
3.513 Beiträge
 
Turbo Delphi für .NET
 
#6

Re: TWebBrowser -> Verknüpfung Kopieren

  Alt 19. Sep 2003, 17:12
In der Uses-Klausel ganz oben musst du ActiveX mit aufnehmen...
Oder was meintest du?
Alexander
  Mit Zitat antworten Zitat
Wadim

Registriert seit: 31. Aug 2003
185 Beiträge
 
#7

Re: TWebBrowser -> Verknüpfung Kopieren

  Alt 19. Sep 2003, 17:22
Zitat von alexander:
In der Uses-Klausel ganz oben musst du ActiveX mit aufnehmen...
Oder was meintest du?
wie mach ich das- mus ich einfach aktivx eigeben oder einen bestimmten komponenten einfügen (ins formblatt) oder was genau?
  Mit Zitat antworten Zitat
Alexander

Registriert seit: 28. Aug 2002
Ort: Oldenburg
3.513 Beiträge
 
Turbo Delphi für .NET
 
#8

Re: TWebBrowser -> Verknüpfung Kopieren

  Alt 19. Sep 2003, 17:50
So:
Delphi-Quellcode:
uses
 SysUtils, ..., ActiveX
Alexander
  Mit Zitat antworten Zitat
Wadim

Registriert seit: 31. Aug 2003
185 Beiträge
 
#9

Re: TWebBrowser -> Verknüpfung Kopieren

  Alt 19. Sep 2003, 18:00
juuhhhhuuuuuuu- es funktioniert

großen dank an dich
  Mit Zitat antworten Zitat
Alexander

Registriert seit: 28. Aug 2002
Ort: Oldenburg
3.513 Beiträge
 
Turbo Delphi für .NET
 
#10

Re: TWebBrowser -> Verknüpfung Kopieren

  Alt 19. Sep 2003, 18:36
GErn geschehen!
Alexander
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 14:42 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz