AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Sprachen und Entwicklungsumgebungen Object-Pascal / Delphi-Language Delphi Probleme beim Installieren eines Packages.

Probleme beim Installieren eines Packages.

Ein Thema von daredd · begonnen am 17. Jul 2008 · letzter Beitrag vom 18. Jul 2008
Antwort Antwort
daredd

Registriert seit: 2. Apr 2006
433 Beiträge
 
#1

Probleme beim Installieren eines Packages.

  Alt 17. Jul 2008, 19:16
Hallo,

ich habe ein Package das unter Delphi6 wunderbar installiert werden kann, also ohne Fehlermeldungen. Nun habe ich Delphi2007 und probier das Package zu Installieren, da kommt aber eine Fehlermedldung unter den requires. Undzwar hat mir der Compiler ausgegeben das ihm die qrtp.dcp fehlt.

Nun habe ich einfach aus der Delphi6\lib die qrpt.dcp genommen und in die delphi2007\lib gepackt.

Jetzt schreibt mir der Compiler folgendes:

[DCC Fehler] NLScomps.dpk(47): F2141 Falsches Dateiformat: 'c:\program files\codegear\rad studio\5.0\lib\qrpt.dcp'

und was soll ich damit? Welches Dateiformat wird jetzt in Delphi2007 verwendet?


Das ist ein bisschen code, die Stelle wo der Compiler meckert:
Delphi-Quellcode:
requires
  rtl,
  vcl,
  dbrtl,
  vclx,
  vcljpg,
  vcldb,
  bdertl,
  VclSmp,
  qrpt; // hier ist das Problem!!
Weiss da einer was zu?
THX

Also ich habe mal gegoogelt und rausgefunden das man das QR502PDW322007.EXE braucht. Dort ist dann das Package drin.
Aber auf der seite von QuickReports kann man das nur mit Seriennummer und PW runterladen, gehts auch anders?
---------------------------------------------------------------------------
Mein Vista-Kind bringt frischen Wind

Gruß DaRedd aka The Red Dragon
  Mit Zitat antworten Zitat
Benutzerbild von SirThornberry
SirThornberry
(Moderator)

Registriert seit: 23. Sep 2003
Ort: Bockwen
12.235 Beiträge
 
Delphi 2006 Professional
 
#2

Re: Probleme beim Installieren eines Packages.

  Alt 17. Jul 2008, 19:58
Das Format ändert sich von Delphiversion zu Delphiversion eigentlich immer. Schmeiß dieses Request einfach mal raus und schau was dir ausgegeben wird. Ich kenne es so das dann eine Meldung kommt was benötigt wird wo man nur noch auf ok klicken muss.
Jens
Mit Source ist es wie mit Kunst - Hauptsache der Künstler versteht's
  Mit Zitat antworten Zitat
Benutzerbild von RavenIV
RavenIV

Registriert seit: 12. Jan 2005
Ort: Waldshut-Tiengen
2.875 Beiträge
 
Delphi 2007 Enterprise
 
#3

Re: Probleme beim Installieren eines Packages.

  Alt 18. Jul 2008, 09:08
Das Problem wird sein, dass bei D2007 der QuickReport nicht mehr standardmässig dabei ist.
Man kann ihn als registrierter User bei CodeGear für D2007 runterladen und nachinstallieren.

Meistens gilt aber:
Eine Komponente, die in D6 funktioniert hat, funktioniert in D2007 ohne mittlere bis grössere Anpassungen nicht mehr. Schau also lieber, ob es eine aktualisierte Version der Komponente gibt.
Klaus E.
Linux - das längste Text-Adventure aller Zeiten...
Wer nie Linux mit dem vi konfiguriert hat, der hat am Leben vorbei geklickt.
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.654 Beiträge
 
Delphi 10.4 Sydney
 
#4

Re: Probleme beim Installieren eines Packages.

  Alt 18. Jul 2008, 09:34
Zitat:
Eine Komponente, die in D6 funktioniert hat, funktioniert in D2007 ohne mittlere bis grössere Anpassungen nicht mehr. Schau also lieber, ob es eine aktualisierte Version der Komponente gibt.
Das stimmt zum Glück nicht. Das manche Komponenten beim Versionswechsel nicht abwärtskompatibel sind hat nichts mit der Delphiversion zu tun
Markus Kinzler
  Mit Zitat antworten Zitat
Benutzerbild von RavenIV
RavenIV

Registriert seit: 12. Jan 2005
Ort: Waldshut-Tiengen
2.875 Beiträge
 
Delphi 2007 Enterprise
 
#5

Re: Probleme beim Installieren eines Packages.

  Alt 18. Jul 2008, 09:38
Zitat von mkinzler:
Das stimmt zum Glück nicht. Das manche Komponenten beim Versionswechsel nicht abwärtskompatibel sind hat nichts mit der Delphiversion zu tun
Hab ich auch nicht behauptet.
Klaus E.
Linux - das längste Text-Adventure aller Zeiten...
Wer nie Linux mit dem vi konfiguriert hat, der hat am Leben vorbei geklickt.
  Mit Zitat antworten Zitat
Muetze1
(Gast)

n/a Beiträge
 
#6

Re: Probleme beim Installieren eines Packages.

  Alt 18. Jul 2008, 15:11
Moin!

Zitat von RavenIV:
Man kann ihn als registrierter User bei CodeGear für D2007 runterladen und nachinstallieren.
Diese Aussage trifft nur bis BDS2006 zu. Bei RAD2007 sind diese auch nicht mehr zum Download verfügbar. CodeGear hatte deshalb extra eine befristete Aktion mit RAD2007 zusammen mit QR Standard zum gleichen Preis.

MfG
Muetze1
  Mit Zitat antworten Zitat
Benutzerbild von RavenIV
RavenIV

Registriert seit: 12. Jan 2005
Ort: Waldshut-Tiengen
2.875 Beiträge
 
Delphi 2007 Enterprise
 
#7

Re: Probleme beim Installieren eines Packages.

  Alt 18. Jul 2008, 16:23
Zitat von Muetze1:
Zitat von RavenIV:
Man kann ihn als registrierter User bei CodeGear für D2007 runterladen und nachinstallieren.
Diese Aussage trifft nur bis BDS2006 zu. Bei RAD2007 sind diese auch nicht mehr zum Download verfügbar. CodeGear hatte deshalb extra eine befristete Aktion mit RAD2007 zusammen mit QR Standard zum gleichen Preis.
Dann schau mal hier: http://cc.codegear.com/item/25002

Zitat von obiger Seite:
-------------------
...
...
QuickReport 4 Standard download for registered Delphi users
...
...
To download this, you must have registered [one of]:
Borland Developer Studio 2006 - Architect edition
...
Delphi 2007 for Win32 Professional
...
CodeGear RAD Studio 2007 Architect
...
...
...
This file is a registered user download for Borland Developer Studio 2006 users and can also be used with Delphi 2007 for Win32.
...
...
-------------------
Klaus E.
Linux - das längste Text-Adventure aller Zeiten...
Wer nie Linux mit dem vi konfiguriert hat, der hat am Leben vorbei geklickt.
  Mit Zitat antworten Zitat
Muetze1
(Gast)

n/a Beiträge
 
#8

Re: Probleme beim Installieren eines Packages.

  Alt 18. Jul 2008, 16:36
Moin!

Na toll, das ist ja mal wieder CodeGear typisch. Einem das erst schmackhaft machen um neue Lizenzen zu kaufen, weil es früher nicht mit bei war und nun umsonst abgeben.

Deutscher CodeGear Support hatte einem früher was ganz anderes erzählt. Wieder was gelernt und wieder mal verarscht von CodeGear.

MfG
Muetze1
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 21:51 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf