AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Problem mit Indy HTTP (IdHTTP), Bug?

Ein Thema von luke2 · begonnen am 24. Sep 2009 · letzter Beitrag vom 25. Sep 2009
Antwort Antwort
luke2

Registriert seit: 17. Jun 2009
117 Beiträge
 
#1

Problem mit Indy HTTP (IdHTTP), Bug?

  Alt 24. Sep 2009, 20:59
Hallo,

Folgendes:
Ich sende mit der Indy HTTP Kompo. (IdHTTP) einen POST-Request an eine Seite und bekomme einen 302 Redirect (HandleRedirects ist aktiviert) zurück.
Anstatt jetzt die Seite, auf die der Redirect erfolgt wieder normal mit einem GET-Request aufzurufen, wird nochmal dasselbe gepostet.

Kann man der Kompo. beibringen die Daten nur einmal zu posten und alles was danach kommt wieder zu getten, so wie es sein soll?

Danke!
  Mit Zitat antworten Zitat
Klaus01

Registriert seit: 30. Nov 2005
Ort: München
5.541 Beiträge
 
Delphi 10.3 Rio
 
#2

Re: Problem mit Indy HTTP (IdHTTP), Bug?

  Alt 24. Sep 2009, 21:08
.. nur der Vollständigkeit halber:

Welche Indy Version?

Grüße
Klaus
Klaus
  Mit Zitat antworten Zitat
luke2

Registriert seit: 17. Jun 2009
117 Beiträge
 
#3

Re: Problem mit Indy HTTP (IdHTTP), Bug?

  Alt 24. Sep 2009, 21:29
Die Version, die mit D2010 mitgeliefert wird, ich denke mal, das ist die neueste.
  Mit Zitat antworten Zitat
Benutzerbild von Assertor
Assertor

Registriert seit: 4. Feb 2006
Ort: Hamburg
1.296 Beiträge
 
Delphi 10 Seattle Enterprise
 
#4

Re: Problem mit Indy HTTP (IdHTTP), Bug?

  Alt 24. Sep 2009, 22:05
Hi,

Zitat von luke2:
Anstatt jetzt die Seite, auf die der Redirect erfolgt wieder normal mit einem GET-Request aufzurufen, wird nochmal dasselbe gepostet.

Kann man der Kompo. beibringen die Daten nur einmal zu posten und alles was danach kommt wieder zu getten, so wie es sein soll?
Ist kein Bug. 302 Redirect (eigentlich Found) ist es nach RFC 1945 und 2068 untersagt, die Methode bei einem Redirect zu ändern. Indy hält sich nur daran. Ich weiß nicht woher Deine Annahme kommt, dies sei ein Bug.

Gruß Assertor
Frederik
Assertor
Embarcadero Tech Partner & Indy Team (OpenSSL). Bitte keine Supportanfragen per PN!
  Mit Zitat antworten Zitat
luke2

Registriert seit: 17. Jun 2009
117 Beiträge
 
#5

Re: Problem mit Indy HTTP (IdHTTP), Bug?

  Alt 24. Sep 2009, 22:24
Danke schonmal, die genaue Antwort vom Server heißt "HTTP/1.x 302 Found".
Ich wusste nicht genau, ob es ein Bug ist, ich hab mich nur an Firefox + Live HTTP Headers gerichtet und da wird nach dem posten nur noch "gegettet".

Ich habe jetzt vorerst so gelöst, indem ich im OnRedirect Event die Header und Postdaten manuell resette.
Ist zwar nicht so schön, aber klappt.
  Mit Zitat antworten Zitat
Benutzerbild von Assertor
Assertor

Registriert seit: 4. Feb 2006
Ort: Hamburg
1.296 Beiträge
 
Delphi 10 Seattle Enterprise
 
#6

Re: Problem mit Indy HTTP (IdHTTP), Bug?

  Alt 25. Sep 2009, 12:18
Hi luke2,

Zitat von luke2:
Danke schonmal, die genaue Antwort vom Server heißt "HTTP/1.x 302 Found".
Ich wusste nicht genau, ob es ein Bug ist, ich hab mich nur an Firefox + Live HTTP Headers gerichtet und da wird nach dem posten nur noch "gegettet".
Ist ja kein Problem, wollte nur darauf hinweisen, dass es so wie es Indy macht korrekt ist.

Zitat von luke2:
Ich habe jetzt vorerst so gelöst, indem ich im OnRedirect Event die Header und Postdaten manuell resette.
Ist zwar nicht so schön, aber klappt.
Ich finde die Lösung ok, schießlich weichst Du beim Redirect bewußt vom Standard-Verhalten ab. Der genutzt Event ist richtig und die Umsetzung auch, also sehe ich da keine Probleme.

Gruß Assertor
Frederik
Assertor
Embarcadero Tech Partner & Indy Team (OpenSSL). Bitte keine Supportanfragen per PN!
  Mit Zitat antworten Zitat
luke2

Registriert seit: 17. Jun 2009
117 Beiträge
 
#7

Re: Problem mit Indy HTTP (IdHTTP), Bug?

  Alt 25. Sep 2009, 12:49
OK, Danke nochmal.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 23:33 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf