Einzelnen Beitrag anzeigen

Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
7.551 Beiträge
 
Delphi 10.3 Rio
 
#13

AW: Oberbegriff für Enable/Disable

  Alt 22. Mai 2020, 12:11
Also ich würde, wenn es geht, immer dem Object die Property "enable" geben
Du meinst Enabled, oder? Denn enable ist ja ein Verb und somit der Befehl etwas zu aktivieren. Genauso ist enableBottomPanel zum Deaktivieren per Parameter nicht intuitiv.

Du sagst ja auch nicht zu jemandem:
Schalte mal bitte den Lichtschalter ein und setze den Wert auf aus.

Um hier unnötige Irritationen und damit unnötigen Aufwand zu vermeiden ist es wichtig, dass man darauf achtet, dass die Benennung auch sprachlich korrekt ist und nicht nur Worte aus dem Englischen verwendet.

Besser wäre also z.B. SetBottomPanelEnabled(AValue).
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat