AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken ADO Zugriff auf DBase Datei unter Windows 7

ADO Zugriff auf DBase Datei unter Windows 7

Ein Thema von Piro · begonnen am 12. Nov 2010 · letzter Beitrag vom 12. Nov 2010
Antwort Antwort
Benutzerbild von Piro
Piro

Registriert seit: 14. Jul 2003
Ort: Flintbek
810 Beiträge
 
Delphi XE2 Professional
 
#1

ADO Zugriff auf DBase Datei unter Windows 7

  Alt 12. Nov 2010, 19:00
Datenbank: DBF • Version: ?? • Zugriff über: ADO
Moin zusammen,

ich habe ein kleines Programm, welches eine DBase Datei einliest (kein Schreibzugriff). Dies funktioniert auch wunderbar unter WinXP. Auf meinem Windows 7 und einem neueren Windows XP Rechner geht es leider nicht mehr.

Mit dem folgenden Code, erhalte ich die Fehlermeldung (siehe Anhang).
Delphi-Quellcode:
ADOConnection.ConnectionString := 'Provider=MSDASQL.1;Persist Security Info=False;Data Source=dBASE Files;Initial Catalog='+outdir;
ADOConnection.Connected := True; // --> hier kommt der Fehler
Ich habe im Internet recheriert und folgendes schon gemacht.
1. Treiber neuregistriert (C:\Program Files\Common Files\System\Ole DB\msdasql.dll)
2. Versucht MDAC neu zu installieren, doch leider ohne Erfolg.

Irgendwie fehlt im der Treiber. Aber welchen brauche ich.
Leider habe ich keine Ahnung mehr, wie ich das Problem lösen soll.

Wäre schön, wenn einer noch ne Idee oder einen Hinweis hat.

Gruß, Sven
Miniaturansicht angehängter Grafiken
fehler.png  
  Mit Zitat antworten Zitat
Benutzerbild von Piro
Piro

Registriert seit: 14. Jul 2003
Ort: Flintbek
810 Beiträge
 
Delphi XE2 Professional
 
#2

AW: ADO Zugriff auf DBase Datei unter Windows 7

  Alt 12. Nov 2010, 19:05
Upps, da war ich doch etwas zu schnell mit dem Thread. Habe es nun gefunden.

Ich verwende jetzt folgenden Code:
Delphi-Quellcode:
ADOConnection.ConnectionString := 'Provider=Microsoft.Jet.OLEDB.4.0;Data Source='+outdir+';Extended Properties=dBase 5.0;Persist Security Info=False';
ADOConnection.Open;
Damit funktioniert es bestens. Vielleicht wisst ja trotzdem warum, der andere Treiber nicht geht.

Dank im Voraus.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 15:54 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf