AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Indy Thread

Ein Thema von nru · begonnen am 28. Mär 2013 · letzter Beitrag vom 29. Mär 2013
Antwort Antwort
Seite 1 von 2  1 2   
nru

Registriert seit: 30. Mai 2008
Ort: Bonn
40 Beiträge
 
Delphi 7 Enterprise
 
#1

Indy Thread

  Alt 28. Mär 2013, 15:32
Hallo ihr,

hat das seine Richtigkeit, dass der von Indy 10 für die Connection aufgemachte Thread auch nach FreeAndNil() bestehen bleibt? Denn nach der folgenden proc zeigt mit der Taskmanager 2 Threads für den Prozess an. Ich würde aber erwarten bzw. davon ausgehen, dass der Thread auch wieder beendet wird.
Hintergrund der Frage ist, dass ein fortlaufender http-Abruf eines RSS-Feeds in einem anderen Projekt massig Threads produziert. Dem wollte ich mal auf den Grund gehen.

Delphi-Quellcode:
procedure TForm1.Button3Click(Sender: TObject);
var
  FHTTP: TIdHTTP;
begin

  FHTTP := TidHTTP.Create( nil );
  try
    try
      FHTTP.Head( 'http://www.chip.de' );
      if (FHTTP.ResponseCode <> 200) then begin
        raise Exception.Create( 'Probleme mit dem Netz! Fehler: ' + FHTTP.ResponseText );
      end;
      memo1.Lines.add( 'Abruf erfolgreich' );
    except
      on E:Exception do begin
        memo1.Lines.add( 'Abruf NICHT erfolgreich' );
        Delay(500);
      end;
    end;
  finally
    FHTTP.Disconnect;
  end;
  FreeAndNil( FHTTP );
end;
  Mit Zitat antworten Zitat
mjustin

Registriert seit: 14. Apr 2008
2.768 Beiträge
 
Delphi 2009 Professional
 
#2

AW: Indy Thread

  Alt 28. Mär 2013, 16:54
IdHTTP.Head erzeugt keinen Thread, es wird im Kontext des aufrufenden Threads ausgeführt (Request und Response) - wird der zweite Thread in der IDE Threaddarstellung angezeigt? p.s. das Disconnect kann weggelassen werden.
Michael Justin
  Mit Zitat antworten Zitat
nru

Registriert seit: 30. Mai 2008
Ort: Bonn
40 Beiträge
 
Delphi 7 Enterprise
 
#3

AW: Indy Thread

  Alt 28. Mär 2013, 17:32
wird der zweite Thread in der IDE Threaddarstellung angezeigt?
Ja, wird er. Es gibt einen Thread vor und zwei nach .Head :/

Das Disconnect war nur zum Test da drin (wie überhaupt die ganze Routine nur zum Text existiert )
  Mit Zitat antworten Zitat
mjustin

Registriert seit: 14. Apr 2008
2.768 Beiträge
 
Delphi 2009 Professional
 
#4

AW: Indy Thread

  Alt 28. Mär 2013, 17:38
wird der zweite Thread in der IDE Threaddarstellung angezeigt?
Ja, wird er. Es gibt einen Thread vor und zwei nach .Head :/
ProcessExplorer und IDE zeigt bei mir nur einen Thread an. Wann genau wird der zweite Thread angezeigt, bei einem Breakpoint auf die nächste Zeile?

Allerdings habe ich die Delay Funktion auskommentieren müssen (in Delphi 2009 habe ich sie nicht gefunden). Kann es an ihr liegen?
Michael Justin
  Mit Zitat antworten Zitat
nru

Registriert seit: 30. Mai 2008
Ort: Bonn
40 Beiträge
 
Delphi 7 Enterprise
 
#5

AW: Indy Thread

  Alt 28. Mär 2013, 17:56
Ich sehe sowohl in der IDE als auch im Taskmanager und auch im ProcessExplorer zwei Threads (siehe Anhänge).
Sehr komische Sache. Irgenwas mit einer CS

Breakpoint vor und nach .Head und wie gesagt, vorher einer, nachher zwei Threads.
Miniaturansicht angehängter Grafiken
p1.png   p2.png  
  Mit Zitat antworten Zitat
mjustin

Registriert seit: 14. Apr 2008
2.768 Beiträge
 
Delphi 2009 Professional
 
#6

AW: Indy Thread

  Alt 28. Mär 2013, 18:13
Ich sehe sowohl in der IDE als auch im Taskmanager und auch im ProcessExplorer zwei Threads (siehe Anhänge).
Das müssten dann aber drei Screenshots sein.
Ich sehe in allen drei (IDE Thread Status, Taskmanager, ProcessExplorer) nur einen Thread...

Was mir noch einfallen würde:

* madExcept oder EurekaLog aktiv?
* Indy 10.5.9 (frisch aus dem Subversion Repository)?
* Delay entfernt?
* (falls alles nicht hilft) Rechner ein- und wieder ausgeschaltet
Michael Justin

Geändert von mjustin (28. Mär 2013 um 18:34 Uhr)
  Mit Zitat antworten Zitat
nru

Registriert seit: 30. Mai 2008
Ort: Bonn
40 Beiträge
 
Delphi 7 Enterprise
 
#7

AW: Indy Thread

  Alt 28. Mär 2013, 18:49
Zitat:
Das müssten dann aber drei Screenshots sein.
Wohl wahr ... sind es jetzt auch
Delay? Da steh ich grad etwas auf dem Schlauch. Was meinst Du damit? Rechnerstart hatte ich gerade eben erst, aber frische Indy-Files könnt ich mir mal holen.
Miniaturansicht angehängter Grafiken
p3.png  
  Mit Zitat antworten Zitat
mjustin

Registriert seit: 14. Apr 2008
2.768 Beiträge
 
Delphi 2009 Professional
 
#8

AW: Indy Thread

  Alt 28. Mär 2013, 19:38
Delay? Da steh ich grad etwas auf dem Schlauch. Was meinst Du damit?

Siehe oben - das Delay(500) ist meinem Delphi 2009 unbekannt:

Delphi-Quellcode:
    
    except
      on E:Exception do begin
        memo1.Lines.add( 'Abruf NICHT erfolgreich' );
        Delay(500); <--------
      end;
    end;
Aber wenn der Breakpoint direkt nach dem Head steht ist er vermutlich nicht relevant.

Wenn es mit neuem Indy immer noch zwei Threads werden, würde ich in die Indy Source Verzeichnisse (Core, System und Protocols) hineindebuggen um den Punkt zu finden, an dem der zweite Thread entsteht.
Michael Justin
  Mit Zitat antworten Zitat
nru

Registriert seit: 30. Mai 2008
Ort: Bonn
40 Beiträge
 
Delphi 7 Enterprise
 
#9

AW: Indy Thread

  Alt 28. Mär 2013, 19:46
achsoooo!
Das ist eine "Haltestelle" hier aus der CodeLib (zumindest rudimentär). 500 ms warten (Komm grad nicht an die Sourcen, anderer Rechner, sonst würd ich's posten).

Hat hier aber keine Bedeutung und macht aber auch keinen Unterschied, denn der zweite Thread wird definitiv früher - .Head (oder auch .get()) - erstellt.
  Mit Zitat antworten Zitat
nru

Registriert seit: 30. Mai 2008
Ort: Bonn
40 Beiträge
 
Delphi 7 Enterprise
 
#10

AW: Indy Thread

  Alt 29. Mär 2013, 07:40
Hab jetzt erstmal ohne neue Sourcen dort "hineindebug't" und interessante Dinge feststellen müssen.

Folgende Situation:
Über DoRequest und ConnectToHost und CheckAndConnect landet man beim Connect.

Dort nimmt das dann seinen Lauf über IOHandler.Open -> ConnectClient -> ResolveHost -> HostByName -> Getaddrinfo!
Bähm, zweiter Thread (CallStack im Anhang)


Vielleicht ist's dann doch eher ein OS-Thema?
(Läuft hier auf Win7 Ultimate 32bit mit IPv4)

EDIT: Sehe gerade, das ich schon 10.5.9 (build 4885) im Einsatz habe! Ob's sich lohnt, mit dem aktuellen Build 4972 zu testen?
Miniaturansicht angehängter Grafiken
p4.png  

Geändert von nru (29. Mär 2013 um 08:18 Uhr)
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 13:14 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf