AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi ZEOS 7.0.4 in XE2 installieren

ZEOS 7.0.4 in XE2 installieren

Ein Thema von Codehunter · begonnen am 15. Jul 2013 · letzter Beitrag vom 16. Jul 2013
Antwort Antwort
Benutzerbild von Codehunter
Codehunter

Registriert seit: 3. Jun 2003
Ort: Thüringen
2.246 Beiträge
 
Delphi 10.4 Sydney
 
#1

ZEOS 7.0.4 in XE2 installieren

  Alt 15. Jul 2013, 13:22
Datenbank: ZEOS • Version: 7.0.4 • Zugriff über: ZEOS
Hallo!

Ich versuche mich gerade daran, die ZEOS 7.0.4 im XE2 zu installieren. Ich halte mich genau an die Anweisungen install.html und bekomme dann beim Compilieren der ZComponentDesign.bpl folgende Fehlermeldung:
Zitat:
ZComponentReg entfernen.
Es wurde(n) die Unit(s) ZComponentReg im benötigten Package 0 gefunden.
Wäre ja erstmal nicht so wild, wenn mir der Laden denn mal verraten würde in welchem anderen Package die Unit noch verlinkt wäre. Aber ein Package "0" kann ich leider auf dem ganzen System nicht finden

Nachdem man die ZComponentReg entfernt hat compiliert das Package zwar, aber nach dem Installieren hat man logischerweise keine Komponenten davon registriert.

Nachtrag: Entferne ich beim ZComponentDesign.dpk die ZComponent aus der Requires-Liste, dann erscheint die Fehlermeldung nicht, sondern der Compiler steigt dann irgendwann wegen nicht gefundener Units aus. Insofern nachvollziehbar. Nur seltsamerweise ist die ZComponentReg.pas im ZComponent.dpk gar nicht enthalten.

Grüße
Cody
Ich mache grundsätzlich keine Screenshots. Schießen auf Bildschirme gibt nämlich hässliche Pixelfehler und schadet der Gesundheit vom Kollegen gegenüber. I und E zu vertauschen hätte den selben negativen Effekt, würde aber eher dem Betriebsklima schaden

Geändert von Codehunter (15. Jul 2013 um 13:38 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von RWarnecke
RWarnecke

Registriert seit: 31. Dez 2004
Ort: Stuttgart
4.408 Beiträge
 
Delphi XE8 Enterprise
 
#2

AW: ZEOS 7.0.4 in XE2 installieren

  Alt 15. Jul 2013, 17:52
Eine dumme Frage: Hast Du die Pfade entsprechend bei 32Bit-Library und 64 Bit-Library eingetragen ? Ich habe die Zeos 7.0.4 unter 2009 installiert bekommen.
Rolf Warnecke
App4Mission
  Mit Zitat antworten Zitat
Benutzerbild von Codehunter
Codehunter

Registriert seit: 3. Jun 2003
Ort: Thüringen
2.246 Beiträge
 
Delphi 10.4 Sydney
 
#3

AW: ZEOS 7.0.4 in XE2 installieren

  Alt 15. Jul 2013, 18:24
Hat sich jetzt aufgeklärt. War was total verrücktes: Im %PATH% von Windows war noch ein Pfad auf das Projects-Verzeichnis von Delphi 5 (!!!) eingetragen, was ich schon lang nicht mehr installiert habe. Der Pfad war aber noch mit ein paar Altdateien bestückt, darunter eben auch einer Uralt-Version von ZEOS. Ich glaub das letzte Projekt habe ich 2011 von D5 auf D7 migriert und jetzt holen mich die Altlasten wieder ein

Schön ist jetzt, im Vergleich zur vorherigen ZEOS 7.0.3, dass es sich auch problemlos für 64 Bit kompilieren lässt. Da gabs bis dato noch Problemchen bei mir.
Ich mache grundsätzlich keine Screenshots. Schießen auf Bildschirme gibt nämlich hässliche Pixelfehler und schadet der Gesundheit vom Kollegen gegenüber. I und E zu vertauschen hätte den selben negativen Effekt, würde aber eher dem Betriebsklima schaden
  Mit Zitat antworten Zitat
Benutzerbild von Codehunter
Codehunter

Registriert seit: 3. Jun 2003
Ort: Thüringen
2.246 Beiträge
 
Delphi 10.4 Sydney
 
#4

AW: ZEOS 7.0.4 in XE2 installieren

  Alt 16. Jul 2013, 07:24
Kleiner Nachtrag noch: In meinem Fall hatte ich nach der Installation von ZEOS 7.0.4 in der IDE keine Property-Editoren mehr installiert. Das habe ich behoben, indem ich ZComponentDesign.bpl nochmal deinstalliert habe, dann die folgenden Änderungen an der ZComponentDesign.dpk vorgenommen und das Ganze nochmal neu installiert habe.
Delphi-Quellcode:
{$I '..\..\src\Zeos.inc'} // <-- Neu

requires
  dbrtl,
  designide,
  ZParseSql,
  ZCore,
  ZPlain,
  ZDbc,
  ZComponent;

contains
{$IFDEF WITH_PROPERTY_EDITOR}  // <-- Neu
  ZPropertyEditor in '..\..\src\component\ZPropertyEditor.pas', // <-- Neu
{$ENDIF}  // <-- Neu
  ZUpdateSqlEditor in '..\..\src\component\ZUpdateSqlEditor.pas{ZUpdateSQLEditForm},
  ZComponentReg in '..\..\src\component\ZComponentReg.pas';
Ich mache grundsätzlich keine Screenshots. Schießen auf Bildschirme gibt nämlich hässliche Pixelfehler und schadet der Gesundheit vom Kollegen gegenüber. I und E zu vertauschen hätte den selben negativen Effekt, würde aber eher dem Betriebsklima schaden
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 12:58 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf