AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

"Probleme" mit VirtualBox

Ein Thema von Popov · begonnen am 9. Okt 2013 · letzter Beitrag vom 10. Okt 2013
Antwort Antwort
Popov
(Gast)

n/a Beiträge
 
#1

"Probleme" mit VirtualBox

  Alt 9. Okt 2013, 17:14
Vielleicht hat einer da eine Lösung, ich hab da ständig ein kleines Problem mit VirtualBox.

Ich kann mich nicht mehr erinnern wie das bei VMWare war, aber da hatte ich diese Probleme nicht. Man hat die Einstellungen und die Festplatte in einen Ordner gespeichert und gut war es. Und änderte sich das Laufwerk, dann wurde es (soweit ich mich noch erinnern kann) einfach nur neu eingebunden.

So einfach klappt das aber nicht bei VirtualBox. Oder ich finde die Option nicht.

Einige meiner VMs liegen auf externen Festplatten, und das kann zu Problemen führen, denn gelegentlich ändert sich der Laufwerksbuchstabe. Ich hab mehrere externe Platten und wenn man die Reihenfolge nicht beachtet, dann wird schon mal der Laufwerksbuchstabe anders zugeordnet. Und plötzlich findet VirtualBox die virtuelle Festplatte nicht.

Das ist ja überhaupt das Problem, denn aus einem mir bisher unbekannten Grund speichert VirtualBox die Einstellungen lokal ab, dafür kann man beim virtuelle Laufwerken den Ort ändern. VMWare macht das anderes. Somit sind die Einstellungen und Laufwerke bei VirtualBox getrennt.

Aber das vordringlichste Problem bei mir ist, wie ich die VM nutzen kann, wenn das Laufwerk, wo die virtuelle Festplatte liegt, sich geändert hat?

Gibt es da eine Möglichkeit die ich einfach nur nicht finde?
  Mit Zitat antworten Zitat
Perlsau
(Gast)

n/a Beiträge
 
#2

AW: "Probleme" mit VirtualBox

  Alt 9. Okt 2013, 17:25
Um für ein bestimmtes USB-Laufwerk immer denselben Laufwerksbuchstaben zu erhalten, bin ich folgendermaßen vorgegangen:

1. USB-Laufwerk mit dem PC verbinden
2. Nachdem das Laufwerk angezeigt wird, in der Datenträgerverwaltung (in Computerverwaltung) den gewünschten Laufwerksbuchstaben ändern.

Bei mir funktioniert das seit Jahren unter XP und Win7 tadellos. Ich habe hier über 15 USB-Laufwerke, von denen ich einige ständig anschließe und abkopple, andere nur selten. Doch jedesmal hat das Laufwerk den zuletzt eingestellten Laufwerksbuchstaben – es sei denn, ich hab gerade 'n Stick oder 'ne Kamera angeschlossen, die einen dieser voreingestellten Laufwerksbuchstaben besetzt, dann wird diese Voreinstellung wieder gelöscht.
  Mit Zitat antworten Zitat
Popov
(Gast)

n/a Beiträge
 
#3

AW: "Probleme" mit VirtualBox

  Alt 9. Okt 2013, 17:40
Ja, das ist so möglich, aber...

...nicht wenn man man mit eingeschränkten Benutzerrechten arbeitet, da man dann eben nicht so ohne weiteres in die Computerverwaltung kann. Unmöglich ist natürlich nichts, aber da stellt sich gleich die Frage was weniger Aufwand ist - eben schnell die Computerverwaltung mit Adminrechten starten oder schnell ein Laufwerk vorschalten, damit die Reihenfolge wieder stimmt.

Natürlich hast du Recht, das System merkt sich in der Regel den letzten Buchstaben, aber nicht immer.
  Mit Zitat antworten Zitat
Lemmy

Registriert seit: 8. Jun 2002
Ort: Berglen
2.166 Beiträge
 
Delphi XE4 Professional
 
#4

AW: "Probleme" mit VirtualBox

  Alt 9. Okt 2013, 18:41
Hi,

das ist einer der Punkte, die mir an VBox nie gefallen hat. Bei VMWare liegt alles in einem Verzeichnis - zippen, sichern gut ist. Bei VBox hast Du halt dein Laufwerks-Verzeichnis in dem alle virtuellen HDD-Dateien liegen. Ich habe es damals nicht geschafft die auch in das eigentliche Config-Verzeichnis meiner virtuellen Maschine zu packen... Ist jetzt aber auch schon 3 Jahre her...

Grüße
  Mit Zitat antworten Zitat
Perlsau
(Gast)

n/a Beiträge
 
#5

AW: "Probleme" mit VirtualBox

  Alt 9. Okt 2013, 18:59
Ja, das ist so möglich, aber ... nicht wenn man man mit eingeschränkten Benutzerrechten arbeitet, da man dann eben nicht so ohne weiteres in die Computerverwaltung kann. Unmöglich ist natürlich nichts, aber da stellt sich gleich die Frage was weniger Aufwand ist - eben schnell die Computerverwaltung mit Adminrechten starten oder schnell ein Laufwerk vorschalten, damit die Reihenfolge wieder stimmt.
Selbstverständlich ist die Lösung mit der Datenträgerverwaltung mit weniger Aufwand verbunden, denn das mußt du nur einmal für jedes deiner Laufwerke, deren Buchstabe sich nicht ändern soll, einstellen. Und natürlich wählst du für solche USB-Laufwerke, deren LW-Buchstaben sich nicht ändern soll, eher einen Buchstaben am Ende der Reihe aus, denn der wird so schnell nicht automatisch vergeben. Zumindest gehe ich mal davon aus, daß sich kaum jemand neben seinen zwei oder drei internen Platten noch 20 USB-Laufwerke anschließt.

Für VirtualBox verwende ich inzwischen jedoch eine interne 2 TB Sataplatte, weil mir die USB-Laufwerke zu langsam sind.

Natürlich hast du Recht, das System merkt sich in der Regel den letzten Buchstaben, aber nicht immer.
Bei mir gab es diesbezüglich noch keine einzige Ausnahme außer der, daß der Laufwerksbuchstabe bereits besetzt ist, wenn ich z.B. gerade einen nicht zugewiesenen Stick oder eine meiner Kameras angeschlossen habe. Ich hab z.B. ein USB-Laufwerk, das immer am Rechner hängt und das immer ohne jede Ausnahme – und das seit Jahren und in einem Multiboot-System (XP & Win7) – immer den Laufwerksbuchstaben J erhält. Mein Backuplaufwerk ist immer N, mein Foto-Laufwerk immer M und auch alle anderen Laufwerke, denen ich einen festen LW-Buchstaben zugewiesen habe, zeigen diesen immer zuverlässig an. Voraussetzung wie gesagt: Du mußt in der Datenträgerverwaltung einmal den gewünschten LW-Buchstaben vergeben. Ich kann da keine Probleme erkennen.
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
7.266 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#6

AW: "Probleme" mit VirtualBox

  Alt 9. Okt 2013, 19:11
Das ändert aber alles nichts am eigentlichen Problem. Das hat mich bei VirtualBox auch immer gestört. Virtual PC konnte zwar nie viel, aber die Laufwerksverwaltung war dort deutlich besser gelöst...
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
jsheyer

Registriert seit: 9. Jun 2005
Ort: Jüchen
55 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#7

AW: "Probleme" mit VirtualBox

  Alt 10. Okt 2013, 13:35
Hallo,

dann gebe ich doch mal die Antwort auf Deine Frage
Also die VirtualBox starten (Das AdminTool), die Virtuelle Maschine auswählen, auf "Ändern" gehen.
Dann links Massenspeicher auswählen und anschliessend in der Mitte dann das virtuelle Laufwerk auswählen.
Ganz rechts wird z. B. "SATA Port 0" angezeigt, daneben ist ein kleinen Symbol daraufklicken es erscheint ein PopUp Menü.
Dort dann "Datei für virtuelle Platte auswählen" anklicken.
Nun einfach den neuen Pfad auswählen und voila, es geht wieder.

Ich hoffe das hilft Dir weiter.

Gruß Jörg
Jörg Heyer
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 10:19 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf