AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Android und diverse Samsung Geräte

Ein Thema von CHackbart · begonnen am 8. Jul 2014 · letzter Beitrag vom 9. Jul 2014
Antwort Antwort
CHackbart

Registriert seit: 22. Okt 2012
260 Beiträge
 
#1

Android und diverse Samsung Geräte

  Alt 8. Jul 2014, 17:15
Hallo,

vor geraumer Zeit habe ich ja den Daddo Player für Android und iOS veröffentlicht. Der Beliebtheitsfaktor hält sich arg in Grenzen, aber primär habe ich die Anwendung für mich entwickelt und somit ist das nicht sonderlich schlimm. Seit ein paar Tagen stehe ich in Kontakt mit dem QA Team von Samsung die wohl offenbar diverse Apps auf ihren auf Herz und Nieren mit bestimmten Geräten testen. Auf einigen Samsung Tablets scheint es komische Probleme zu geben, wenn die Applikation läuft und der Nutzer den Aus-Knopf drückt. Danach friert die Anwendung teilweise ein. Zuerst dachte ich es liegt an meinem Renderthread der im Hintergrund Zusatzinformationen lädt (Cover, Songdaten, Senderlogos) und dadurch - adäquat wie bei iOS Probleme entstehen können, sobald die Anwendung in aeEnteredBackground Modus fällt. Das überprüfe ich jedoch und da es bei iOS geht, denke ich liegt es nicht direkt daran. Konkret gibt es wohl nur ein Problem beim Galaxy S3 und selbst eine Testanwendung die lediglich ein ListView beinhaltet, verhält sich da genauso. Ist jemandem das Problem bekannt?

Konkret beschrieben ist das wie folgt:

Zitat:
1. Run the app
2. Press H/W Hold key without selecting any station
3. Press H/W Hold key again
4. Black screen
Christian

Geändert von CHackbart ( 8. Jul 2014 um 17:17 Uhr)
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.851 Beiträge
 
Delphi 11 Alexandria
 
#2

AW: Android und diverse Samsung Geräte

  Alt 8. Jul 2014, 17:22
Stelle am Besten die Testanwendung hier ein.
Markus Kinzler
  Mit Zitat antworten Zitat
CHackbart

Registriert seit: 22. Okt 2012
260 Beiträge
 
#3

AW: Android und diverse Samsung Geräte

  Alt 8. Jul 2014, 17:30
Das betrifft diese App hier auch: https://play.google.com/store/apps/d...lignment&hl=en

Einfach die Anwendung starten, den Aus Knopf drücken und danach sollte sich die Anwendung festfrieren.

Alternativ kann man eine Listview auf ein Formular packen, dass befüllen:

Delphi-Quellcode:
procedure TForm1.FormCreate(Sender: TObject);
var
  I: Integer;
begin
  ListView1.Items.BeginUpdate;
  for I := 0 to 1000 do
    with ListView1.Items.Add do
    begin
      Text := format('Item %d', [I]);
      if I mod 10 = 0 then
        Purpose := TListItemPurpose.Header;
    end;
  ListView1.Items.EndUpdate;
end;
Wie gesagt ich hab hier mit einem Nexus7 und einem Huawei X1 getestet und da geht das Ganze problemlos. Auf letzterem Gerät sogar erfreulich flott.
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.851 Beiträge
 
Delphi 11 Alexandria
 
#4

AW: Android und diverse Samsung Geräte

  Alt 8. Jul 2014, 17:39
Ich habe nur ein HTC One, dort besteht das Problem auch nicht.
Markus Kinzler
  Mit Zitat antworten Zitat
Horst0815

Registriert seit: 23. Mai 2011
Ort: Görlitz
150 Beiträge
 
Delphi XE Starter
 
#5

AW: Android und diverse Samsung Geräte

  Alt 8. Jul 2014, 18:13
Motorola PhotonQ 4G LTE -> keine Probleme
  Mit Zitat antworten Zitat
Benutzerbild von rapante
rapante

Registriert seit: 3. Jun 2009
Ort: OPR
171 Beiträge
 
Delphi XE2 Professional
 
#6

AW: Android und diverse Samsung Geräte

  Alt 9. Jul 2014, 08:44
Mit meinem S3 und der SAT-App kann ich das Problem reproduzieren.
  Mit Zitat antworten Zitat
CHackbart

Registriert seit: 22. Okt 2012
260 Beiträge
 
#7

AW: Android und diverse Samsung Geräte

  Alt 9. Jul 2014, 11:01
Oh super, kannst du eventuell mit dem Tool (Quellcode liegt bei): http://www.dvbviewer.tv/Daddo/usys.zip mal probieren ob bzw. wo der Debugger eine Exception produziert?

Christian
  Mit Zitat antworten Zitat
Benutzerbild von rapante
rapante

Registriert seit: 3. Jun 2009
Ort: OPR
171 Beiträge
 
Delphi XE2 Professional
 
#8

AW: Android und diverse Samsung Geräte

  Alt 9. Jul 2014, 13:13
Ich habe hier nur Appmethod zu Hand um das zu Testen und da scheint es die FMX.Sensors nicht zu geben.
Nachdem ich das aus den Uses entfernt habe, lässt sich das Programm starten. Es kommt aber ständig zu "Segmentation Fault(11)". Keine Ahnung ob das mit der fehlenden Unit zu tun hat.
Wenn ich rechtzeitig(vor Segmentaion Fault) den Power-Button drücke bekomme ich allerdings auch nichts vom Debugger. Der Bildschirm bleibt eine weile schwarz und das Telefon ist nicht mehr bedienbar. Manchmal berappelt es sich wieder halbwegs und ich bekomme den Lock-Screen angezeigt. Nach dem entsperren fehlt allerdings der "Homescreen". Manchmal startet auch das Telefon von selbst durch...
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 15:03 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz