AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke iOS Indy TCPClient: Problem mit OnConnect?

Indy TCPClient: Problem mit OnConnect?

Ein Thema von romber · begonnen am 12. Jan 2015 · letzter Beitrag vom 13. Jan 2015
Antwort Antwort
romber

Registriert seit: 15. Apr 2004
Ort: Köln
1.163 Beiträge
 
Delphi 10 Seattle Professional
 
#1

Indy TCPClient: Problem mit OnConnect?

  Alt 12. Jan 2015, 02:10
Hallo!

Ich versuche gerade in einer Firemonkey iOS-App eine TCP-Verbindung mittels Indy IdTCPClient aufzubauen. OnConnect soll dann ein String mit den Login-Daten an den Server senden. Das Problem ist, dass OnConnect nach dem Connect-Aufruf sofort abgefeuert wird, obwohl die eigentliche Verbindung noch gar nicht aufgebaut ist.
Was mache ich falsch? Gibt es irgendwas besonderes bei Indy, was ich im Fall Firemonkey beachten muss?

Ich habe den Client-Thread aus der Desktop-Version meines Programms übernommen. Ein weiterer Thread überwacht die Verbindung und sorgt für Wiederaufbau der letzteren, sollte es zum Abbruch kommen. Das ganze funktioniert auch ohne weiteres auch in der iOS-App, solange der Server erreichbar ist. Ist es nicht der Fall, stürzt die App böse ab statt immer wieder zu versuchen, Verbindung aufzubauen.
  Mit Zitat antworten Zitat
romber

Registriert seit: 15. Apr 2004
Ort: Köln
1.163 Beiträge
 
Delphi 10 Seattle Professional
 
#2

AW: Indy TCPClient: Problem mit OnConnect?

  Alt 13. Jan 2015, 11:55
Bin ich der einzige mit diesem Problem? Es ist doch ein Bug, oder mache ich wirklich etwas falsch?
  Mit Zitat antworten Zitat
13. Jan 2015, 12:23
Dieses Thema wurde am "13. Jan 2015, 12:23 Uhr" von "Daniel" aus dem Forum "Cross-Platform-Entwicklung" in das Forum "Netzwerke" verschoben.
bernhard_LA

Registriert seit: 8. Jun 2009
Ort: Bayern
1.019 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#4

AW: Indy TCPClient: Problem mit OnConnect?

  Alt 13. Jan 2015, 16:37
wenn man den Client von http://sourceforge.net/projects/indy10clieservr/ auf FM /iOS umstellt, tritt dann dieses Problem auch auf?
bzw. bekommst Du bei Dir unter WIN x32/x64 mit Deiner Anwendung eine gültige Verbindung ?
  Mit Zitat antworten Zitat
romber

Registriert seit: 15. Apr 2004
Ort: Köln
1.163 Beiträge
 
Delphi 10 Seattle Professional
 
#5

AW: Indy TCPClient: Problem mit OnConnect?

  Alt 13. Jan 2015, 21:29
wenn man den Client von http://sourceforge.net/projects/indy10clieservr/ auf FM /iOS umstellt, tritt dann dieses Problem auch auf?
bzw. bekommst Du bei Dir unter WIN x32/x64 mit Deiner Anwendung eine gültige Verbindung ?
Mit dem Demo probiere ich es glech aus, danke für den Link. Bei Windows x32/x64 bekomme ich eine Verbindung, wenn der Server erreichbar ist und ein Fehler, wenn das nicht der Fall ist. Benutze Indy in allen meinen Desktop-Programmen und es läuft auch alles. Das o.g. Problem tritt nur unter iOS auf. Auch wenn ich nicht existierende Host und Port eingebe wird OnConnected ausgeführt, obwohl es mit dieser Host/Port Kombination überhaupt keine physikalische Verbindung zustande kommen kann.

[EDIT] Habe gerade iOS Simulator 7.1 installiert (8.1 funktioniert noch nicht) und auf dem Simulator läuft alles perfekt. Das Problem betrifft also nur das Gerät.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 01:10 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf