AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

DBGrid - ADO - Access

Ein Thema von rudi01 · begonnen am 20. Jan 2015 · letzter Beitrag vom 20. Jan 2015
Antwort Antwort
rudi01

Registriert seit: 1. Dez 2004
9 Beiträge
 
#1

DBGrid - ADO - Access

  Alt 20. Jan 2015, 10:06
Datenbank: Acces • Version: 2007 • Zugriff über: ADO
Hallo @all,
gestern habe ich festgestellt, dass meine Daten aus der Access-Tabelle (die stehen da) nicht im Grid angezeigt werden.
Im Grid kann ich runterscrollen ... nichts passiert.
Es hat wahrscheinlich mit dem Aktualisieren zu tuen, aber ich bin zZt, ein wenig stupido

Wie/wo kann ich diesen Fehler beheben?

Danke für jeden Tipp.

BG Rudi
  Mit Zitat antworten Zitat
jobo

Registriert seit: 29. Nov 2010
2.959 Beiträge
 
Delphi 2010 Enterprise
 
#2

AW: DBGrid - ADO - Access

  Alt 20. Jan 2015, 10:14
Danke für jeden Tipp.
Tipp1:
Zeig mal relevanten Code und/oder die Komponentenverdrahtung.
Gruß, Jo
  Mit Zitat antworten Zitat
Benutzerbild von baumina
baumina

Registriert seit: 5. Mai 2008
Ort: Oberschwaben
1.275 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#3

AW: DBGrid - ADO - Access

  Alt 20. Jan 2015, 10:20


- Connection nicht aktiv oder der Query nicht zugewiesen
- Query nicht aktiv oder der DBGrid nicht zugewiesen
- irgendwo Query.DisableControls und Query.EnableControls vergessen
Hinter dir gehts abwärts und vor dir steil bergauf ! (Wolfgang Ambros)
  Mit Zitat antworten Zitat
Benutzerbild von DeddyH
DeddyH

Registriert seit: 17. Sep 2006
Ort: Barchfeld
27.265 Beiträge
 
Delphi 10.4 Sydney
 
#4

AW: DBGrid - ADO - Access

  Alt 20. Jan 2015, 10:22
Du meinst sicherlich: nach einem DisableControls das abschließende EnableControls vergessen
Detlef
"Ich habe Angst vor dem Tag, an dem die Technologie unsere menschlichen Interaktionen übertrumpft. Die Welt wird eine Generation von Idioten bekommen." (Albert Einstein)
Dieser Tag ist längst gekommen
  Mit Zitat antworten Zitat
Benutzerbild von baumina
baumina

Registriert seit: 5. Mai 2008
Ort: Oberschwaben
1.275 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#5

AW: DBGrid - ADO - Access

  Alt 20. Jan 2015, 10:32
sag ich doch
Hinter dir gehts abwärts und vor dir steil bergauf ! (Wolfgang Ambros)
  Mit Zitat antworten Zitat
rudi01

Registriert seit: 1. Dez 2004
9 Beiträge
 
#6

AW: DBGrid - ADO - Access

  Alt 20. Jan 2015, 12:30
Thanks @all,
ich muß meine Angaben konkretisieren:

In der Basistabelle sind 684 Datensätze (ID).
Im DBGrid wird mir ALLES bis zur ID 678 ordentlich dargestellt.

Ich komme nicht über das DBGrid an die DS über 678, nicht mit dem Scrollbalken, nicht mit den Cursortasten ....
In der Tabelle sind sie aber!

Eben habe ich 2 DS hinzugefügt, die waren als letzte in der aktuellen Sitzung sichtbar
Aber die DS von 679-684 fehlten weiterhin, also ein Lücke ...

Nach dem Neustart des Programms wieder nur 684 DS sichtbar.

BD Rudi
  Mit Zitat antworten Zitat
rudi01

Registriert seit: 1. Dez 2004
9 Beiträge
 
#7

AW: DBGrid - ADO - Access

  Alt 20. Jan 2015, 12:50
Stupido ...

das Problem ist gelöst:
die DS waren da, wurden aber in der DBGrid-Anzeige an den Anfang gestellt.
Also eine Frage der Sortierung ...

Vielen Dank und
BG Rudi
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 06:00 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf