AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Cross-Platform-Entwicklung iOS Simulator verhält sich sehr seltsam bei String Auswertung

Simulator verhält sich sehr seltsam bei String Auswertung

Ein Thema von Sherlock · begonnen am 11. Apr 2016 · letzter Beitrag vom 29. Apr 2016
Antwort Antwort
Seite 1 von 2  1 2   
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.557 Beiträge
 
Delphi 10.4 Sydney
 
#1

Simulator verhält sich sehr seltsam bei String Auswertung

  Alt 11. Apr 2016, 16:24
Ich habe eine FMX-Anwendung, die mit einem SOAP-Server kommuniziert. Dabei gilt es dann einiges an Strings zu empfangen und zu parsen. Ersteres klappt unter allen Plattformen(Win, Mac, iOS) wunderbar, aber letzteres bereitet mir unter iOS Kopfschmerzen. Sind mir Meldungen entgangen, denenzufolge der Simulator ein wenig "eigenwillig" bei der Interpretation von Strings vorgeht? Müssen die einen bestimmten Typen haben? Ich habe noch keinen Developer Account, weshalb ich das nicht auf einem echten Device testen kann. Aber ich wäre davon ausgegangen, daß wenn es unter MacOS tut, es eigentlich auch unter iOS nicht komplett explodieren sollte - sprich nur marginale Anpassungen am Code nötig wären. Gegenwärtig habe ich halt die Situation, daß ich einen String zerlege und auswerte, und im Debugger ganz klar der Term in einem if "True" ist, es aber zum Else gesprungen wird...nur im Simulator wohlgemerkt, der gleiche String wird unter Win oder Mac korrekt ausgewertet. Es ist dabei realitv schwer ein Beispiel zu konstruieren, ich werde es aber gerne tun, wenn hier niemandem sowas bekannt ist.

Danke fürs lesen

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
4dk2

Registriert seit: 4. Sep 2007
176 Beiträge
 
#2

AW: Simulator verhält sich sehr seltsam bei String Auswertung

  Alt 12. Apr 2016, 09:55
Ich kenn mich zwar mit iOS entwicklung null aus , aber vielleicht ein Unicode/Ansi/Codierungs Problem?
Vielleicht hast du ja die Möglichkeit die Strings als Hex einmal darzustellen und zu prüfen?
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.903 Beiträge
 
Delphi 10.4 Sydney
 
#3

AW: Simulator verhält sich sehr seltsam bei String Auswertung

  Alt 12. Apr 2016, 10:06
Wie sieht die Auswertung und das IF-ELSE denn aus?
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Benutzerbild von DeddyH
DeddyH

Registriert seit: 17. Sep 2006
Ort: Barchfeld
27.303 Beiträge
 
Delphi 11 Alexandria
 
#4

AW: Simulator verhält sich sehr seltsam bei String Auswertung

  Alt 12. Apr 2016, 10:15
Zum Testen auf einem Device wird seit XCode 7 übrigens kein Developer Account benötigt, siehe z.B. hier.
Detlef
"Ich habe Angst vor dem Tag, an dem die Technologie unsere menschlichen Interaktionen übertrumpft. Die Welt wird eine Generation von Idioten bekommen." (Albert Einstein)
Dieser Tag ist längst gekommen
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.557 Beiträge
 
Delphi 10.4 Sydney
 
#5

AW: Simulator verhält sich sehr seltsam bei String Auswertung

  Alt 12. Apr 2016, 11:01
Ich danke Euch für die Anregungen. Des Pudels Kern und Lösung ist dies hier Delphi-Referenz durchsuchenSystem.SysUtils.TStringHelper. Strings sind auf Mobiledevices offenbar 0-basiert und sonst 1-basiert. Ich stricke jetzt mal eben alles auf die StringHelper um
Also im Prinzip hat mich 4dk2 auf die Spur geführt, denn ich habe über die Stringtypen nachgelesen und bin dann auf dieses gestoßen. Also Danke! Und Notiz an alle: Pos ist nicht mehr wirklich unser Freund...jedenfalls nicht immer Der neue Freund heisst .IndexOf ...immer.

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.557 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: Simulator verhält sich sehr seltsam bei String Auswertung

  Alt 29. Apr 2016, 14:13
Zum Testen auf einem Device wird seit XCode 7 übrigens kein Developer Account benötigt, siehe z.B. hier.
OK, das ist interessant. Aber wie verheirate ich das mit Delphi?

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
Benutzerbild von DeddyH
DeddyH

Registriert seit: 17. Sep 2006
Ort: Barchfeld
27.303 Beiträge
 
Delphi 11 Alexandria
 
#7

AW: Simulator verhält sich sehr seltsam bei String Auswertung

  Alt 29. Apr 2016, 14:15
Du legst in XCode ein Projekt an und lässt es zertifizieren. Den dort eingegebenen Bundle Identifier trägst Du auch in Deinem Delphi-Projekt ein. Wenn Du nichts falsch gemacht hast, sollte sich das Projekt dann auch auf einem angeschlossenen Gerät starten lassen.
Detlef
"Ich habe Angst vor dem Tag, an dem die Technologie unsere menschlichen Interaktionen übertrumpft. Die Welt wird eine Generation von Idioten bekommen." (Albert Einstein)
Dieser Tag ist längst gekommen
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.557 Beiträge
 
Delphi 10.4 Sydney
 
#8

AW: Simulator verhält sich sehr seltsam bei String Auswertung

  Alt 29. Apr 2016, 14:33
OK, ich bekomme aber immer diesen Fehler:
Zitat:
[DCC Fataler Fehler] F2588 Linker-Fehlercode: 1 ($00000001)
Davor diese Warnung:
Zitat:
[DCC Fehler] E2597 ld: warning: directory not found for option '-F\\Mac\Home\Documents\Embarcadero\Studio\SDKs\iPho neOS9.3.sdk\System\Library\PrivateFrameworks'
ld: file not found: L


Simulator läuft einwandfrei.

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.557 Beiträge
 
Delphi 10.4 Sydney
 
#9

AW: Simulator verhält sich sehr seltsam bei String Auswertung

  Alt 29. Apr 2016, 14:45
Habs:
https://forums.embarcadero.com/threa...hreadID=109069

Ich habe natürlich Parallels und so weiter...

Jetzt klappts.

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
bra

Registriert seit: 20. Jan 2015
711 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#10

AW: Simulator verhält sich sehr seltsam bei String Auswertung

  Alt 29. Apr 2016, 14:48
OK, ich bekomme aber immer diesen Fehler:
Zitat:
[DCC Fataler Fehler] F2588 Linker-Fehlercode: 1 ($00000001)
Davor diese Warnung:
Zitat:
[DCC Fehler] E2597 ld: warning: directory not found for option '-F\\Mac\Home\Documents\Embarcadero\Studio\SDKs\iPho neOS9.3.sdk\System\Library\PrivateFrameworks'
ld: file not found: L
Wir hatten das Problem auch, hier fehlen (?) bei der SDK 9.3 scheinbar Verzeichnisse oder haben sich geändert. Wir sind auf die SDK 9.2 zurückgegangen, damit funktioniert es.
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 10:49 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf