AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

komischer Programmstart

Ein Thema von Mattze · begonnen am 19. Apr 2016 · letzter Beitrag vom 20. Apr 2016
Antwort Antwort
Mattze

Registriert seit: 6. Jan 2005
664 Beiträge
 
#1

komischer Programmstart

  Alt 19. Apr 2016, 11:20
Hallo,

eine ganz merkwürdige Sache:
Starte ich mein Programm zum ersten Mal nach dem Booten, wird es ordentlich in die Prozessliste, aber NICHT in die Anwendungsliste eingetragen. (Taskmanager)
Lösche ich es dann aus der Prozessliste (Prozess beenden) und starte es noch mal, wird es normal (und richtig) als Application gestartet mit Hauptformular usw.
Lösche ich es nicht aus der Prozesslist und starte es noch mal, wird es wieder in die Prozessliste eingetragen und mehr nicht.

Weiß jemand, warum das passiert und was man dagegen tun kann?
(Delphi 7 pro unter Win 7 64)

Ich weiß, dass man ein Programm aus der Anwendungsliste entfernen kann. Aber, ich habe das noch nie gemacht und sehe zurzeit auch keine Notwendigkeit dafür.
Um so mehr bin ich natürlich überrascht, das sowas "einfach so" passieren kann.

Gruß
Mattze
  Mit Zitat antworten Zitat
Benutzerbild von markus5766h
markus5766h

Registriert seit: 5. Mär 2009
Ort: Hamburg
569 Beiträge
 
Delphi XE8 Professional
 
#2

AW: komischer Programmstart

  Alt 19. Apr 2016, 14:26
Moin, da ich die fast gleiche Konstellation (Delphi 7 Enterprise / Win 7 64Bit) habe :
gleich mal ausprobiert :
neu gebootet,
Programm gestartet,
--> Eintrag in Anwendungsliste und Prozessliste

also hier nicht reproduzierbar . . .
Markus H.
  Mit Zitat antworten Zitat
Mattze

Registriert seit: 6. Jan 2005
664 Beiträge
 
#3

AW: komischer Programmstart

  Alt 19. Apr 2016, 14:44
Hallo,

oh, da hast Du mich falsch verstanden. Habe ich nicht explizit geschrieben.
Genau das ist nämlich das Problem!
Ich programmiere nicht erst seit gestern und habe das noch nie erlebt.
Mit keinem Programm, mit keinem Delphi und unter keinem BS.
(Muss nachher mal probieren, was unter Win 10 64 passiert...)

Es funktioniert nur mit diesem einen Programm und ich kann mir einfach nicht erklären, warum.
Ich glaube, es hat in einer früheren Programmversion auch mal richtig funktioniert.
Irgendwann fing dann dieses komische Verhalten an, ging aber auch immer mal wieder weg - jedenfalls glaube ich das. Ganz sicher bin ich mir da nicht. Vielleicht hatte ich nur den Eindruck, dass es weg ging...
Nun ist das jedenfalls unverändert so komisch.

Ich werde mal alles rausschmeißen und nur noch eine Art Grundgerüst übrig lassen. Mal sehen...

Gruß
Mattze
  Mit Zitat antworten Zitat
BenjaminH

Registriert seit: 14. Okt 2004
Ort: Freiburg im Breisgau
713 Beiträge
 
Turbo Delphi für Win32
 
#4

AW: komischer Programmstart

  Alt 19. Apr 2016, 16:07
Ich glaube, es hat in einer früheren Programmversion auch mal richtig funktioniert.
Verwendest du git? Dann empfehle ich dir die Verwendung von git-bisect. Im Prinzip checkt er für dich ein paar Versionen aus, du schaust, ob die das Problem haben und grenzt dadurch den Fehler ein.
Git hilft dabei, den Überblick zu behalten, welche Versionen gehen - und welche nicht. Außerdem wählt es aus, welche Version du prüfst
Benjamin
  Mit Zitat antworten Zitat
Mattze

Registriert seit: 6. Jan 2005
664 Beiträge
 
#5

AW: komischer Programmstart

  Alt 19. Apr 2016, 18:12
Hallo,

also unter Win 10 64 startet es sofort richtig. Kein Problem!

Wasist git? (Womit die Frage, ob ich es verwende, auch beantwortet ist.)

Gruß
Mattze
  Mit Zitat antworten Zitat
BenjaminH

Registriert seit: 14. Okt 2004
Ort: Freiburg im Breisgau
713 Beiträge
 
Turbo Delphi für Win32
 
#6

AW: komischer Programmstart

  Alt 19. Apr 2016, 19:12
Git ist ein Versionsverwaltungssystem. Das lohnt sich spätestens, wenn man im Team arbeitet, aber hat auch davor schon einige Vorteile(wie z.B. bisect, was ich oben erwähnt hab). Aber hier jetzt mehr darüber zu erzählen wäre OT. Wenn's dich interessiert gibt's tausend Tutorials im Netz.
Benjamin
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
9.406 Beiträge
 
Delphi 11 Alexandria
 
#7

AW: komischer Programmstart

  Alt 20. Apr 2016, 02:55
Startet dein Programm denn komplett und funktioniert auch wenn es nicht in der Liste der Anwendungen auftaucht?
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Benutzerbild von Zacherl
Zacherl

Registriert seit: 3. Sep 2004
4.629 Beiträge
 
Delphi 10.2 Tokyo Starter
 
#8

AW: komischer Programmstart

  Alt 20. Apr 2016, 10:50
Nur sone Idee: Hast du es mal auf einer frischen Win 7 64-bit Installation versucht? Nur um sicher zu gehen, dass es tatsächlich an deinem Code liegt und nicht Windows sich irgendwie verschluckt hat und jetzt immer falsche Kompatibilitätseinstellungen auf dein Programm anwendet.

Zweite Idee wäre mal ein modernes Manifest hinzuzufügen (himitsu hatte hierfür mal ein umfangreiches Tool gebastelt).
Projekte:
- GitHub (Profil, zyantific)
- zYan Disassembler Engine ( Zydis Online, Zydis GitHub)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 19:44 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz