AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

EMail-Versand via SMTP/Mapi

Ein Thema von BerTa · begonnen am 28. Jun 2016 · letzter Beitrag vom 4. Jul 2016
Antwort Antwort
Seite 2 von 2     12
Benutzerbild von dataspider
dataspider

Registriert seit: 9. Nov 2003
Ort: 04539 Groitzsch
1.291 Beiträge
 
Delphi 10.3 Rio
 
#11

AW: EMail-Versand via SMTP/Mapi

  Alt 29. Jun 2016, 17:13
Herzlichen Dank an Martin und Sir Rufo...

Ich habe es gerade mal getestet. Funktioniert!

Frank
Frank Reim
  Mit Zitat antworten Zitat
BerTa

Registriert seit: 31. Aug 2004
Ort: Dinklage
77 Beiträge
 
Delphi 7 Enterprise
 
#12

AW: EMail-Versand via SMTP/Mapi

  Alt 1. Jul 2016, 13:52
Hi,
vielen Dank für die Hilfe,
mit Imap hatten wir es auch schonmal probiert.
Hatten, bzw. haben gelegentlich das Problem, dass sich unser Programm aufhängt.
Der Versand per SMTP hat geklappt, aber im Versand Ordner ist keine Kopie zu finden.
Er scheint sich beim Connect aufzuhängen.
Woran kann sowas liegen? Es kommt nicht immer vor.
alles läuft, aber nichts geht...
  Mit Zitat antworten Zitat
Benutzerbild von Sir Rufo
Sir Rufo

Registriert seit: 5. Jan 2005
Ort: Stadthagen
9.454 Beiträge
 
Delphi 10 Seattle Enterprise
 
#13

AW: EMail-Versand via SMTP/Mapi

  Alt 1. Jul 2016, 15:03
IdR müsste der Connect auch einen Timeout haben. Wenn der aber default auf INFINITE steht, dann wartest du eben bis "end of days"

Also TimeOut für den Connect mitgeben und entsprechend darauf reagieren.

Es macht da durchaus Sinn mit entsprechenden Warteschlangen zu arbeiten, die von den beiden Diensten Sende per SMTP, Verschiebe in Versand-Ordner (laufen jeweils im eigenen Thread) abgearbeitet werden.

Die Daten liegen dafür lokal auf der Platte und werden dann wenn möglich abgearbeitet. Stürzt dein Programm ab, dann wird beim nächsten Start einfach an der Stelle weitergemacht
Kaum macht man's richtig - schon funktioniert's
Zertifikat: Sir Rufo (Fingerprint: ‎ea 0a 4c 14 0d b6 3a a4 c1 c5 b9 dc 90 9d f0 e9 de 13 da 60)
  Mit Zitat antworten Zitat
BerTa

Registriert seit: 31. Aug 2004
Ort: Dinklage
77 Beiträge
 
Delphi 7 Enterprise
 
#14

AW: EMail-Versand via SMTP/Mapi

  Alt 4. Jul 2016, 10:32
Nach einem Neustart des Programms habe ich keine Probleme ein EMail zu versenden.
Wenn ich aber die IMAP Daten den Bediener zuordnen will und die MailBoxen abfragen, bekomme ich danach Probleme beim Versenden -> ReadTimeOut
Schon merkwürdig, dass es in der Konstellation immer auftritt.

Code:
  IMAP := TIdIMAP4.Create(nil);
  IMAP.Host    := bedDM.MyQBedimap_server.Value;
  IMAP.Port    := bedDM.MyQBedimap_port.Value;
  IMAP.Username := bedDM.MyQBedimap_account.Value;
  IMAP.Password := bedDM.MyQBedimap_pw.Value;
  //LTheSASLListEntry := TheSmtp.FSASLMechanisms.Add;
  //LTheSASLListEntry.SASL := TheSASLLogin;
  IMAP.ReadTimeout   := 10000;
  IMAP.ConnectTimeout := 10000;
  if IMAP.Connect then
  begin
    IMAP.ListMailBoxes(UsersFolders);
    for i := 0 to UsersFolders.Count-1 do
      cxComboIMAPSent.Properties.Items.Add(UsersFolders[i]);
    IMAP.Disconnect;
  end;

  if IMAP <> nil then
  begin
    IMAP.Free;
    IMAP := nil;
  end;
Code:
  IMAP := TIdIMAP4.Create(self);

  IMAP.Host := ApsToolDM.MyQBedDatenimap_server.Value;
  IMAP.Port := ApsToolDM.MyQBedDatenimap_port.Value;
  IMAP.Username := ApsToolDM.MyQBedDatenimap_account.Value;
  IMAP.Password := ApsToolDM.MyQBedDatenimap_pw.Value;
  IMAP.ReadTimeout   := 5000;
  IMAP.ConnectTimeout := 5000;
  if IMAP.Connect then
  begin
    Imap.AppendMsg(APsToolDM.MyQBedDatenimap_sent.Value,IdMsgSend,NIL,[mfseen]);
    if IMAP.Connected then
      IMAP.Disconnect;
  end;
  if IMAP <> nil then
  begin
    IMAP.Free;
    IMAP := nil;
  end;
alles läuft, aber nichts geht...
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 03:23 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf