AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Projekte Spectragram

Spectragram

Ein Thema von EWeiss · begonnen am 21. Sep 2016 · letzter Beitrag vom 12. Aug 2018
Antwort Antwort
Seite 1 von 9  1 23     Letzte » 
EWeiss
Projekt entfernt..

Geändert von EWeiss (24. Jul 2019 um 04:48 Uhr)
 
Benutzerbild von Luckie
Luckie

 
Delphi 2006 Professional
 
#2
  Alt 22. Sep 2016, 02:09
Windows 7 Starter
Spectragram.part1
Beim Klicken auf die Schaltfläche, um eine MP3 Datei auszuwählen:

Code:
---------------------------
Anwendungsfehler
---------------------------
Exception EAccessViolation in Modul Spectragram.exe bei 00052135.

Zugriffsverletzung bei Adresse 00452135 in Modul 'Spectragram.exe'. Lesen von Adresse 00000000.


---------------------------
OK  
---------------------------
Wo merkt sich dein Programm eigentlich welchen Hintergrund ich eingestellt habe? Ich würde das Programm gerne wieder irgendwie sauber von meinem Rechner bekommen.

Nachtrag: Gleiches Problem mit der Exe in Spectragram.part2
Michael
  Mit Zitat antworten Zitat
EWeiss
 
#3
  Alt 22. Sep 2016, 02:22
Windows 7 Starter
Spectragram.part1
Beim Klicken auf die Schaltfläche, um eine MP3 Datei auszuwählen:

Code:
---------------------------
Anwendungsfehler
---------------------------
Exception EAccessViolation in Modul Spectragram.exe bei 00052135.

Zugriffsverletzung bei Adresse 00452135 in Modul 'Spectragram.exe'. Lesen von Adresse 00000000.


---------------------------
OK  
---------------------------
Wo merkt sich dein Programm eigentlich welchen Hintergrund ich eingestellt habe? Ich würde das Programm gerne wieder irgendwie sauber von meinem Rechner bekommen.

Nachtrag: Gleiches Problem mit der Exe in Spectragram.part2
Erst mal benötigt man beide Archive um die Dateien zu entpacken ich dachte eigentlich das wäre bekannt.
AppData/Brewideas/Spectragram.

Warum sauber deinstallieren wird doch nichts Installiert.
Mal geschaut warum das nicht läuft.. Source ist doch dabei. Hmmm.. Nun gut.
Kann ich schließen öffnen wann ich will kann kein Problem feststellen.

Kein Problem hier siehe Pic.

Zitat:
Nachtrag: Gleiches Problem mit der Exe in Spectragram.part2
Boahh eh.. Nochmal ich dachte eigentlich das wäre bekannt das dies ein Multipart Archiv ist.
Und es zwingend nötig ist das Archiv Part1 und part2 zu laden
Part1 wird extrahiert der Rest folgt automatisch.

Ist der erste Part fertig werden die restlichen Teile aus dem Part2 Archiv extrahiert.
Und die EXE ist die gleiche denn sie gehört zum Archiv (Spectragram) das lediglich geplittet wurde weil ich hier keine Anhänge mehr als 5MB hochladen kann.


gruss

Geändert von EWeiss (11. Jul 2019 um 15:44 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie

 
Delphi 2006 Professional
 
#4
  Alt 22. Sep 2016, 02:45
Ich besitze kein Entpacker der Rar Archive entpacken kann. Der Freecommander kann jedes Archiv einzeln ohne Probleme entpacken. Keine Ahnung , ob er erkennt, dass es ein Multipartarchiv ist. Ich bekomme entsprechend zwei Ordner. Siehe Anhang. In beiden Ordner befinden sich wohl identische Dateien.

Ich kann dir nur berichten, was bei mir passiert. Beweis siehe Anhang. Debuggen kann ich es auf dem Netbook nicht, da ich hier kein Delphi installiert habe. Und ich weiß gar nicht, ob sich dein Code mit dem BDS2006 überhaupt kompilieren lässt.

Es kann ja sein, dass es bei dir funktioniert. Bei mir tut es das jedenfalls nicht. Und ich bin bestimmt nicht zu doof eine Exe zu starten und einen Button anzuklicken.

Auch wenn nichts installiert wird und ich es einfach lösche, bleibt doch noch Müll übrig, den ich eben auch gerne loswerden wollen täte. Sonst habe ich nach zehn Testprogramme nur noch Müll auf dem Rechner, der nicht mehr benötigt wird.

Und ich würde dich bitte deinen Ton mir gegenüber etwas zu ändern. Ich bin kein vollkommener Idiot.
Miniaturansicht angehängter Grafiken
untitled-1.jpg   untitled-2.jpg   untitled-3.jpg  
Michael

Geändert von Luckie (22. Sep 2016 um 02:48 Uhr)
  Mit Zitat antworten Zitat
EWeiss
 
#5
  Alt 22. Sep 2016, 02:52
Zitat:
Und ich würde dich bitte deinen Ton mir gegenüber etwas zu ändern. Ich bin kein vollkommener Idiot.
Bitte ?

Wo war ich unfreundlich..
Ich kann nichts dafür wenn dir nicht klar ist das es hier um ein Multipart Archiv geht.
Sorry aber das weis meine Nichte schon und die ist 5.

Das es nicht starte wird wohl daran liegen das du alle Design spezifische Dinge in deinem System deaktiviert hast.
Da geht kein Aero oder sonstiges das kann dann zu deinem Fehler führen.
Aber das kann ich selber testen.

Aber kein Problem

Jedenfalls war ich nicht unfreundlich und als Idiot habe ich dich auch nicht angesprochen.
Bitte sachlich bleiben. Besonders als Mod!

Zitat:
Und ich bin bestimmt nicht zu doof eine Exe zu starten und einen Button anzuklicken.
Hat niemand behauptet.. Schlecht geschlafen ? Oder noch gar nicht.

Es ist aber offensichtlich das der Freecommander wohl keine Multipart Archive entpacken kann denn da fehlt der Ordner "Src" (Source).
Oder ich habe ihn nicht gesehen auf deinen Bildern.
Was ich noch feststellen muss durch die Veränderung der Anhänge das addieren Unterschiedlicher Zahlen zu jedem Archiv ist das Multipart Archiv quasi zerstört.

Dann bitte wieder umbenennen nach
spectragram.part1.rar
spectragram.part2.rar

Ansonsten funktioniert das Entpacken nicht.


gruss

Geändert von EWeiss (22. Sep 2016 um 03:10 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie

 
Delphi 2006 Professional
 
#6
  Alt 22. Sep 2016, 02:59
Der Ton macht die Musik:
Zitat:
Boahh eh.. Nochmal ich dachte eigentlich das wäre bekannt das dies ein Multipart Archiv ist.
Das mit den Archiven hat sich geklärt. Wenn ich nur Part1 habe, sagt mir der Freecommander, dass es kein gültiges Archiv ist. Daran liegt es also nicht.

Windows 7 Starter kennt kein Aero. Und auf meinem Windows 7 Home habe ich es deaktiviert. Es würde also auch da abstürzen, weil es zwingend Aero voraussetzt?
Michael

Geändert von Luckie (22. Sep 2016 um 03:01 Uhr)
  Mit Zitat antworten Zitat
EWeiss
 
#7
  Alt 22. Sep 2016, 03:09
Der Ton macht die Musik:
Zitat:
Boahh eh.. Nochmal ich dachte eigentlich das wäre bekannt das dies ein Multipart Archiv ist.
Das mit den Archiven hat sich geklärt. Wenn ich nur Part1 habe, sagt mir der Freecommander, dass es kein gültiges Archiv ist. Daran liegt es also nicht.

Windows 7 Starter kennt kein Aero. Und auf meinem Windows 7 Home habe ich es deaktiviert. Es würde also auch da abstürzen, weil es zwingend Aero voraussetzt?
Und deshalb warst du jetzt angep....
Ok werde ich mir merken das du ein Boahh im Text nicht ausstehen kannst.
Das war nichts anderes als ein erstaunter Aufruf..

Es sieht so aus das wenn ich mit meinem Dialog auf Aero hin überprüfe das der Dialog hier den Absturz verursacht.
Nein wird wohl nicht gehen deshalb läuft es auch unter W10 nicht.
Jain.. du hast Aero deaktiviert aber im System selbst gibt es trotzdem DWM oder nicht? (W7 Home)

In deinem Window ist zumindest "Crystal" und "Blur Mode" deaktiviert. (Was auch richtig ist.)
Das Fenster wird dann wie unter XP behandelt wo es auch kein DWM gibt.

gruss

Geändert von EWeiss (22. Sep 2016 um 03:17 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie

 
Delphi 2006 Professional
 
#8
  Alt 22. Sep 2016, 03:16
OK. Dein Boah ey hat bei mir den Eindruck hinterlassen, dass du genervt warst, weil ich anscheinend unfähig bin ein Multipartarchiv zu erkennen. Da habe ich mich etwas angepisst gefühlt. Vergessen wir das.

Der Freecommander macht wohl folgendes (und das ist etwas blöd vom Freecommander): Er erkennt dass es sich um ein Multipartarchiv handelt egal welchen Teil man entpackt. So weit so gut. Jetzt der blöde Teil: Entpackt man in Unterordner, benennt er die Ordner nach dem Archivteil, den man zum Entpacken genommen hat. Daher meine Verwirrung.

Der Source Ordner fehlt nicht. In meinen Screenshot sieht man nur den Unterordner bin.

Aber warum wird Aero unbedingt benötigt? Du bringst doch deinen eigenen Skinengine mit. Oder benötigt der Skinengine Aero? Das würde es erklären. Also das würde ich irgendwie ändern, man kann wohl kaum erwarten, dass man dafür Aero aktiviert, wenn überhaupt möglich.

Ich werde es morgen noch mal auf dem großen Rechner mit Windows 7 Home und deaktivierten Aero probieren.
Michael
  Mit Zitat antworten Zitat
EWeiss
 
#9
  Alt 22. Sep 2016, 03:21
Zitat:
Aber warum wird Aero unbedingt benötigt? Du bringst doch deinen eigenen Skinengine mit. Oder benötigt der Skinengine Aero? Das würde es erklären. Also das würde ich irgendwie ändern, man kann wohl kaum erwarten, dass man dafür Aero aktiviert, wenn überhaupt möglich.
Jain.. Warum.
Wie du sehen kannst wurden ja bei dir "Crystal" und "Blur Mode" deaktiviert.
Der Grund liegt daran weil dein System das nicht unterstützt.

Meine Dialoge hingegen prüfen den Status ob das Haupt-Fenster Aero eingeschaltet hat oder nicht.
Ich denke das hier im Code ein Fehler vorliegt den ich noch berichtigen muss.

Danke so kann ich zumindest das Problem beheben.

gruss.
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie

 
Delphi 2006 Professional
 
#10
  Alt 22. Sep 2016, 03:28
Was wurde bei mir deaktiviert und woran siehst du das? Ich hatte vorher mal ein paar Hintergründe durch probiert bevor ich eine MP3 auswählen wollte. Das Hintergrundbild wechseln funktioniert ohne Probleme.
Michael
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 13:35 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf