AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Programmieren allgemein XML Delphi XML geschachteltes selectNodes liefert falsches Ergebnis zurück

XML geschachteltes selectNodes liefert falsches Ergebnis zurück

Ein Thema von news2swen · begonnen am 28. Mär 2017 · letzter Beitrag vom 6. Aug 2019
Antwort Antwort
news2swen

Registriert seit: 7. Nov 2008
36 Beiträge
 
Delphi XE4 Enterprise
 
#1

XML geschachteltes selectNodes liefert falsches Ergebnis zurück

  Alt 28. Mär 2017, 09:23
Hallo zusammen

irgendwie komme ich nicht weiter und weiß nicht, wo mein Fehler liegt.
Ich habe eine XML-Datei:
Code:
<?xml version="1.0" encoding="utf-8"?>
<STL date="2017-02-24">
   <Ebene0 id="id4" primaryRef="id7">
      <Ebene1 id="id7">
         <Ebene2 id="id6">
            <Ebene3 title="A" value="0815"/>
            <Ebene3 title="B" value="747"/>
         </Ebene2>
         <Ebene2 id="id8" type="ADD">
            <Ebene3 title="NO" value="-"/>
            <Ebene3 title="AM" value="-"/>
         </Ebene2>
      </Ebene1>
      <Ebene1 id="id11" parentRef="id7">
         <Ebene2 id="id10">
            <Ebene3 title="A" value="0819"/>
            <Ebene3 title="B" value="A.001"/>
         </Ebene2>
         <Ebene2 id="id12" type="ADD">
            <Ebene3 title="NO" value="25"/>
            <Ebene3 title="AM" value="40"/>
         </Ebene2>
      </Ebene1>
      <Ebene1 id="id71" parentRef="id8">
         <Ebene2 id="id78">
            <Ebene3 title="A" value="0816"/>
            <Ebene3 title="B" value="A.001"/>
         </Ebene2>
         <Ebene2 id="id79" type="ADD">
            <Ebene3 title="NO" value="8825"/>
            <Ebene3 title="AM" value="4054"/>
         </Ebene2>
      </Ebene1>
      <Ebene1 id="id81" parentRef="id7">
         <Ebene2 id="id89">
            <Ebene3 title="A" value="0817"/>
            <Ebene3 title="B" value="A.005"/>
         </Ebene2>
         <Ebene2 id="id99" type="ADD">
            <Ebene3 title="NO" value="2"/>
            <Ebene3 title="AM" value="4"/>
         </Ebene2>
      </Ebene1>
      <Ebene1 id="id99" parentRef="id7">
         <Ebene2 id="id100">
            <Ebene3 title="A" value="0818"/>
            <Ebene3 title="B" value="A.002"/>
         </Ebene2>
         <Ebene2 id="id112" type="ADD">
            <Ebene3 title="NO" value="125"/>
            <Ebene3 title="AM" value="140"/>
         </Ebene2>
      </Ebene1>
   </Ebene0>
</STL>
Aus dieser hole ich mir mittels node.selectNodes('//Ebene1[@parentRef='id7']) alle Knoten der Ebene1, welche mich interessieren in eine Nodelist.
Nun möchte ich für jeden einzelnen Knoten dieser Liste bestimmte Attribute der Ebene3 abfragen. Wenn ich dies mit selectSingleNode('//Ebene2/Ebene3[@title=''A'']') versuche, erhalte ich für alle selektierten Knoten (in dem Falle 3) immer den gleichen Wert zurück. Das ist schon verwirrend genug, aber ganz mysteriös ist, dass der zurückgelieferte Knoten gar nicht Teil der in Nodelist befindlichen Elemente ist, sondern der erste in der XML vorkommende.

Hier mein code mit dem ich das versuche:
Delphi-Quellcode:
procedure TForm1.Button1Click(Sender: TObject);
var
  XMLDoc: DOMDocument;
  Node,subnode1: IXMLDOMNode;
  nodelist: IXMLDOMNodeList;

  sPrimary : string;
  i : integer;
begin
    Memo1.Clear;
    XMLDoc := CoDOMDocument.Create;

    xmlDoc.Load('C:\Temp\test.xml');
    // Knoten auswählen
    Node:= XMLDoc.selectSingleNode('/STL/Ebene0') as IXMLDOMElement;

    if Assigned(Node) then
    begin
        // ermitteln der ID, um die entsprechenden Unterknoten zu selektieren
        sPrimary := Node.attributes.getNamedItem('primaryRef').text;
        nodelist := node.selectNodes('//Ebene1[@parentRef=''' + sPrimary + ''']');

        // für alle Knoten, welche diese ID in parentRef haben, die Daten
        // der Ebene3 mit entsprechendem Attribut ermitteln
        for i := 0 to nodelist.length-1 do
        begin
            subnode1:= nodelist.item[i].selectSingleNode('//Ebene2/Ebene3[@title=''A'']');
            memo1.Lines.Add(subnode1.attributes.getNamedItem('value').text);
            subnode1:= nodelist.item[i].selectSingleNode('//Ebene2/Ebene3[@title=''NO'']');
            memo1.Lines.Add(subnode1.attributes.getNamedItem('value').text);
        end;
    end;

end;
Wo liegt mein Fehler? Ich hoffe ihr habt eine Idee

VG
Swen
Angehängte Dateien
Dateityp: xml test.xml (1,5 KB, 1x aufgerufen)
Swen
  Mit Zitat antworten Zitat
Der schöne Günther

Registriert seit: 6. Mär 2013
5.716 Beiträge
 
Delphi 10 Seattle Enterprise
 
#2

AW: XML geschachteltes selectNodes liefert falsches Ergebnis zurück

  Alt 28. Mär 2017, 10:29
Kannst du für deinen Beispielcode noch die uses angeben? Meine IDE ist zu dumm das selbst herauszufinden.
  Mit Zitat antworten Zitat
news2swen

Registriert seit: 7. Nov 2008
36 Beiträge
 
Delphi XE4 Enterprise
 
#3

AW: XML geschachteltes selectNodes liefert falsches Ergebnis zurück

  Alt 28. Mär 2017, 11:07
selbstverständlich gern

uses
Winapi.Windows, Winapi.Messages, System.SysUtils, System.Variants, System.Classes, Vcl.Graphics,
Vcl.Controls, Vcl.Forms, Vcl.Dialogs, Vcl.StdCtrls,MSXML;
Swen
  Mit Zitat antworten Zitat
Der schöne Günther

Registriert seit: 6. Mär 2013
5.716 Beiträge
 
Delphi 10 Seattle Enterprise
 
#4

AW: XML geschachteltes selectNodes liefert falsches Ergebnis zurück

  Alt 28. Mär 2017, 11:24
Entweder habe ich die Frage nicht richtig verstanden, oder dein Fehler liegt einfach am XPath-Ausdruck in der for-schleife. Sieh ihn dir noch einmal genau an: Er beginnt mit "//". Du willst nicht das gesamte Dokument. Du willst "von hier aus, alle Unterknoten". Richtig?

Wenn ja, dann würde es nicht mit "//", sondern mit ".//" beginnen.

Dann spuckt dein Code folgendes aus:
Code:
0819
25
0817
2
0818
125
  Mit Zitat antworten Zitat
news2swen

Registriert seit: 7. Nov 2008
36 Beiträge
 
Delphi XE4 Enterprise
 
#5

AW: XML geschachteltes selectNodes liefert falsches Ergebnis zurück

  Alt 28. Mär 2017, 12:45
Fantastisch. Hab vielen Dank. Der Punkt war es.
Swen
  Mit Zitat antworten Zitat
Benutzerbild von sakura
sakura

Registriert seit: 10. Jun 2002
Ort: München
11.579 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: XML geschachteltes selectNodes liefert falsches Ergebnis zurück

  Alt 28. Mär 2017, 12:58
Fantastisch. Hab vielen Dank. Der Punkt war es.
// - suche alle passenden Node (auch in Unterebenen) ab der ROOT-Node
.// - suche alle passenden Node (auch in Unterebenen) ab der aktuellen Node

......
Daniel W.
Ich bin nicht zurück, ich tue nur so
  Mit Zitat antworten Zitat
Benutzerbild von juergen
juergen

Registriert seit: 10. Jan 2005
Ort: Bönen
1.017 Beiträge
 
Delphi 10.3 Rio
 
#7

AW: XML geschachteltes selectNodes liefert falsches Ergebnis zurück

  Alt 6. Aug 2019, 00:03
Hallo zusammen,

nach dem oben aufgezeigten Beispiel versuche ich alle span-Nodes innerhalb von dem "DetailAddText"-Node aus einem XML-File auszulesen.
Ich hatte angenommen, dass das o.g. Beispiel für mich richtig ist.
Mir geht's um alle Texte bei allen span-Nodes innerhalb des "DetailAddText"-Node, wie z.B. V E R T R A G L I C H E R E G E L U N G E N


Code:
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<xxxx xmlns="http://www.xxxxxxx">
   <xxxInfo>
      <Version>3.1</Version>
      <VersDate>2009-12</VersDate>
      <Date>2012-02-29</Date>
      <Time>16:29:12</Time>
      <ProgSystem>xxxxx GmbH</ProgSystem>
      <ProgName>xxxxxx</ProgName>
   </xxxInfo>
   <PrjInfo>
      <NamePrj>Beispielprojekt</NamePrj>
      <LblPrj>Musterprojekt</LblPrj>
      <Cur>EUR</Cur>
      <CurLbl>Euro</CurLbl>
      <UPFracDig>2</UPFracDig>
   </PrjInfo>
   <Award>
      <DP>83</DP>
      <AwardInfo>
         <Cur>EUR</Cur>
         <CurLbl>Euro</CurLbl>
         <EvalEnd>2011-12-20</EvalEnd>
         <SumbLoc>siehe Anschrift AG</SumbLoc>
      </AwardInfo>
      <OWN>
         <Address>
            <Name1>xxxx GmbH</Name1>
            <Street>xxxxxstr. 4</Street>
            <PCode>12345</PCode>
            <City>Musterhausen</City>
            <Country>Deutschland</Country>
            <Phone>0049 123456789-0</Phone>
            <Fax>0049 123456789-10</Fax>
         </Address>
      </OWN>
      <AddText>
         <OutlineAddText>
            <p style="text-align:left;">
               <span style="font-family:'Courier New CYR';font-size:10pt;"> </span>
            </p>
         </OutlineAddText>
         <DetailAddText>
            <p style="text-align:left;">
               <span style="font-family:'Arial';">         V E R T R A G L I C H E  R E G E L U N G E N</span>
            </p>
            <p style="text-align:left;">
               <span style="font-family:'Arial';">                vor der Angebotsaufforderung</span>
            </p>
            <p style="text-align:left;">
               <span style="font-family:'Arial';">                      Stand: </span>
               <span style="font-family:'Arial';font-size:12pt;">20.12.2011</span>
            </p>
            <p style="text-align:left;">
               <span style="font-family:'Courier New';font-size:10pt;">1 ALLGEMEINER TEIL</span>
            </p>
            <p style="text-align:left;">
               <span style="font-family:'Courier New';font-size:10pt;">1.1 Geltungsbereich, Allgemeines</span>
            </p>
            <p style="text-align:left;">
               <span style="font-family:'Courier New';font-size:10pt;">1.1.1 Diese Vorbemerkungen sind ZUSÄTZLICHE TECHNISCHE</span>
            </p>
            <p style="text-align:left;">
               <span style="font-family:'Courier New';font-size:10pt;">VERTRAGSBEDINGUNGEN - ZTV.</span>
            </p>
         </DetailAddText>
         <Zusatz>
            <p style="text-align:left;">
               <span style="font-family:'Arial';">         ZUSATZVEREINBARUNGEN</span
            </p>
         </Zusatz>
      </AddText>
   </Award>
</xxxx>
Mein momentaner Code:

Delphi-Quellcode:
...
VAR
  xXMLDoc: IXMLDOMDocument2;
  NodeList: IXMLDOMNodeList;
  xXPath: STRING;
  i: Integer;
BEGIN
  Memo_tmp.Clear;
  xXMLDoc := CoDOMDocument.Create;
  xXMLDoc.Load(gsFileName);

  xXPath := '//Award/AddText/DetailAddText/p/span';

  NodeList := xXMLDoc.selectNodes(xXPath);
  Showmessage(IntToStr(NodeList.Length)); // <-- zeigt immer 0 an
...
Egal was ich nun unter xXPath eingebe, die ShowMessage zeigt mir immer 0 an für NodeList.Length…

Ich würde mich sehr freuen wenn mir jemand helfen könnte.

Vielen Dank schon mal vorab!
Jürgen
Indes sie forschten, röntgten, filmten, funkten, entstand von selbst die köstlichste Erfindung: der Umweg als die kürzeste Verbindung zwischen zwei Punkten. (Erich Kästner)
  Mit Zitat antworten Zitat
Benutzerbild von juergen
juergen

Registriert seit: 10. Jan 2005
Ort: Bönen
1.017 Beiträge
 
Delphi 10.3 Rio
 
#8

AW: XML geschachteltes selectNodes liefert falsches Ergebnis zurück

  Alt 6. Aug 2019, 00:25
Es ist wohl schon zu spät für mich heute. Ich trau es mir gar nicht zu sagen.
Anstelle meiner globalen Variablen gs_FileName die den Pfad und den Dateinamen der XML-Datei hält, hatte ich gsFileName, tatsächliche wird dieses in Vcl.Graphics verwendet!!! Es kam auch keine Fehlermeldung, so dass ich immer dachte mein XPath wäre falsch...
Jetzt funktioniert alles.

Gute N8!
Jürgen
Indes sie forschten, röntgten, filmten, funkten, entstand von selbst die köstlichste Erfindung: der Umweg als die kürzeste Verbindung zwischen zwei Punkten. (Erich Kästner)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 09:55 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf