AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

TAdvMemo - Probleme

Ein Thema von haentschman · begonnen am 1. Mai 2017 · letzter Beitrag vom 2. Mai 2017
Antwort Antwort
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
5.000 Beiträge
 
Delphi 11 Alexandria
 
#1

TAdvMemo - Probleme

  Alt 1. Mai 2017, 18:40
Hallöle...

Ich beneide die, die sich aus der GUI nichts machen.

Im Moment quäle ich mich den Memos rum. TAdvMemo stammt aus meiner bevorzugten Bibliothek. Da kann man doch denken, das die Schriften eines Edits mit dem des Memos zusammenpassen. Das Edit hat Tahoma, Size 8. Nur kommen bei dieser Schriftart, und anderen, beim Memo komische Ergebnisse heraus. Nur die Standard Schriftart COURIER NEW, Size 10 kann man einfach eingeben.

PS: Das ist auch bei SynEdit so. Die exakt gleiche eingestellte Schriftart, im Vergleich zum Edit, ergibt zur Laufzeit andere optische Ergebnisse.

Bilder:

1: Standardschriftart...ok mit Selektieren und eintragen, aber falsche Schrift
2: Tahoma...eintragen. Der Cursor steht gefühlt 20 Stellen weiter und der Abstand erhöht sich mit der Anzahl der Zeichen dynamisch.
3: Tahoma...selektiert aus 2:. Der Cursor steht irgendwo vor dem Selected. Selektiert wird irgendwas.

Bevor ich meinem Unmut Gehör (beim Hersteller) verschaffe, bitte ich um Bestätigung.

Danke.

PS: Die Cursorpositionen sind als rote Rechtecke gekennzeichnet.
IDE: Berlin mit aktuellem ComponentPack
Miniaturansicht angehängter Grafiken
normal_courier-new_standard.png   fehler_tahoma.png   fehler_tahoma_selektiert.png  

Geändert von haentschman ( 1. Mai 2017 um 21:13 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
9.507 Beiträge
 
Delphi 11 Alexandria
 
#2

AW: TAdvMemo - Probleme

  Alt 1. Mai 2017, 21:05
Bei mir lässt TAdvMemo den Font Tahoma überhaupt nicht zu! Es ändert das automatisch (spätestens beim Run) auf FixedSys. Ist wohl dem Verwendungszweck (Source Code Editor) geschuldet.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
5.000 Beiträge
 
Delphi 11 Alexandria
 
#3

AW: TAdvMemo - Probleme

  Alt 1. Mai 2017, 21:16
Du hast Recht beim Auswählen über die Fontauswahl. Wenn du im OI den Fontnamen direkt auswählst dann geht das... mehr oder weniger.
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
9.507 Beiträge
 
Delphi 11 Alexandria
 
#4

AW: TAdvMemo - Probleme

  Alt 1. Mai 2017, 23:06
Du hast Recht beim Auswählen über die Fontauswahl. Wenn du im OI den Fontnamen direkt auswählst dann geht das... mehr oder weniger.
Auch das ist (zumindest hier bei mir) trügerisch: Obwohl in der IDE Tahoma angezeigt wird, schaltet er im laufenden Programm wieder auf FixedSys.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
8.123 Beiträge
 
Delphi 10.4 Sydney
 
#5

AW: TAdvMemo - Probleme

  Alt 2. Mai 2017, 04:20
Hallo,
tja das wohl per Design so
https://www.tmssoftware.com/site/tip...s=faq&show=225

Lösung: andere Komponente für diesen Zweck benutzen.
Heiko
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
5.000 Beiträge
 
Delphi 11 Alexandria
 
#6

AW: TAdvMemo - Probleme

  Alt 2. Mai 2017, 05:12
Moin...
Zitat:
tja das wohl per Design so
...dann sollten sie das Ding nicht MEMO nennen.
Zitat:
Lösung: andere Komponente für diesen Zweck benutzen.
...so einfach ist das nicht. Andere Komponenten passen nicht in den Stil. (Theme, BorderColor etc.)

Danke.

Geändert von haentschman ( 2. Mai 2017 um 10:20 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
9.507 Beiträge
 
Delphi 11 Alexandria
 
#7

AW: TAdvMemo - Probleme

  Alt 2. Mai 2017, 08:06
Zitat:
Lösung: andere Komponente für diesen Zweck benutzen.
...so einfach ist das nicht. Andere Komponenten passen nicht in den Stil. (Theme, BorderCorlor etc.)
Was ist denn mit TAdvRichEditor?
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
bnreimer42

Registriert seit: 26. Mai 2013
Ort: Erlangen, Franken
118 Beiträge
 
Delphi 11 Alexandria
 
#8

AW: TAdvMemo - Probleme

  Alt 2. Mai 2017, 08:19
Schau Dir mal TAdvRichEditor an, ob Du damit zu recht kommst.
Björn Reimer
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
5.000 Beiträge
 
Delphi 11 Alexandria
 
#9

AW: TAdvMemo - Probleme

  Alt 2. Mai 2017, 10:18
Dankeschön...
Der TAdvRichEditor paßt nicht in den Style weil der Rahmen immer grau ist. Ich habe nun ein Panel aus dem Style benutzt und ein TMemo mit Margins = 1 draufgelegt. Da sieht das wie mit dem richtigen Rahmen aus.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 22:57 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf