AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Cross-Platform-Entwicklung Delphi Keine Verbindung zu Linux-PAServer

Keine Verbindung zu Linux-PAServer

Ein Thema von Rainer Wolff · begonnen am 3. Dez 2017 · letzter Beitrag vom 13. Dez 2017
Antwort Antwort
Rainer Wolff

Registriert seit: 25. Okt 2005
Ort: Bretten
240 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#1

Keine Verbindung zu Linux-PAServer

  Alt 3. Dez 2017, 12:33
Hallo,

nachdem ich über diverse Blog-Einträge und Tutorials gestolpert bin, wollte ich auch mal ein Hello-World unter Linux laufen lassen, leider bin ich mal wieder erfolglos, und google hilft auch nicht wirklich weiter.

Wenn ich ein Test Connection auf den PAServer mache, erhalte ich immer nur die Meldung

Remote error: Unauthorized user, all server requests are ignored

Ob ich nun ein Passwort setze oder nicht, grad egal. Linux Ubuntu Server 16.04 (die Desktop-Version erzählt den gleichen Müll). Firewall auf beiden Rechnern deaktiviert. Ubuntu läuft innerhalb einer VMWare. Ping geht in beide Richtungen.
  Mit Zitat antworten Zitat
mensch72

Registriert seit: 6. Feb 2008
757 Beiträge
 
#2

AW: Keine Verbindung zu Linux-PAServer

  Alt 3. Dez 2017, 14:15
Laut Profil: "Delphi 10.1 Berlin Enterprise"

das funktioniert doch erst ab Tokyo?!
aber "zufällig" installiere ich es auch gerade auf einem neuem komplett VMware basieren System.

Ziel: DelphiVM(10.2u1 auf Win10-1709), OSXvm(10.13), UbuntoVM(17.10)
Delhpi & Android unter Windows laufen, unter OSx läuft nun auch FMX für OSX&IOS, die aktuelle UbuntoVM von "osboxes" entwickelt sich langsam...

Google & Inet sei Dank... erst zusätzlich
sudo apt-get update
sudo apt-get install net-tools

dann gemäß "http://www.osboxes.org/guide/
sudo ./vmware-install.pl

Jetzt kommt der PAserver und der zusätzliche PAserver Patch... alles wird gut, denn unter OSX ging es ja auch "fast problemlos"

Zum Schluss noch FMXlinux und CrossVCL... dann gibt es hoffentlich "HelloWorld" für jeweils für Console, FMX und VCL

Geändert von mensch72 ( 3. Dez 2017 um 14:31 Uhr)
  Mit Zitat antworten Zitat
Rainer Wolff

Registriert seit: 25. Okt 2005
Ort: Bretten
240 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#3

AW: Keine Verbindung zu Linux-PAServer

  Alt 10. Dez 2017, 13:31
Hatte jetzt nochmal Zeit zum rumprobieren, leider immer noch erfolglos. Ich habe jetzt noch ein Dead Rat Linux aufgesetzt, und auch diesen PAServer-Patch noch eingespielt, aber erhalte immer noch die Meldung (sowohl unter Ubuntu als auch Dead Rat).

Code:
Remote error: Unauthorized user, all server requests are ignored
Versuche mit und ohne Password, Passwortfile generieren mit PAServer und in Delphi importieren, alles erfolglos.

Wenn das Passwort nicht zusammenpasst, erhalte ich eine andere Meldung:

Code:
TDBXError: Remote error: Authentication manager rejected user credentials. This may due to invalid combination of DS user name and password
Also reden tun die miteinander, aber verstehen tun sie sich nicht. Dead-Rat-Distro ist die 7.3, mein Windoof ist auf dem Herbst-Update 1709

Die eingesetzte Version ist im übrigen natürlich Tokyo, 10.2.1, habs im Profil korrigiert.
  Mit Zitat antworten Zitat
Benutzerbild von Harry Stahl
Harry Stahl

Registriert seit: 2. Apr 2004
Ort: Bonn
1.712 Beiträge
 
Delphi 10.3 Rio
 
#4

AW: Keine Verbindung zu Linux-PAServer

  Alt 10. Dez 2017, 17:02
Ich gehe mal davon aus, dass Dein Windows-User Name keine Sonderzeichen oder deutschen Umlaute enthält (das kann u.U. zu solchen Authentifizierungs-Problemen führen).

Davon abgesehen solltest Du sicherstellen, dass Dein Ubuntu eine andere IP-Adresse als Dein Windows hat (also nicht die IP sharen).
Ferner sollten beide Rechner in dem gleichen Netzwerk sein.

Weiter könntest Du mal versuchen, eine SMB-Verbindung vom Linux-Rechner auf z.B. ein in Windows freigegebenes Laufwerk einrichten (oder auch umgekehrt). Nach meiner Erfahrung erleichtern solche einmal eingerichteten Netzwerkverbindungen auch andere Netzwerkaktivitäten, bzw. wenn schon das nicht klappt, dann erhält man evtl. mehr Informationen wo Probleme in der Verbindung bestehen könnten.

Ich persönlich arbeite so, dass ich Ubuntu 16.04 LTS als Bootsystem auf dem Rechner habe und Windows 10 in einer virtuellen Maschine (Virtualbox) läuft, das funktioniert ganz hervorragend.
  Mit Zitat antworten Zitat
Rainer Wolff

Registriert seit: 25. Okt 2005
Ort: Bretten
240 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#5

AW: Keine Verbindung zu Linux-PAServer

  Alt 10. Dez 2017, 20:47
Ich gehe mal davon aus, dass Dein Windows-User Name keine Sonderzeichen oder deutschen Umlaute enthält (das kann u.U. zu solchen Authentifizierungs-Problemen führen).
Den Hinweis hatte ich schon irgendwo bei der Recherche gefunden, ist aber nicht der Fall

Davon abgesehen solltest Du sicherstellen, dass Dein Ubuntu eine andere IP-Adresse als Dein Windows hat (also nicht die IP sharen).
Das war nicht der Fall, da hab ich jetzt aber auch nochmals rumgefummelt: gleiches Ergebnis.
Ich habe zuhause zwar momentan einen etwas komplizierteren Netzaufbau, aber nachdem ich den Hostrechner jetzt direkt an den ersten Router gehängt habe, sind Delphi und Ubuntu/Red Hat im selben Netzwerk unterwegs, WLAN (über das vorher alles im Netz hing), ist deaktiviert,
Weiter könntest Du mal versuchen, eine SMB-Verbindung vom Linux-Rechner auf z.B. ein in Windows freigegebenes Laufwerk einrichten (oder auch umgekehrt). Nach meiner Erfahrung erleichtern solche einmal eingerichteten Netzwerkverbindungen auch andere Netzwerkaktivitäten, bzw. wenn schon das nicht klappt, dann erhält man evtl. mehr Informationen wo Probleme in der Verbindung bestehen könnten.
Auch das habe ich jetzt noch zusammengebastelt, Ubuntu schaut auf meine Windows-Freigabe, aber die Fehlermeldung bleibt die selbe
  Mit Zitat antworten Zitat
Benutzerbild von Harry Stahl
Harry Stahl

Registriert seit: 2. Apr 2004
Ort: Bonn
1.712 Beiträge
 
Delphi 10.3 Rio
 
#6

AW: Keine Verbindung zu Linux-PAServer

  Alt 10. Dez 2017, 22:03
OK. Welche Ubuntu-Version nutzt Du genau?

Wo hast Du das PAServer-Programm "installiert"? Evtl. in einem Shared-Folder?
Dann kopiere es lieber in einen UnterOrdner des Dokumenten-Ordners und starte das PAServer-Programm von dort aus.

Wenn das nicht hilft: Macht es einen Unterschied, wenn Du den PAServer (Version 10.1.1.33 sollte es sein) per sudo startest?

Klick doch mal in Ubuntu im Dateimanager mit der rechten Maustaste auf das paserver-programm und wähle im angezeigten Dialog das Register "Zugriffsrechte". Was wird dort angezeigt? Steht dort bei "Gruppe" der Name des aktuell angemeldeten Users?
  Mit Zitat antworten Zitat
Rainer Wolff

Registriert seit: 25. Okt 2005
Ort: Bretten
240 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#7

AW: Keine Verbindung zu Linux-PAServer

  Alt 11. Dez 2017, 10:51
OK. Welche Ubuntu-Version nutzt Du genau?

Wo hast Du das PAServer-Programm "installiert"? Evtl. in einem Shared-Folder?
Dann kopiere es lieber in einen UnterOrdner des Dokumenten-Ordners und starte das PAServer-Programm von dort aus.

Wenn das nicht hilft: Macht es einen Unterschied, wenn Du den PAServer (Version 10.1.1.33 sollte es sein) per sudo startest?

Klick doch mal in Ubuntu im Dateimanager mit der rechten Maustaste auf das paserver-programm und wähle im angezeigten Dialog das Register "Zugriffsrechte". Was wird dort angezeigt? Steht dort bei "Gruppe" der Name des aktuell angemeldeten Users?
Die Version des PAServers ist inzwischen 10.1.1.37 ( PAserver Patch siehe Hinweis von Mensch72 weiter oben)

Meine beiden Linux-Server sind Kommandozeilen-Server-Versionen (von daher nix Rechtsclick), installiert ist der PAServer im Unterordner meines Home-Verzeichnises, Eigentümer und gruppe ist mein Username.
Und auch per Sudo starten bringt nichts (gerade nochmal versucht, hatte ich aber auch schon vorher mal irgendwann getestet)
  Mit Zitat antworten Zitat
Rainer Wolff

Registriert seit: 25. Okt 2005
Ort: Bretten
240 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#8

AW: Keine Verbindung zu Linux-PAServer

  Alt 13. Dez 2017, 20:32
Auch mit dem neuen Tokyo-Update 10.2 die selben Probleme. Delphi hat erkannt, dass auf der Linux-Kiste noch ein älterer PAServer läuft, nach Update des PAServer wieder das Authentifizierungsproblem.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 00:56 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf