AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Cross-Platform-Entwicklung Neuste Delphiversion - kann keine Android App erstellen

Neuste Delphiversion - kann keine Android App erstellen

Ein Thema von Klapauzius · begonnen am 8. Feb 2018 · letzter Beitrag vom 9. Nov 2018
Antwort Antwort
Seite 2 von 3     12 3   
MichaelT

Registriert seit: 14. Sep 2005
381 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#11

AW: Neuste Delphiversion - kann keine Android App erstellen

  Alt 9. Feb 2018, 11:34
Gibt es irgendein verlässlichen Android Device neben dem Nexus 7 der mit Delphi geht. Mir ist schon klar, dass es ARM sein soll, 8 Cores vermutlich, Grafikchip usw... Bisher hatte ich nur den Emulator und die Trial Versionen von Delphi zur Verfügung. Das ging so lala zumindest mal konnte ich einen positiven Eindruck gewinnen.

Nexus 7 ist super, habe (hatte) ich auch.

Hat leider den Geist aufgegeben, wg. Hardware-Taster, aber Orginal Google Hardware ist am Problemlosesten.

Rollo
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
1.669 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#12

AW: Neuste Delphiversion - kann keine Android App erstellen

  Alt 9. Feb 2018, 13:20
Schwer zu sagen, ich hätte da auch gerne eine verlässliche Liste.

Ich habe bisher auch immer mit Samsung Galaxy Geräten gearbeitet, aber da gab es Neuerdings bei einigen auch ein Problem mit dem Debuggen.
Mit einem Samsung Galaxy Typ (A3 glaube ich) gab es diese Probleme, mein S7 Edge funktioniert gut, es sieht für mich so aus als wäre das behoben.

Probleme gibt es noch bei der Sensor-Unterstützung seit Android 6.x.x, das haben aber auch andere, liegt nicht an Delphi.

Wichtig ist das es überhaupt USB-Debugging unterstützt nd gute Treiber mitliefert,
das ist bei Allen Google-Geräten eigentlich immer gegeben.
Leider gibt es ja nur noch die teuren Pixel von Google.

Womöglich gibt es ADB-Treiber nicht bei Allen Herstellen, da würde ich immer VORHER nachfragen.

Google kannst du glaube ich blind kaufen, bei Allen anderen am Besten ein Gerät aussuchen und dann hier mal konkret nachfragen, wer das schon einsetzt.

Rollo
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
381 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#13

AW: Neuste Delphiversion - kann keine Android App erstellen

  Alt 9. Feb 2018, 16:51
Danke.

Ich hatte bisher nur ein iPAD2 und den XCode. Die Kombination funktioniert ganz gut und Android ging immer irgendwie mit Emulator. Eine GUI habe ich nie grafisch designed sondern einfach die XML Datei mit der Hand angepasst.

Aber mein 15 Jahre altes Handy segnet langsam das Zeitliche.

Ich will allein nicht zuviel Geld für Dinge die ich hernach nicht mehr brauchen kann ausgeben. In dem Sinne besten Dank für das Feedback.

Eine Frage zur Entwicklung. Braucht man einen eigenen Mobile Device im Sinne, dass zuviele Schreibzugriffe auf den vermutlich auf Flash basierten Speicher kaputt machen oder ist das Thema heute nicht mehr aktuell?


Schwer zu sagen, ich hätte da auch gerne eine verlässliche Liste.

Ich habe bisher auch immer mit Samsung Galaxy Geräten gearbeitet, aber da gab es Neuerdings bei einigen auch ein Problem mit dem Debuggen.
Mit einem Samsung Galaxy Typ (A3 glaube ich) gab es diese Probleme, mein S7 Edge funktioniert gut, es sieht für mich so aus als wäre das behoben.

Probleme gibt es noch bei der Sensor-Unterstützung seit Android 6.x.x, das haben aber auch andere, liegt nicht an Delphi.

Wichtig ist das es überhaupt USB-Debugging unterstützt nd gute Treiber mitliefert,
das ist bei Allen Google-Geräten eigentlich immer gegeben.
Leider gibt es ja nur noch die teuren Pixel von Google.

Womöglich gibt es ADB-Treiber nicht bei Allen Herstellen, da würde ich immer VORHER nachfragen.

Google kannst du glaube ich blind kaufen, bei Allen anderen am Besten ein Gerät aussuchen und dann hier mal konkret nachfragen, wer das schon einsetzt.

Rollo
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
1.669 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#14

AW: Neuste Delphiversion - kann keine Android App erstellen

  Alt 9. Feb 2018, 17:01
Zitat:
mein 15 Jahre altes Handy
Also da tut es ja fast schon jedes aktuelle Volksphone
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
381 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#15

AW: Neuste Delphiversion - kann keine Android App erstellen

  Alt 10. Feb 2018, 10:57
Schurlos ist davon nicht mehr weit entfernt.


Zitat:
mein 15 Jahre altes Handy
Also da tut es ja fast schon jedes aktuelle Volksphone
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
6.199 Beiträge
 
Delphi 10.2 Tokyo Architect
 
#16

AW: Neuste Delphiversion - kann keine Android App erstellen

  Alt 10. Feb 2018, 11:33
Es gibt ganz frisch einen Patch für Tokyo Upd 2. Keine Ahnung, ob der jetzt auch dieses Problem löst.

ID: 30819, RAD Studio 10.2.2 Tokyo February 2018 Patch
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
zeras

Registriert seit: 11. Mär 2007
Ort: Langeneichstädt
1.035 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#17

AW: Neuste Delphiversion - kann keine Android App erstellen

  Alt 10. Feb 2018, 17:29
Es gibt ganz frisch einen Patch für Tokyo Upd 2. Keine Ahnung, ob der jetzt auch dieses Problem löst.

ID: 30819, RAD Studio 10.2.2 Tokyo February 2018 Patch
Habe nun das Hotfix installiert und folgende Meldung bekommen.
Miniaturansicht angehängter Grafiken
hotfix_eventuell_nicht_richtig_installiert.png  
Matthias
Manchmal kommt es anders, wenn man denkt.
(Daniel Keiper-Knorr)
  Mit Zitat antworten Zitat
mensch72

Registriert seit: 6. Feb 2008
747 Beiträge
 
#18

AW: Neuste Delphiversion - kann keine Android App erstellen

  Alt 10. Feb 2018, 18:03
..."und folgende Meldung bekommen."...

uff, dann mal so die "üblichen Fragen":
- das Ganze mal mit als 100% CleanInstall versucht ?(also "ActualWin10"+"CleanTokyo1022.2004" und auch da reproduzierbar ?
- was für ein Windows(bei WIn10 exakt das was "winver" ausspuckt) ?
- aktiver Virentest ?
- aktiver Spy&Malwarescanner ?
- aktiver RegistryTracker ?
- LocalUser oder DomainControled ActiveDirectoryUser ?
- physische Maschine(AMD oder Intel) oder VM(welche VMware,VirtualBox,..) sowie 32 oder 64Bit und wie viel RAM?
- Grafikkarte (Intel, AMD oder Nvidia) ?
- Java SDK&NDK-Version ?
- Delphi "Tokyo1022.2004" zuletzt per ISOinstaller oder WEBinstaller installiert ?
- Delphi "Tokyo1022.2004" mit oder ohne Patch von Mr. Hausladen ?
- Delphi "Tokyo1022.2004" zuletzt per GetIT und/oder anderen Komponenten erweitert(wenn ja welche und wie) ?
=> Fragen über Fragen

Ich werde es Montag mal fix mit meiner archivierten "CleanInstall-VM" unseres "Tokyo1022.2004" versuchen... wenn das geht benenne ich dann das Windows in der VM auf "???DE1022K4hf182" um... das kostet uns zwar wieder einen Lizenz-Zähler, aber das ist egal. Emba/Idera haben bisher nie gemeckert, wenn man einen Zähler-Reset mit nachweisbarem Bezug auf eine nach einem neuem Update/Hotfix zur Archivierung nötige separate Installation begründet. (sonst dann März/April eben erst beim neuem 10.3RTM )
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
1.669 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#19

AW: Neuste Delphiversion - kann keine Android App erstellen

  Alt 10. Feb 2018, 20:42
Warning:
https://quality.embarcadero.com/browse/RSP-19913
Es könnte mit dem Hotfix was nicht stimmen ...

! Vorher sichern ...

Edit:
Noch mehr Warnungen, und eine traurige Nachricht ...

Rollo

Geändert von Rollo62 (11. Feb 2018 um 12:24 Uhr)
  Mit Zitat antworten Zitat
Redeemer
Online

Registriert seit: 19. Jan 2009
Ort: Kirchlinteln (LK Verden)
410 Beiträge
 
Delphi 2009 Professional
 
#20

AW: Neuste Delphiversion - kann keine Android App erstellen

  Alt 10. Feb 2018, 23:55
Es gibt ganz frisch einen Patch für Tokyo Upd 2. Keine Ahnung, ob der jetzt auch dieses Problem löst.

ID: 30819, RAD Studio 10.2.2 Tokyo February 2018 Patch
Habe nun das Hotfix installiert und folgende Meldung bekommen.
Diese Meldung kommt doch ständig bei Windows, wenn eine Installation erfolgreich war...
Janni
2005 PE, 2009 PA, XE2 PA
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 22:17 Uhr.
Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2018 by Daniel R. Wolf