AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Programmieren allgemein Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

Ein Thema von JFB · begonnen am 17. Jul 2018 · letzter Beitrag vom 18. Jul 2018
Antwort Antwort
Seite 1 von 2  1 2   
JFB

Registriert seit: 8. Apr 2005
57 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#1

Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

  Alt 17. Jul 2018, 15:28
Hallo,

ich habe ein merkwürdiges Problem beim Versuch, eine Methode in einer Delphi-Dll (habe ich als Anhang beigefügt) aus einer DotNet-Anwendung aufzurufen.

Ich habe folgenden Code:

Code:
// c#-Programm
// ===========
using System;
using System.Runtime.InteropServices;

namespace ConsoleApp3
{
    class Program
    {
        [StructLayout(LayoutKind.Sequential, CharSet = CharSet.Ansi, Pack = 1)]
        public struct TPara1Rec
        {
            public double Jahresumsatz1;
            public double Jahresumsatz2;
            public double Aufwendungen;
            public double Privateinlagen;
            public double Privatentnahmen;
            public double LandwFlaeche;
            public double ForstFlaeche;
            public double Teichflaeche;

            [MarshalAs(UnmanagedType.ByValTStr, SizeConst = 3 + 1)]
            public string Waehrung; // EUR

            public bool P39A3;
        }

        [DllImport("DStbVV2012.dll", EntryPoint = "Gegenstandswerte", CallingConvention = CallingConvention.StdCall, CharSet = CharSet.Ansi)]
        private static extern void DStbVV2012_Gegenstandswerte(ref TPara1Rec para, ref double pWertDa, ref double pWertDb, IntPtr ptr);

        static void Main(string[] args)
        {
            TPara1Rec para1 = new TPara1Rec() { Aufwendungen = 1154659.74d, ForstFlaeche = 4.95d, Jahresumsatz1 = 1219758.83d, Jahresumsatz2 = 12, LandwFlaeche = 219.26d, P39A3 = false, Privateinlagen = 67148.41d, Privatentnahmen = 157779.99d, Teichflaeche = 0d, Waehrung = "EUR" };
            double para2 = 0;
            double para3 = 0;
            IntPtr ptr = IntPtr.Zero;

            DStbVV2012_Gegenstandswerte(ref para1, ref para2, ref para3, ptr);
        }
    }
}

// Delphi-Dll DStbVV2012.dll
// =========================

  TPara1Rec = packed record
    Jahresumsatz1   :real;
    Jahresumsatz2   :real;
    Aufwendungen   :real;
    PrivatEinlagen :real;
    PrivatEntnahmen :real;
    LandwFlaeche   :real;
    ForstFlaeche   :real;
    TeichFlaeche   :real;
    VerpachtFlaeche :real;
    Waehrung       :AnsiString;
    P39A3           :boolean;
  end;

procedure Gegenstandswerte(var Para :TPara1Rec;
                           var pWertDA,pWertDB :real;
                           Para4Ptr:TPara4Ptr = nil);

var W_BETRAG_1, W_BETRAG_2, ZWI_BETRAG_1,ZWI_BETRAG_2,ZWI_BETRAG_3,ZWI_BETRAG_4,
    w_jahresumsatz_je_ha, W_MULTIPLIKATOR,mp : real;
begin
  if Para.Waehrung = 'DEM' then mp := cEuroFaktor else mp := 1;

  W_BETRAG_1 := Para.JahresUmsatz1 / mp +
                          Para.PrivatEinlagen / mp;
                         
  // Weiterer Code
end;
Wenn ich die Delphi-Dll debugge, ist der Parameter "Para" nicht verfügbar und es kommt zu einer Schutzverletzung. Entfernt man in der C#-Anwendung im Feld para1.Jahresumsatz1 die Nachkommastellen (statt 1219758.83d nur 1219758 übergeben) funktioniert alles wunderbar.

Ich bin ratlos. Hat jemand eine Idee?
Bin nur noch heute und morgen in der Firma, dann erst nächste Woche wieder. Kann also auf Rückfragen u.U. nicht sofort antworten.

Gruß
Johann
Angehängte Dateien
Dateityp: zip DStbVV2012.zip (357,5 KB, 3x aufgerufen)

Geändert von JFB (17. Jul 2018 um 16:00 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von KodeZwerg
KodeZwerg

Registriert seit: 1. Feb 2018
3.166 Beiträge
 
Delphi 10.3 Rio
 
#2

AW: Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

  Alt 17. Jul 2018, 15:34
1219758.83d
Ist das ein Schreibfehler mit dem "d" am Ende?
Gruß vom KodeZwerg
  Mit Zitat antworten Zitat
JFB

Registriert seit: 8. Apr 2005
57 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#3

AW: Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

  Alt 17. Jul 2018, 15:37
1219758.83d
Ist das ein Schreibfehler mit dem "d" am Ende?
Nein, das ist notwendig, damit der C#-Compiler weiß, in welches Format das Literal konvertiert werden soll. In diesem Fall bedeutet "d" = double.
  Mit Zitat antworten Zitat
Benutzerbild von KodeZwerg
KodeZwerg

Registriert seit: 1. Feb 2018
3.166 Beiträge
 
Delphi 10.3 Rio
 
#4

AW: Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

  Alt 17. Jul 2018, 15:45
Nur so eine Idee, ich weiß nicht genau zwischen C# <-> Delphi wie das intern abläuft aber vielleicht kann Dir ein Frac() helfen.
Also Vorkomma und Kommata Werte einzeln schicken. Tut mir leid falls das völliger Blödsinn ist!
Gruß vom KodeZwerg
  Mit Zitat antworten Zitat
JFB

Registriert seit: 8. Apr 2005
57 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#5

AW: Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

  Alt 17. Jul 2018, 15:48
Nur so eine Idee, ich weiß nicht genau zwischen C# <-> Delphi wie das intern abläuft aber vielleicht kann Dir ein Frac() helfen.
Also Vorkomma und Kommata Werte einzeln schicken. Tut mir leid falls das völliger Blödsinn ist!
Du hast die Antwort selbst gegeben: Völliger Blödsinn. Wenn die Struct nur einen double-Wert für Jahresumsatz1 hat, kann ich natürlich nicht einfach zwei daraus machen, zumal ich die aufgerufene Dll nicht ändern darf.
  Mit Zitat antworten Zitat
Benutzerbild von KodeZwerg
KodeZwerg

Registriert seit: 1. Feb 2018
3.166 Beiträge
 
Delphi 10.3 Rio
 
#6

AW: Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

  Alt 17. Jul 2018, 15:55
Könnte es sein das C# String nicht mit Delphi String eins ist?
Probehalber String mit PAnsiChar tauschen und testen, ginge das? (in der DLL, nicht im C#, auch wenn du DLL nicht verändern darfst)
Gruß vom KodeZwerg
  Mit Zitat antworten Zitat
JFB

Registriert seit: 8. Apr 2005
57 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#7

AW: Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

  Alt 17. Jul 2018, 16:04
Hatte vergessen, für den Delphi-Teil die Deklaration des Übergabeparameters hinzuzufügen. Habe ich jetzt gemacht (siehe Anfangsposting).

Der C#-String wird in einen AnsiString umgewandelt ([MarshalAs(UnmanagedType.ByValTStr, SizeConst = 3 + 1)]).

Gruß
Johann
  Mit Zitat antworten Zitat
Benutzerbild von KodeZwerg
KodeZwerg

Registriert seit: 1. Feb 2018
3.166 Beiträge
 
Delphi 10.3 Rio
 
#8

AW: Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

  Alt 17. Jul 2018, 16:10
Überall wo ich lese, wie hier zum Beispiel wird kein direkter String genutzt sondern die Pointer-Variante, deswegen fragte ich ob Du das mal testen könntest (das betrifft nur die Delphi DLL und nicht dein C#)
Gruß vom KodeZwerg
  Mit Zitat antworten Zitat
TiGü

Registriert seit: 6. Apr 2011
Ort: Berlin
2.861 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#9

AW: Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

  Alt 17. Jul 2018, 16:19
In Delphi einen WideString umändern und in C# einen UnmanagedType.BStr konvertieren.
Siehe: https://social.msdn.microsoft.com/Fo...=csharpgeneral
  Mit Zitat antworten Zitat
JFB

Registriert seit: 8. Apr 2005
57 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#10

AW: Aufruf Delphi-Dll von DotNet, Probleme mit struct-Parameter

  Alt 18. Jul 2018, 10:21
@KodeZwerg:
Vielen Dank! Du hast mich auf die richtige Spur gebracht. Meine Lösung sieht jetzt folgendermaßen aus:

In der Delphi-Dll habe ich AnsiString durch PAnsiChar ersetzt. Das allein reichte aber noch nicht, da dadurch zwar kein Fehler mehr auftrat, das Währungs-Feld der Struktur aber nur als leerer String übergeben wurde. In der C#-Struktur habe ich das Währungsfeld in Unmanaged.LPStr (statt wie bisher in UnmanagedType.ByValTStr) geändert.

Hier ist eine ganz gute Beschreibung der Problematik:
https://limbioliong.wordpress.com/20...d-code-part-1/
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 09:37 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf