AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Compilerfehler F2085

Ein Thema von Gagamba · begonnen am 15. Sep 2018 · letzter Beitrag vom 21. Sep 2018
Antwort Antwort
Seite 3 von 3     123
Gagamba

Registriert seit: 25. Jun 2012
19 Beiträge
 
#21

AW: Compilerfehler F2085

  Alt 20. Sep 2018, 14:11
Hallo,
explizites DEinstallieren geht bei mir ja leider nicht: das fehlt im Kontextmenü!
Siegfried
  Mit Zitat antworten Zitat
Rolf Frei

Registriert seit: 19. Jun 2006
67 Beiträge
 
#22

AW: Compilerfehler F2085

  Alt 20. Sep 2018, 16:39
Hallo,
explizites DEinstallieren geht bei mir ja leider nicht: das fehlt im Kontextmenü!
Siegfried
Ich mache dir mal einen Vorschlag. Wenn du willst komme ich mal per TeamViewer auf dein System und schaue mir das genauer an.

Wenn du daran Interesse hättest, melde dich per Private Nachricht für einen Termin (Telefon).

PS. Wohne in der Schweiz.
  Mit Zitat antworten Zitat
Gagamba

Registriert seit: 25. Jun 2012
19 Beiträge
 
#23

AW: Compilerfehler F2085

  Alt 20. Sep 2018, 18:24
Danke für den Vorschlag,
wo in der Schweiz bist Du denn? Ich wohne am Bodensee, deutsche Nord-Seite.
Ich hab jetzt Delphi2009 komplett deinstalliert (inkl. manuelles Löschen übrig gebliebener Reste) und neu installiert: es kommt immer noch der Fehler mit den angeblich unpassenden Modulnamen. Dann hab ichs wieder deinstalliert, danach die registry durchstöbert auf Verweise auf das alte Installationsverzeichnis, und diese gelöscht. Dann wieder installiert - WIEDER kam dieselbe Fehlermeldung! Ausserdem hat das neu installierte Delphi2009 ungefragt alle bpl geladen: woher weiss ein frisch installiertes 'jungfräuliches' System überhaupt davon? Ist mit alles sehr rätselhaft. Mein nächster Versuch wäre, einen alternative Rechner zu besorgen, und Delphi2009 dort zu installieren. Damit bin ich erst mal eine Weile 'beschäftigt'. Im Moment deinstalliere ich zum wiederholten Mal..
Gruß: Siegfried
  Mit Zitat antworten Zitat
mensch72

Registriert seit: 6. Feb 2008
750 Beiträge
 
#24

AW: Compilerfehler F2085

  Alt 20. Sep 2018, 19:23
"Alte Delphi's" sind ja ganz schick... mein D2007 als letztes "NonUnicode" werde ich z.B. "ewig" behalten.

Aber "Delphi2009"... ich weiß nicht ob sich da so ein Stress lohnt... zumindest für Privat zum "Test" gibt es doch aktuelles Tokyo als CE("Pro)-Edition kostenlos.
D2009 als erste Unicode Variante war&ist nicht gerade das, wofür ich mir heutejetzt noch so einen Stress jetzt antun würde
  Mit Zitat antworten Zitat
Gagamba

Registriert seit: 25. Jun 2012
19 Beiträge
 
#25

AW: Compilerfehler F2085

  Alt 20. Sep 2018, 19:28
Hallo,
ich habe nicht vor, ein aktuelleres Delphi anzuschaffen. Der Vorschlag mit Tokyo geht leider ins Leere - die Version ist leider NICHT kostenlos: sobald man einen Jahresumsatz von ca. 5000€ erreicht, muss man bezahlen. Und dann kostet es halt doch einiges mehr, als ich mir im Moment leisten kann.
Siegfrieed
  Mit Zitat antworten Zitat
Rolf Frei

Registriert seit: 19. Jun 2006
67 Beiträge
 
#26

AW: Compilerfehler F2085

  Alt 20. Sep 2018, 19:28
Danke für den Vorschlag,
wo in der Schweiz bist Du denn? Ich wohne am Bodensee, deutsche Nord-Seite.
Ich hab jetzt Delphi2009 komplett deinstalliert (inkl. manuelles Löschen übrig gebliebener Reste) und neu installiert: es kommt immer noch der Fehler mit den angeblich unpassenden Modulnamen. Dann hab ichs wieder deinstalliert, danach die registry durchstöbert auf Verweise auf das alte Installationsverzeichnis, und diese gelöscht. Dann wieder installiert - WIEDER kam dieselbe Fehlermeldung! Ausserdem hat das neu installierte Delphi2009 ungefragt alle bpl geladen: woher weiss ein frisch installiertes 'jungfräuliches' System überhaupt davon? Ist mit alles sehr rätselhaft. Mein nächster Versuch wäre, einen alternative Rechner zu besorgen, und Delphi2009 dort zu installieren. Damit bin ich erst mal eine Weile 'beschäftigt'. Im Moment deinstalliere ich zum wiederholten Mal..
Gruß: Siegfried
Komme aus dem Aargau.

Dass das Deinstallierern/Instalieren nicht funktioniert, war mir fast klar. Dein Problem liegt zu 100% an deinen ganzen Einstellungen und vermutlich mehrfach vorhanden DLL/BPL/DCU's etc., die da irgendwo "verstreut" auf deinem PC liegen und die mit einer Deinstallation eben nicht verschwinden.

Mein Angebot besteht nachwievor. Bin mir sicher, dass wir das zusammen per TeamViewer (das sagt dir was?) relativ schnell beheben können. Das Ganze wird wahrscheinlich erheblich weniger rätselhaft sein als du denkst, aber ohne dem nötigen KnowHow wirkt das für dich halt rätselhaft. Wenn wir das zusammen lösen wirst du sicher noch was dabei lernen. Du kannst ja dann zuschauen was ich mache.

Verwende doch auch mal den Process Monitor von SysInternals und logge da alles. Dieses Tool ist extrem hilfreich für solche Fälle. Da wirst du genau sehen können, auf was Delphi da alles zugreift und lädt.
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
6.436 Beiträge
 
Delphi XE4 Professional
 
#27

AW: Compilerfehler F2085

  Alt 20. Sep 2018, 19:36
Hallo,
ich würde nach der Deinstallation auch mal mit SearchEverything nach verweisten dcu, pas, bpl usw. suchen.
Heiko
  Mit Zitat antworten Zitat
Benutzerbild von Codehunter
Codehunter

Registriert seit: 3. Jun 2003
Ort: Thüringen
1.643 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#28

AW: Compilerfehler F2085

  Alt 21. Sep 2018, 14:25
Ich würde ja meinen Hintern drauf verwetten dass das was ganz Banales ist. Ein (Unicode-) Zeichen z.B. das optisch sehr ähnlich aussieht aber eben nicht das selbe ist. Da hilft dir die ganze Deinstalliererei nicht. Wie zum Beispiel:
Code:
í und i
Da kannst du nur Stück für Stück die Uses ausklammern und schauen ab wann der Fehler nicht mehr kommt.
Ich mache grundsätzlich keine Screenshots. Schießen auf Bildschirme gibt nämlich hässliche Pixelfehler und schadet der Gesundheit vom Kollegen gegenüber.
  Mit Zitat antworten Zitat
Gagamba

Registriert seit: 25. Jun 2012
19 Beiträge
 
#29

Compilerfehler F2085 > tut wieder!

  Alt 21. Sep 2018, 16:14
Hallo,
eigentlich sollte ich HEUREKA rufen, aber das wäre geprahlt - in Wirklichkeit habe ich keine Ahnung, warum es wieder geht. Mein Leidensweg verlief folgendermaßen:

1) Delphi2009 total deinstalliert
2) alle dcu / bpl gelöscht
3) Neuinstallation Delphi2009
4) Neuinstallation aller *.bpl
hat nix gebracht, daher:

1 bis 2 nochmal, zusätzlich
2a) registry nach Pfadangaben bzgl. Delphi2009 durchforstet und diese gelöscht
denn 3) und 4) Neuinstallation
hat nix gebracht, außer einem Startfehler von Delphi (*.bpl kann nicht geladen werden da nicht gefunden, sogar mit Angabe des Pfades, wo die bpl gesucht wurde, aber: genau da lag genau diese bpl!??) daher:

1 bis 3 nochmal, vorher
2b) in der registry zudem alle RAD-Verweise gelöscht
hat nix gebracht (gleicher bpl-Ladefehler Fehler wie oben), daher:

alles nochmal (dem Wahnsinn nahe), diesmal zusätzlich:
3a) vor Erzeugen und Installieren zuerst alle Pfade der Projekte in der IDE gelöscht, und erst hinzugefügt, wenn der Compiler meckert, ggf. verlangte *.res / *.dfm in gesondertes Verzeichnis kopiert, und diesen als SuchpPfad aufgenommen

Danke für die gutgemeinten Tipps: Siegfried
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 16:38 Uhr.
Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2018 by Daniel R. Wolf