AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Cross-Platform-Entwicklung Delphi Delphi Rio (10.3): FMX.TWebBrowser nur quadratisch

Delphi Rio (10.3): FMX.TWebBrowser nur quadratisch

Ein Thema von Jaybee2018 · begonnen am 5. Dez 2018 · letzter Beitrag vom 11. Dez 2018
Antwort Antwort
Seite 2 von 2     12
Jaybee2018

Registriert seit: 5. Dez 2018
6 Beiträge
 
#11

AW: Delphi Rio (10.3): FMX.TWebBrowser nur quadratisch

  Alt 10. Dez 2018, 10:43
Zitat:
Jedenfalls, könnte das "quadratisch" durch eine fehlendes Setzen der Align-Property (z.B. auf TAlignLayout.Client) liegen ?
Leider nein. Ich habe es mit align=client probiert, aber auch mit diversen anderen Einstellungen sowie mit Frames. Es wird in der Vorschau stets korrekt dargestellt, aber auf dem S8 bleibt es quadratisch. Das gilt auch für das unveränderte Beispiel aus den mitgelieferten Examples. Ein zweiter Effekt kommt hinzu. Der Bereich oberhalb des Quadrates in touch sensitive. D.h. wenn man dort eine Wischbewegung ausführt, wird der Inhalt des Quadrates bewegt.

Das ganze könnte mit dem Seitenverhältnis des S8 zusammenhängen. Möglicherweise hat Emba die Komponente nur auf 16:9 Geräten getestet, nicht aber auf 18.5:9 oder 19:9. Dann wären allerdings praktisch alle aktuellen Handys betroffen.

Geändert von Jaybee2018 (10. Dez 2018 um 10:46 Uhr)
  Mit Zitat antworten Zitat
skoschke

Registriert seit: 6. Jan 2009
60 Beiträge
 
Delphi 10.1 Berlin Enterprise
 
#12

AW: Delphi Rio (10.3): FMX.TWebBrowser nur quadratisch

  Alt 10. Dez 2018, 12:56
Ich habe gerade mal auf meinem Galaxy A8 (Display 18:9) getestet:

Formular mit TWebbrowser drauf, Align = alClient und alles schick im Hoch und im Querformat!

Allerdings ist hier Berlin 10.1, sollte sich da wirklich zu 10.2 was eingeschlichen haben?

Ciao
Stefan
  Mit Zitat antworten Zitat
Jaybee2018

Registriert seit: 5. Dez 2018
6 Beiträge
 
#13

AW: Delphi Rio (10.3): FMX.TWebBrowser nur quadratisch

  Alt 10. Dez 2018, 15:09
Ich habe nun testweise statt TWebBrowser mal ein TMemo auf das Formular gesetzt. Hier läuft alles einwandfrei, d.h. es wird korrekt client aligned. Von daher gehe ich davon aus, dass es sich wirklich um einen Bug in 10.3 handelt. Das lässt zumindest auf einen Hotfix hoffen.
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
108 Beiträge
 
Delphi 10.1 Berlin Enterprise
 
#14

AW: Delphi Rio (10.3): FMX.TWebBrowser nur quadratisch

  Alt Gestern, 20:02
Ja, es könnte sich in 10.3 etwas eingeschlichen haben, da die viel an der Architektur des Android Supports
geändert haben um die Z-Order Unterstützung einzubauen, von der auch TWebbrowser profitieren soll, da es ja
von Haus aus ein natives Steuerelement einbindet.

=> bitte mal prüfen ob dieser Sachverhalt schon in QP bekannt ist und falls nicht bitte schleunigst einen
Report inklusive Angabe betroffener Geräte anlegen, damit das möglichst schon für Update 1 behoben wird.

Die Report Nummer auch gerne hier posten, damit andere betroffene mit anderen Smartphones ihre Modelle
beim Report in die Kommentare schreiben können.

Grüße

TurboMagic
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 15:17 Uhr.
Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2018 by Daniel R. Wolf