AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke Delphi Fehler beim Abrufen des Serverzertifikats

Fehler beim Abrufen des Serverzertifikats

Ein Thema von Sliver18 · begonnen am 4. Feb 2019 · letzter Beitrag vom 19. Feb 2019
Antwort Antwort
Seite 1 von 3  1 23   
Sliver18

Registriert seit: 4. Aug 2011
Ort: Hamburg
19 Beiträge
 
Delphi 7 Enterprise
 
#1

Fehler beim Abrufen des Serverzertifikats

  Alt 4. Feb 2019, 23:29
Hallo Delphi-Experten,

ich habe da eine Problematik, bei der ich bereits in der Analyse verzweifle...

In der Firma benutzen wir Shipment das API von UPS, um unsere Pakete anzumelden. Dazu habe ich einst die WSDL von UPS importiert. Das klappt seit etlichen Monaten. Nun bin ich auf Delphi 10.3 umgestiegen und es klappt nicht mehr. Beim Ausführen meines Aufrufs erhalte ich die Fehlermeldung "Fehler beim Abrufen des Serverzertifikats". Damit kann ich gar nichts anfangen, denn die Fehlermeldung sagt mir überhaupt nichts und ich weiß auch gar nicht, was ich nun für Analyse-Möglichkeiten habe. Das Verrückte ist: Führe ich den Code auf meiner Entwicklungsmaschine aus (Debug), klappt es - auf allen anderen Maschinen klappt es jedoch nicht (Release). Das macht mich stutzig, denn ich wüsste nicht, was sich da anders verhält. Im Code wird kein Unterschied gemacht, um welchen Build es sich handelt - und so weit ich weiß, muss man eine importierte WSDL doch nicht mit ausliefern, oder? Ich weiß noch nicht einmal, was für ein Zertifikat hierbei gemeint ist. Schicke ich absichtlich "defekte" Daten , erhalte ich auch eine entsprechende Response vom Server, die Kommunikation kommt also zustande.

Kennt jemand diese Problematik? Kann mir jemand erläutern, was für Analyse-Möglichkeiten bestehen?

Vorsichtshalber erwähne ich noch, dass auch ein THTTPRIO hierbei verwendet wird, damit ich den Request und die Response loggen kann. Vielleicht hängt das ja irgendwie damit zusammen. Allerdings läuft der OnBeforeExecute-Event fehlerfrei durch.
JP
  Mit Zitat antworten Zitat
TiGü

Registriert seit: 6. Apr 2011
Ort: Berlin
2.195 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#2

AW: Fehler beim Abrufen des Serverzertifikats

  Alt 5. Feb 2019, 09:18
Es gibt eine Vielzahl an Berichten, dass diverse Teile des SOAP-Frameworks und der darin verwendeten Softwarekomponenten Breaking Changes erfahren haben.
Sollte es möglich sein, das Projekt zurück auf Delphi Tokyo 10.2.3. zu bringen, sparst du dir viele graue Haare.
Natürlich nur insofern es daran lag und nicht doch der Fehler in deinen Quelltexten oder dem Zertifikat liegt.
Aber der Versuch ist relativ schnell gemacht.

Es gilt die goldene Regel:
Keine Delphi-Version vor dem Update 1 verwenden.
  Mit Zitat antworten Zitat
Sliver18

Registriert seit: 4. Aug 2011
Ort: Hamburg
19 Beiträge
 
Delphi 7 Enterprise
 
#3

AW: Fehler beim Abrufen des Serverzertifikats

  Alt 5. Feb 2019, 17:24
Es gibt eine Vielzahl an Berichten, dass diverse Teile des SOAP-Frameworks und der darin verwendeten Softwarekomponenten Breaking Changes erfahren haben.
Sollte es möglich sein, das Projekt zurück auf Delphi Tokyo 10.2.3. zu bringen, sparst du dir viele graue Haare.
Oha, da habe ich noch gar nichts mitgekriegt. Aber gut, dass Du es erwähnst, danke!

Natürlich nur insofern es daran lag und nicht doch der Fehler in deinen Quelltexten oder dem Zertifikat liegt.
Aber der Versuch ist relativ schnell gemacht.
Ja, ich habe auf der alten Entwicklermaschine noch 10.2.3 drauf. Theoretisch könnte ich mir da ja eine DLL basteln, die das Ganze dann einfach in der 10.2.3er-Version ausgliedert.

Es gilt die goldene Regel:
Keine Delphi-Version vor dem Update 1 verwenden.
Das werde ich mir merken... :/
JP
  Mit Zitat antworten Zitat
Sliver18

Registriert seit: 4. Aug 2011
Ort: Hamburg
19 Beiträge
 
Delphi 7 Enterprise
 
#4

AW: Fehler beim Abrufen des Serverzertifikats

  Alt 7. Feb 2019, 11:06
Ich habe noch etwas herausgefunden:

Führe ich das Programm auf meinem Entwicklersystem aus, kann ich die SOAP-Kommunikation fehlerfrei durchführen. Kopiere ich die EXE auf ein anderes System, kommt es weiterhin zu der besagten Fehlermeldung. Es scheint also, als wäre nur der Rechner, mit dem ich das Programm erstellt habe, mit "etwas" ausgestattet, das die Kommunikation gestattet.

Dazu mal die Frage: Von was für einem Zertifikat ist hier überhaupt die Rede? Geht es hier um ein SSL-Zertifikat für die Kommunikation (der Webservice liegt unter einer HTTPS-Adresse)? Kann es sein, dass beim Ausführen aus Delphi heraus eine andere (vielleicht vorinstallierte) Version der SSL-Bibliotheken verwendet wird? Oder werden die freien SSL-Bibliotheken bei einer HTTPRIO bzw. WSDL-Verbindung überhaupt nicht benutzt?
JP
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.456 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#5

AW: Fehler beim Abrufen des Serverzertifikats

  Alt 7. Feb 2019, 11:07
Kommt darauf an, welche Delphiversion. Neuere Versionen verwenden die Unterstützung von Windows.
Markus Kinzler
  Mit Zitat antworten Zitat
Sliver18

Registriert seit: 4. Aug 2011
Ort: Hamburg
19 Beiträge
 
Delphi 7 Enterprise
 
#6

AW: Fehler beim Abrufen des Serverzertifikats

  Alt 7. Feb 2019, 11:26
Kommt darauf an, welche Delphiversion. Neuere Versionen verwenden die Unterstützung von Windows.
Die verwendete Delphiversion ist 10.3 auf einem Rechner mit Windows 10.

EDIT: Das System, auf dem die Kopie getestet wurde ist übrigens Windows 7
JP

Geändert von Sliver18 ( 7. Feb 2019 um 11:34 Uhr)
  Mit Zitat antworten Zitat
generic

Registriert seit: 24. Mär 2004
Ort: bei Hannover
2.197 Beiträge
 
Delphi XE5 Professional
 
#7

AW: Fehler beim Abrufen des Serverzertifikats

  Alt 7. Feb 2019, 12:42
Ich habe noch etwas herausgefunden:

Dazu mal die Frage: Von was für einem Zertifikat ist hier überhaupt die Rede? Geht es hier um ein SSL-Zertifikat für die Kommunikation (der Webservice liegt unter einer HTTPS-Adresse)? Kann es sein, dass beim Ausführen aus Delphi heraus eine andere (vielleicht vorinstallierte) Version der SSL-Bibliotheken verwendet wird? Oder werden die freien SSL-Bibliotheken bei einer HTTPRIO bzw. WSDL-Verbindung überhaupt nicht benutzt?
An so etwas glaube ich auch. Die haben bestimmt auf ein SHA256 Zertifikat umgestellt oder einige alte Methoden wie RC4, MD5 abgeschaltet.
Vielleicht kann daher dein Delphi nicht mehr mit dem Server kommunizieren, weil die SSL-Bib. zu alt ist?
  Mit Zitat antworten Zitat
Sliver18

Registriert seit: 4. Aug 2011
Ort: Hamburg
19 Beiträge
 
Delphi 7 Enterprise
 
#8

AW: Fehler beim Abrufen des Serverzertifikats

  Alt 7. Feb 2019, 13:20
An so etwas glaube ich auch. Die haben bestimmt auf ein SHA256 Zertifikat umgestellt oder einige alte Methoden wie RC4, MD5 abgeschaltet.
Vielleicht kann daher dein Delphi nicht mehr mit dem Server kommunizieren, weil die SSL-Bib. zu alt ist?
Dann wäre der nächste Ansatz also, neue SSL-Bibliotheken herunterzuladen und es damit zu versuchen?

Noch was: Die ausgelieferten Bibliotheken sind auf beiden Systemen identisch. Werden in Delphi mittlerweile bei der Erstinstallation Bibliotheken mitgeliefert? Das war meines Wissens nach früher nicht so...? Das würde zumindest erklären, warum es auf dem Entwicklungssystem mit frisch installiertem neuen Delphi funktioniert und auf dem "alten" System mit den alten Bibliotheken nicht. Außerdem sind die Bibliotheken im Order der EXE identisch - die werden doch als erstes verwendet, oder?
JP

Geändert von Sliver18 ( 7. Feb 2019 um 13:23 Uhr)
  Mit Zitat antworten Zitat
TiGü

Registriert seit: 6. Apr 2011
Ort: Berlin
2.195 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#9

AW: Fehler beim Abrufen des Serverzertifikats

  Alt 7. Feb 2019, 14:22
Kannst du auf den Windows 7 System was installieren?

Wenn ja, schau doch mal bitte, wie weit du in der Unit Soap.SOAPHTTPTRans in der Methode THTTPReqResp.Send kommst, indem du die Windowsfunktionen:
HttpOpenRequest,
InternetSetOption,
HttpAddRequestHeaders,
HttpSendRequest,
WinHttpReceiveResponse und HttpEndRequest
mit diesen Tool loggst:
http://www.rohitab.com/apimonitor
  Mit Zitat antworten Zitat
Sliver18

Registriert seit: 4. Aug 2011
Ort: Hamburg
19 Beiträge
 
Delphi 7 Enterprise
 
#10

AW: Fehler beim Abrufen des Serverzertifikats

  Alt 7. Feb 2019, 15:58
Kannst du auf den Windows 7 System was installieren?
Japp.

Wenn ja, schau doch mal bitte, wie weit du in der Unit Soap.SOAPHTTPTRans in der Methode THTTPReqResp.Send kommst, indem du die Windowsfunktionen:
HttpOpenRequest,
InternetSetOption,
HttpAddRequestHeaders,
HttpSendRequest,
WinHttpReceiveResponse und HttpEndRequest
mit diesen Tool loggst:
http://www.rohitab.com/apimonitor
Ui, mächtiges Tool.

Tatsächlich gehen die Aufrufe in den Bereich der WinHttp.dll:

WinHttpOpenRequest
WinHttpAddRequestHeaders
WinHttpSetOption
WinHttpSendRequest

Dabei wird mir auf dem nicht funktionierenden System direkt die Fehlermeldung "12175 - Die Inhaltscodierung ist fehlgeschlagen." im Tool an der Methode WinHttpSendRequest mit angezeigt. Das sieht mir stark nach der Fehlerursache aus.

Kommen wir damit weiter?
JP

Geändert von Sliver18 ( 7. Feb 2019 um 16:21 Uhr)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 21:29 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf