AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Fastreport - Hält die Gruppe nicht zusammen

Ein Thema von NoName1 · begonnen am 20. Mär 2019 · letzter Beitrag vom 21. Mär 2019
Antwort Antwort
NoName1

Registriert seit: 8. Mär 2018
106 Beiträge
 
Delphi XE7 Professional
 
#1

Fastreport - Hält die Gruppe nicht zusammen

  Alt 20. Mär 2019, 17:56
Guten Tag,
in Fastreport wird die Gruppe nicht zusammen gehalten.

Ich weiß jetzt nicht so richtig wie ich es beschreiben soll, aber ich versuche es einmal:
Folgender SQL-Befehl selektiert die Daten:
Delphi-Quellcode:
ibqryDrkForderungen.Close;
  ibqryDrkForderungen.SQL.Clear;
  ibqryDrkForderungen.SQL.Add('select adressid, bezahlt, forderungstxt, forderung, '
    + 'fordaus, brzahlung, art, brname, forderung-brzahlung as restforderung from forderungen ');
Im Report habe ich ein GroupHeader- und ein MasterData-Band eingefügt
Der GroupHeader ist auf folgendes eingestellt: Gruppenwechel bei: Datenfeld = AdressID
Wenn ich nun Fastreport aufrufe, werden nicht alle Daten die zu einer AdressID gehören in der Gruppe angezeigt,
sondern in mehreren Gruppen. Auch ein Umstellen der Gruppenselektion auf: Ausdruck = <frxDBDrkForderungen."ADRESSID">
brachte kein Erfolg.
Die "zerrissenen Daten" gehöhren aber alle einer AdressID. Master und Gruppe sind auch der richtigen Query zugeordnet.
Ich finde einfach den Fehler nicht, den ich mache um die Gruppen korrekt anzuzeigen.
Vielleicht weiß jemand waran es liegen könnte?
  Mit Zitat antworten Zitat
Lemmy

Registriert seit: 8. Jun 2002
Ort: Berglen
2.166 Beiträge
 
Delphi XE4 Professional
 
#2

AW: Fastreport - Hält die Gruppe nicht zusammen

  Alt 20. Mär 2019, 19:45
als aller erstes würde ich ein

  order by adressid in deine SQL einfügen.

Existiert das Problem dann immer noch?
  Mit Zitat antworten Zitat
NoName1

Registriert seit: 8. Mär 2018
106 Beiträge
 
Delphi XE7 Professional
 
#3

AW: Fastreport - Hält die Gruppe nicht zusammen

  Alt 21. Mär 2019, 07:27
als aller erstes würde ich ein

  order by adressid in deine SQL einfügen.

Existiert das Problem dann immer noch?
Danke Lemmy, damit ist das Problem gelöst.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 01:44 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf