AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Delphi 10.3.1 in VM Probleme

Ein Thema von krau001 · begonnen am 21. Mär 2019 · letzter Beitrag vom 23. Mär 2019
Antwort Antwort
Seite 2 von 2     12
krau001

Registriert seit: 9. Feb 2011
4 Beiträge
 
#11

AW: Delphi 10.3.1 in VM Probleme

  Alt 21. Mär 2019, 13:57
Jo, hab's gemerkt.
IDE Fix, gibt es nicht bei Embarcadero
Ich werde das mal gleich ausprobieren.

Danke und Grüße,

Wolfgang
  Mit Zitat antworten Zitat
jsp

Registriert seit: 9. Aug 2003
50 Beiträge
 
#12

AW: Delphi 10.3.1 in VM Probleme

  Alt 21. Mär 2019, 14:00
Idefix gibts nur bei Obelix SCNR
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
8.147 Beiträge
 
Delphi 10.4 Sydney
 
#13

AW: Delphi 10.3.1 in VM Probleme

  Alt 21. Mär 2019, 22:03
Nur benötige ich die VM Installation, da ich einige Tage in der Woche auch im Home Office arbeite.
Da ist das Mitnehmen der SSD mit den VM's einfacher und das Sichern einer VM auch übersichtlicher.
Das wäre für mich nichts, viel zu umständlich. Ich habe Delphi schlicht sowohl zu Hause installiert als auch im Büro und auf dem Laptop.

Aber das muss ja jeder für sich entscheiden.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Frickler

Registriert seit: 6. Mär 2007
Ort: Osnabrück
375 Beiträge
 
Delphi XE6 Enterprise
 
#14

AW: Delphi 10.3.1 in VM Probleme

  Alt 22. Mär 2019, 13:57
Zwei Dinge:
- IDE Fix Pack
- Themes abschalten

Ich hatte 10.3.1 zuerst probeweise in einer Windows 10 VM (1809), bin dann aber auf Windows 8.1 gewechselt. Das ist einfach schneller.
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.556 Beiträge
 
Delphi 10.3 Rio
 
#15

AW: Delphi 10.3.1 in VM Probleme

  Alt 22. Mär 2019, 14:41
Ich habe das Gefühl die VM-Software und die echte Hardware dürften auch eine Rolle spielen. Habe hier Parallels auf einem 2,5GHz Core i7 mit 16GB Ram und einer SSD. Ich merke keine Langsamkeit.

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
3.306 Beiträge
 
Delphi 10.4 Sydney
 
#16

AW: Delphi 10.3.1 in VM Probleme

  Alt 22. Mär 2019, 15:43
IMHO sind der Hauptgrund für langsames Kompilieren bis hin zu internal Error im Wesentlichen zirkuläre Unit-Referenzen.
Würde mal versuchen mit Uwe Raabes MMX Tool einen Frühjahrsputz zu machen.
  Mit Zitat antworten Zitat
krau001

Registriert seit: 9. Feb 2011
4 Beiträge
 
#17

AW: Delphi 10.3.1 in VM Probleme

  Alt 23. Mär 2019, 04:41
Ich habe nun einige Zeit experimentieren können.
IDEFix scheint wirklich etwas zu bringen, allerdings passieren jetzt andere, merkwürdige Sachen unter Rio.
Den Desctop speichert das Teil auch nicht richtig ab.
Ich habe da Bauchweh, schwenke wieder zu Tokio und warte ab was da kommt.
Tokio läuft jetzt mit IDEFix auch etwas schneller.
Zumindest habe ich den Eindruck, Super !
Vielen Dank für die vielen Anregungen.

Grüße,

Wolfgang
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
8.147 Beiträge
 
Delphi 10.4 Sydney
 
#18

AW: Delphi 10.3.1 in VM Probleme

  Alt 23. Mär 2019, 11:07
Ich hatte 10.3.1 zuerst probeweise in einer Windows 10 VM (1809), bin dann aber auf Windows 8.1 gewechselt. Das ist einfach schneller.
Interessant, dass das in einer VM genau umgekehrt ist wie bei einer physischen Installation. Bei VMWare nehme ich an? Mit Hyper-V ist es nämlich auch andersherum bei mir.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Frickler

Registriert seit: 6. Mär 2007
Ort: Osnabrück
375 Beiträge
 
Delphi XE6 Enterprise
 
#19

AW: Delphi 10.3.1 in VM Probleme

  Alt 23. Mär 2019, 13:32
Ich hatte 10.3.1 zuerst probeweise in einer Windows 10 VM (1809), bin dann aber auf Windows 8.1 gewechselt. Das ist einfach schneller.
Interessant, dass das in einer VM genau umgekehrt ist wie bei einer physischen Installation. Bei VMWare nehme ich an? Mit Hyper-V ist es nämlich auch andersherum bei mir.
Ja auf VMware 12. Host ist ein Xeon E3 mit 24 GB RAM und SSD auf Windows 10 1809.

Von der Geschwindigkeit der VMs sieht da so aus: XP > Windows 7 > Windows 8.1 > Windows 10.

Dass W10 unter Hyper-V schneller ist, könnte auch "politische Gründe" (im Gegensatz zu technischen Gründen) haben. Vmware hat keine Motivation, bestimmte Gastsysteme schneller auszuführen.

Ich benutze VMware statt Hyper-V, denn ich habe auch noch ältere VMs. Außerdem kann man mit VMware schön langsame Netzwerke mit Aussetzern simulieren, etwa für VPN-Tests.
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
8.820 Beiträge
 
Delphi 10.4 Sydney
 
#20

AW: Delphi 10.3.1 in VM Probleme

  Alt 23. Mär 2019, 13:52
Ja auf VMware 12.
Da würde ich vielleicht mal ein Update in Erwägung ziehen. Ein Blick in die Kompatibilitätsliste sollte diesen Ansatz unterstützen.
Miniaturansicht angehängter Grafiken
23-03-_2019_13-49-07.png  
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 11:37 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf