AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

ttimer Intervall bewirkt nichts

Ein Thema von DrUArn · begonnen am 29. Mai 2019 · letzter Beitrag vom 11. Jun 2019
Antwort Antwort
Seite 1 von 2  1 2   
DrUArn

Registriert seit: 20. Mär 2003
130 Beiträge
 
Delphi 10.3 Rio
 
#1

ttimer Intervall bewirkt nichts

  Alt 29. Mai 2019, 20:43
Hi Comm,

Die Veränderung der Eigenschaft ttimer.intervall bewirkt bei mir gar nichts.

Die ontimer-Routine taktet im Sekundenrhythmus, egal was in intervall steht (gesetzt direkt in der IDE)

Delphi-Quellcode:
procedure TForm1.Timer1Timer(Sender: TObject);

begin
label1.caption:='aktuelle Zeit: '+timetostr(gettime);
end;
Woran kann das liegen.

Grüße Uwe
  Mit Zitat antworten Zitat
DieDolly

Registriert seit: 22. Jun 2018
1.062 Beiträge
 
#2

AW: ttimer Intervall bewirkt nichts

  Alt 29. Mai 2019, 20:44
Setz das Intervall zu Testzwecken im Code zur Laufzeit.
  Mit Zitat antworten Zitat
DrUArn

Registriert seit: 20. Mär 2003
130 Beiträge
 
Delphi 10.3 Rio
 
#3

AW: ttimer Intervall bewirkt nichts

  Alt 29. Mai 2019, 20:49
Hi,

ja, zur Laufzeit bewirkt diese Änderung das, was sie soll!

Heißt, die Voreinstellung lässt sich in der IDE nicht beeinflussen?


Uwe

Geändert von DrUArn (29. Mai 2019 um 20:52 Uhr)
  Mit Zitat antworten Zitat
DieDolly

Registriert seit: 22. Jun 2018
1.062 Beiträge
 
#4

AW: ttimer Intervall bewirkt nichts

  Alt 29. Mai 2019, 21:11
Eigentlich sollte sie das ohne Probleme. Vielleicht ist das in deiner Version kaputt.
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
Ort: Oberreichenbach
16.475 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#5

AW: ttimer Intervall bewirkt nichts

  Alt 29. Mai 2019, 21:25
AFAIK musst du den Timer erste stoppen, Intervall ändern und dann neu starten.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Dennis07

Registriert seit: 19. Sep 2011
Ort: Deutschland
347 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#6

AW: ttimer Intervall bewirkt nichts

  Alt 29. Mai 2019, 21:47
AFAIK musst du den Timer erste stoppen, Intervall ändern und dann neu starten.
Du kannst den Timer zur Entwurfszeit weder stoppen noch starten.
Und zur Laufzeit scheint alles so zu gehen.

Ich würde mal versuchen das Projekt neu zu erzeugen. Es scheint, als dass deine Formularressource wohl nicht neu eingebunden wird.
Dennis
  Mit Zitat antworten Zitat
DieDolly

Registriert seit: 22. Jun 2018
1.062 Beiträge
 
#7

AW: ttimer Intervall bewirkt nichts

  Alt 29. Mai 2019, 22:18
So wie ich das verstanden habe, ist das Problem kein Laufzeitproblem sondern ein Entwurfszeitproblem.
  Mit Zitat antworten Zitat
DrUArn

Registriert seit: 20. Mär 2003
130 Beiträge
 
Delphi 10.3 Rio
 
#8

AW: ttimer Intervall bewirkt nichts

  Alt 29. Mai 2019, 22:26
Ja, es ist "nur" ein Problem zur Entwurfszeit.

Grüße Uwe
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
2.069 Beiträge
 
Delphi 10.3 Rio
 
#9

AW: ttimer Intervall bewirkt nichts

  Alt 30. Mai 2019, 07:17
AFAIK musst du den Timer erste stoppen, Intervall ändern und dann neu starten.
Du kannst den Timer zur Entwurfszeit weder stoppen noch starten.
Und zur Laufzeit scheint alles so zu gehen.

Ich würde mal versuchen das Projekt neu zu erzeugen. Es scheint, als dass deine Formularressource wohl nicht neu eingebunden wird.
Stoppen und neustarten geht so
Delphi-Quellcode:
    Timer1.Enabled := False;
    Timer1.Enabled := True;
  Mit Zitat antworten Zitat
Benutzerbild von DeddyH
DeddyH

Registriert seit: 17. Sep 2006
Ort: Barchfeld
26.827 Beiträge
 
Delphi 10.3 Rio
 
#10

AW: ttimer Intervall bewirkt nichts

  Alt 30. Mai 2019, 07:51
Im OI?
Detlef
"Ich habe Angst vor dem Tag, an dem die Technologie unsere menschlichen Interaktionen übertrumpft. Die Welt wird eine Generation von Idioten bekommen." (Albert Einstein)
Dieser Tag ist längst gekommen
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 11:09 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf