AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Cross-Platform-Entwicklung Android - Hinweis, dass Anwendung veraltet ist

Android - Hinweis, dass Anwendung veraltet ist

Ein Thema von greenmile · begonnen am 1. Nov 2019 · letzter Beitrag vom 24. Nov 2019
Antwort Antwort
Seite 1 von 2  1 2   
greenmile

Registriert seit: 17. Apr 2003
1.056 Beiträge
 
Delphi 10.1 Berlin Professional
 
#1

Android - Hinweis, dass Anwendung veraltet ist

  Alt 1. Nov 2019, 21:44
Hallo,

ich bekomme beim Start meiner Android App (entwickelt mit 10.1 Berlin) den Hinweis, dass die Anwendung ggf veraltet ist. Das ist bei Kunden natürlich unschön, ich weiß leider nicht so recht, wer oder was diesen Hinweis verursacht und ob ich das ev mit einem "Schalter" oder sowas abstellen kann. Falls nicht: Welche Delphi / Mobile Version wird mindestens gebraucht, damit der Hinweis beim Start auf aktuellen Smartphones (Galaxy S10) nicht mehr kommt? Soweit ich das sehe, kann ich mit meiner (nicht mehr aktiven) Subscription noch Delphi 10.2 Tokyo laden.

Geändert von greenmile ( 1. Nov 2019 um 21:51 Uhr)
  Mit Zitat antworten Zitat
Alt 1. Nov 2019, 21:56     Erstellt von Frühlingsrolle
Dieser Beitrag wurde von Daniel gelöscht. - Grund: Verdacht auf SPAM und den damit verbundenen verschwenderischen Umgang von wertvollen Bits und Bytes
greenmile

Registriert seit: 17. Apr 2003
1.056 Beiträge
 
Delphi 10.1 Berlin Professional
 
#2

AW: Android - Hinweis, dass Anwendung veraltet ist

  Alt 1. Nov 2019, 22:07
Der Hinweis kommt vom Handy, also Android/Google
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
7.556 Beiträge
 
Delphi 10.3 Rio
 
#3

AW: Android - Hinweis, dass Anwendung veraltet ist

  Alt 2. Nov 2019, 05:55
Soweit ich das sehe, kann ich mit meiner (nicht mehr aktiven) Subscription noch Delphi 10.2 Tokyo laden.
Für die mobile Entwicklung macht alles außer Subscription nicht wirklich Sinn sofern es um geschäftliche Entwicklung geht. Für die private Nutzung gibt es ja die aktuelle Community Edition kostenlos.

Du kannst versuchen das API Level manuell zu erhöhen. Hier hat jemand so etwas gemacht:
https://www.delphiworlds.com/2018/06...her-continued/

Aber du musst damit rechnen, dass du irgendwann gar keine Apps mehr in den Playstore bekommst, die mit einer alten Version von Delphi erstellt wurden.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Rollo62
Online

Registriert seit: 15. Mär 2007
2.500 Beiträge
 
Delphi 10.3 Rio
 
#4

AW: Android - Hinweis, dass Anwendung veraltet ist

  Alt 2. Nov 2019, 08:38
Das Problem ist das Google 32-Bit nicht mehr erlaubt, und nur noch Android 64-Bit benötigt wird.
Dass wird es erst in Rx10.3 (in der Zukunft) geben, oder in der Beta-Subscription.

Google gewährt noch auf Anfrage eine Zeitlang 32-Bit App upzuloaden, aber dafür gibt es keine Garantie.

Wie schon Sebastian richtig bemerkt, es führt kein sinnvoller Weg an einer Subscxription vorbei.
  Mit Zitat antworten Zitat
greenmile

Registriert seit: 17. Apr 2003
1.056 Beiträge
 
Delphi 10.1 Berlin Professional
 
#5

AW: Android - Hinweis, dass Anwendung veraltet ist

  Alt 2. Nov 2019, 11:50
Vielen Dank, ich versuche mal, die App mit den Tricks auf die Sprünge zu helfen.
Ach was lobe ich mir Microsoft. Ewig und fünf Tage abwärtskompatibel und nicht "32 Bit ab heute nicht mehr", egal was der User will.

Meine App ist nicht im Store, das Spiel mache ich nicht mit.
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer
Online

Registriert seit: 13. Aug 2002
16.645 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#6

AW: Android - Hinweis, dass Anwendung veraltet ist

  Alt 2. Nov 2019, 13:32
Vielen Dank, ich versuche mal, die App mit den Tricks auf die Sprünge zu helfen.
Ach was lobe ich mir Microsoft. Ewig und fünf Tage abwärtskompatibel und nicht "32 Bit ab heute nicht mehr", egal was der User will.
Würden sie gerne machen. Aber damit würden sie (in 2019) den endgültigen Untergang der Windows-Plattform einleiten.

Meine App ist nicht im Store, das Spiel mache ich nicht mit.
Wird dir nicht viel bringen wenn Android in wenigen Jahren nur noch 64-Bit Apps ausführt. Also Aufpassen beim nächsten Smartphone-Kauf oder beim Update auf neue Android-Version
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Rollo62
Online

Registriert seit: 15. Mär 2007
2.500 Beiträge
 
Delphi 10.3 Rio
 
#7

AW: Android - Hinweis, dass Anwendung veraltet ist

  Alt 2. Nov 2019, 13:43
Man muss es auch mal Positiv sehen.
Besser alte Zöpfe mal abschneide, als ewig und drei Tage mitzuschleppen.
Das tut heute etwas weh, bringt uns aber in der Zukunft schneller nach vorne.

M$ muss ja in seinen alten Strukturen immer noch alles Alte mitpflegen und teilweise wieder eaktivieren (z.B. COM, etc.), und wohl auch deshalb kommen die im Moment nicht ganz in die Pötte gegen die Mobilen.

Vielleicht kann man das so einordnen:
Apple/iOS - viel zu strikt (das ist auch nicht OK)
Android - ganz vernünftige, pragmatische Strategie und Kompatibilität
Microsoft - etwas zu lasch

Versteht mich nicht falsch, auch ich möchte im Moment Win32 nicht missen,
aber ein striktere Umstellen auf 64-Bit hätten sie besser schon im letzen Jahrzehnt gemacht,
statt zu versuchen "everybodies darling" zu sein.
  Mit Zitat antworten Zitat
greenmile

Registriert seit: 17. Apr 2003
1.056 Beiträge
 
Delphi 10.1 Berlin Professional
 
#8

AW: Android - Hinweis, dass Anwendung veraltet ist

  Alt 2. Nov 2019, 20:44
https://curved.de/news/android-p-ein...onieren-590341

Geändert von greenmile ( 2. Nov 2019 um 20:59 Uhr)
  Mit Zitat antworten Zitat
greenmile

Registriert seit: 17. Apr 2003
1.056 Beiträge
 
Delphi 10.1 Berlin Professional
 
#9

AW: Android - Hinweis, dass Anwendung veraltet ist

  Alt 2. Nov 2019, 23:54
So, habs hinbekommen und war (in meinem Fall) einfacher gemacht als gedacht. Habe erst Delphi 10.2.3 installiert und dann alles von DelphiWorlds ausprobiert. Das hat zwar geklappt, war aber grottenlangsam. So läuft es nun bei mir unter 10.1 (Berlin):

1. In der Datei "AndroidManifest.template.xml" unter "android:targetSdkVersion" direkt "26" eingetragen
2. Im SDK-Manager unter "ZipAlign" / "Adb location" und "SDK-API Level" die 26 statt 22 eingetragen

Compiliert, getestet, läuft unter Android 9.

Vielen Dank an alle!

Geändert von greenmile ( 3. Nov 2019 um 00:13 Uhr)
  Mit Zitat antworten Zitat
greenmile

Registriert seit: 17. Apr 2003
1.056 Beiträge
 
Delphi 10.1 Berlin Professional
 
#10

AW: Android - Hinweis, dass Anwendung veraltet ist

  Alt 23. Nov 2019, 11:40
Muss leider nochmal nachfragen. Die Meldung an sich ist weg, alles läuft, aaaaber ... Ich kann keine Daten speichern, also nicht dauerhaft. Wenn ich zB eine Textdatei in "TPath.GetDocumentsPath+TPath.DirectorySeparatorCh ar+'test.txt'" schreibe, dann ist die beim Neustart nicht mehr da.

Hat das Problem noch jemand, der so getrickst hat?
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 16:09 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf