AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Aufruf von .net Core 3.1 Assemblies

Ein Thema von Sergej_Molotov · begonnen am 31. Jan 2020 · letzter Beitrag vom 16. Feb 2022
Antwort Antwort
Seite 2 von 2     12
Sergej_Molotov

Registriert seit: 18. Jul 2006
61 Beiträge
 
Delphi 11 Alexandria
 
#11

AW: Aufruf von .net Core 3.1 Assemblies

  Alt 31. Jan 2020, 10:37
Der Hinweis mit x86 in C# hat auch bei mir geholfen. Jetzt versuche ich gerade eine Funktion meiner erzeugten Klasse aufzurufen, aber das geht noch nicht. Versuche es aber weiter...

Variante referenziert kein Automatisierungsobjekt
Thomas

Geändert von Sergej_Molotov (31. Jan 2020 um 10:43 Uhr)
  Mit Zitat antworten Zitat
Sergej_Molotov

Registriert seit: 18. Jul 2006
61 Beiträge
 
Delphi 11 Alexandria
 
#12

AW: Aufruf von .net Core 3.1 Assemblies

  Alt 31. Jan 2020, 12:16
Der Aufruf der Funktion geling jetzt auch. Ich habe über "Komponente --> Komponente importieren --> .Net-Assembly importieren" die OHNE comhost.dll importiert und konnte dann die Funktionen aufrufen.

Danke 4dk2 und allen anderen
Thomas
  Mit Zitat antworten Zitat
Sergej_Molotov

Registriert seit: 18. Jul 2006
61 Beiträge
 
Delphi 11 Alexandria
 
#13

AW: Aufruf von .net Core 3.1 Assemblies

  Alt 31. Jan 2020, 14:08
Wer eine TLB-Datei haben möchte, kann diese wie folgt berechnen:
Code:
tlbexp Test.dll /asmpath:"C:\Windows\Microsoft.NET\Framework\v4.0.30319"
tlibimp -P Test.tlb -Pt+
Thomas
  Mit Zitat antworten Zitat
Alt 18. Sep 2020, 15:21     Erstellt von aris0514
Dieser Beitrag wurde von Daniel gelöscht. - Grund: Verdacht auf SPAM und den damit verbundenen verschwenderischen Umgang von wertvollen Bits und Bytes
Abudinka

Registriert seit: 21. Jan 2020
1 Beiträge
 
#14

AW: Aufruf von .net Core 3.1 Assemblies

  Alt 16. Feb 2022, 07:31
Der Aufruf der Funktion geling jetzt auch. Ich habe über "Komponente --> Komponente importieren --> .Net-Assembly importieren" die OHNE comhost.dll importiert und konnte dann die Funktionen aufrufen.

Danke 4dk2 und allen anderen
Hab den selben weg "durch gemacht" allerdings wird mein Interface falsch implementiert, bzw. automatisch ein zusätzliches erstellt. Auch taucht auch nach der registrierung weder mein eigener comhost noch die comserverdemo in der delphi import list auf

c#:

Code:
  [ComVisible(true)]
    [Guid("E7637EE9-EDBC-4BA4-984D-B87A2CA6B97E")]
    [InterfaceType(ComInterfaceType.InterfaceIsDual)]
    public interface IWFNet5
    {
        IntPtr DoSomething();
    }
    [ComVisible(true)]
    [Guid("E04FA7A1-481D-42F4-A14C-D7CA94017B2B")]
    public class WFNet5 : IWFNet5
    { 
        public WFNet5()
        {
        }

        public IntPtr DoSomething()
        {
        }
    }
woraus delphi zwar das interface IWFNet5 erstellt aber zusätzlich ein leeres _WFNet5 interface erstellt von dem die WFNet5 implementierung erbt, die dann die Funktion DoSomething nicht implementiert

hat da jemand einen tipp? -- es fehlt bei der Klassendefinition das Attribut
[ClassInterface(ClassInterfaceType.None)]

Geändert von Abudinka (16. Feb 2022 um 07:45 Uhr) Grund: lösung gefunden
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 17:50 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz