AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

keine gültige Win32 Application

Ein Thema von Ykcim · begonnen am 11. Sep 2020 · letzter Beitrag vom 17. Sep 2020
Antwort Antwort
Seite 1 von 2  1 2   
Ykcim

Registriert seit: 29. Dez 2006
Ort: NRW
760 Beiträge
 
Delphi 10.4 Sydney
 
#1

keine gültige Win32 Application

  Alt 11. Sep 2020, 19:02
Hallo Zusammen,

ich bin gerade irgendwie verzweifelt. Ich bekomme neuerdings immer wieder beim Compilieren die Nachricht, dass die exe keine gültige Win32 Application sei. Manchmal wenn ich neu compiliere funktioniert es wieder, bei meinem wichtigsten (sehr großen) Projekt nicht.

Ich habe jetzt die gesamte Entwicklungsumgebung neu installiert (vorher 10.3 jetzt 10.4), aber die Fehlermeldung kommt wieder.

Was kann die Ursache sein oder wie kann ich die Ursache herausfinden?

Problem: Heute läuft die Update-Phase für meine Komponenten aus und ich kann sie morgen nicht neu installieren...

Vielen Dank
Patrick
Patrick
  Mit Zitat antworten Zitat
venice2

Registriert seit: 5. Dez 2019
Ort: Köln
682 Beiträge
 
Delphi 2010 Architect
 
#2

AW: keine gültige Win32 Application

  Alt 11. Sep 2020, 19:16
Prüfe dein Manifest und sorge dafür das dir Delphi nicht da reinpfuscht.
Es hört sich für mich so an als ob sich da irgend etwas schneidet.

Es gibt 2 typische Fehler.
Side-by-Side-Konfiguration ungültig und oder die Exe ist keine Win32 Anwendung wenn Probleme mit dem Manifest auftreten.

Geändert von venice2 (11. Sep 2020 um 19:22 Uhr)
  Mit Zitat antworten Zitat
Ykcim

Registriert seit: 29. Dez 2006
Ort: NRW
760 Beiträge
 
Delphi 10.4 Sydney
 
#3

AW: keine gültige Win32 Application

  Alt 11. Sep 2020, 19:21
Ich weiß leider nicht, was eine manifest-Datei ist. Wo finde ich die?
Patrick
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.977 Beiträge
 
Delphi XE4 Professional
 
#4

AW: keine gültige Win32 Application

  Alt 11. Sep 2020, 19:22
Hallo,
mal den Virenscanner ausschalten?
Heiko
  Mit Zitat antworten Zitat
venice2

Registriert seit: 5. Dez 2019
Ort: Köln
682 Beiträge
 
Delphi 2010 Architect
 
#5

AW: keine gültige Win32 Application

  Alt 11. Sep 2020, 19:24
Hallo,
mal den Virenscanner ausschalten?
Das wäre aber böse wenn es daran liegen sollte, glaube aber nicht.
  Mit Zitat antworten Zitat
Ykcim

Registriert seit: 29. Dez 2006
Ort: NRW
760 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: keine gültige Win32 Application

  Alt 11. Sep 2020, 19:31
Hallo Zusammen,

vielen Dank für Eure Hilfe. Kann es an der Art und Weise liegen, wie ich arbeite. Ich programmiere nur nebenher. Ich habe von der IT einen virtuellen Server dazu bereitgestellt bekommen auf den ich remote zugreife. Den Viren-Scanner kann ich daher nur mit Aufwand umgehen...

Die Entwicklungsdateien liegen auf einem anderen File-Server. Ich habe jetzt die Source-Dateien auf den Entwicklungsserver kopiert, damit der FileServer nicht mehr dazwischen hängt.

Jetzt scheint es zu klappen.

Ich habe das Problem so jetzt bei zwei unterschiedlichen Projekten anscheinend lösen können... Kann das sein?
Patrick

Geändert von Ykcim (11. Sep 2020 um 19:35 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.879 Beiträge
 
Delphi 10.4 Sydney
 
#7

AW: keine gültige Win32 Application

  Alt 11. Sep 2020, 19:36
Hallo,
mal den Virenscanner ausschalten?
Das wäre aber böse wenn es daran liegen sollte, glaube aber nicht.
Dann wurdest du bisher wohl vor diesen "Lieblingen der Compilierung" verschont.
Bei uns sorgt dieser ab und bei einem Rebuild für Probleme. Vermutlich ist der Compiler mit der Erstellung von dcu-Dateien zu schnell.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.879 Beiträge
 
Delphi 10.4 Sydney
 
#8

AW: keine gültige Win32 Application

  Alt 11. Sep 2020, 19:38
Die Entwicklungsdateien liegen auf einem anderen File-Server. Ich habe jetzt die Source-Dateien auf den Entwicklungsserver kopiert, damit der FileServer nicht mehr dazwischen hängt.

Jetzt scheint es zu klappen.
Virenscanner auf Server könnte ein Problem sein.

Ich habe das Problem so jetzt bei zwei unterschiedlichen Projekten anscheinend lösen können... Kann das sein?
Ja.

Heutzutage mit git und Co. sollten die Quelldateien lokal liegen, um solche Probleme zu vermeiden.
Eine Sicherung erfolgt da du die Quelldateien eincheckst bzw. das die lokalen Kopien (Verzeichnis mit git-Rep + Quelldateien) ebenfalls im Backup sind, so das man nicht immer ins zentrale Repository pushen muss.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
venice2

Registriert seit: 5. Dez 2019
Ort: Köln
682 Beiträge
 
Delphi 2010 Architect
 
#9

AW: keine gültige Win32 Application

  Alt 11. Sep 2020, 19:41
Hallo,
mal den Virenscanner ausschalten?
Das wäre aber böse wenn es daran liegen sollte, glaube aber nicht.
Dann wurdest du bisher wohl vor diesen "Lieblingen der Compilierung" verschont.
Bei uns sorgt dieser ab und bei einem Rebuild für Probleme. Vermutlich ist der Compiler mit der Erstellung von dcu-Dateien zu schnell.
Liegt doch an jedem selbst ob er den System internen Scanner verwendet oder Fremdsoftware.
Hatte mit Defender noch nie Probleme diesbezüglich.

Geändert von venice2 (11. Sep 2020 um 19:43 Uhr)
  Mit Zitat antworten Zitat
Ykcim

Registriert seit: 29. Dez 2006
Ort: NRW
760 Beiträge
 
Delphi 10.4 Sydney
 
#10

AW: keine gültige Win32 Application

  Alt 11. Sep 2020, 19:42
Ich muss gestehen, dass ich nach 15 Jahren Delphi das Thema Sicherung nie richtig geblickt habe. Ich kopiere mir also immer Zwischenstände in einen anderen Ordner...

Aber ok, dann habe ich die Hoffnung, dass ich mit der heute neuinstallierten Umgebung arbeiten kann. Ich war schon kurz davor wieder alles runterzuschmeißen und eine Nachtschicht einzulegen...

Vielen Dank!!!
Patrick
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 22:46 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf