AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Sprachen und Entwicklungsumgebungen Sonstige Fragen zu Delphi Remote Debugging PAServer - keine Haltepunkte

Remote Debugging PAServer - keine Haltepunkte

Ein Thema von galtec · begonnen am 17. Feb 2021 · letzter Beitrag vom 24. Nov 2022
Antwort Antwort
galtec

Registriert seit: 28. Mär 2016
2 Beiträge
 
#1

Remote Debugging PAServer - keine Haltepunkte

  Alt 17. Feb 2021, 18:21
Hallo, folgendes Problem mit XE2 (Win10): obwohl ein Remoteprofil zugewiesen wurde, Build-Konfiguration auf Debug gestellt ist, Projekt->Optionen->Linken->mit externen Debug-Symbolen = true, verschwinden beim Start mit (F9) die bis dato blauen bzw. roten Haltepunkte. Die Anwendung startet auf dem Remote-Rechner: Win10, ich kann jedoch nicht auf dem lokalen System debuggen.
Bei einem anderen, jedoch wesentlich kleinerem Testprogramm funktioniert bei gleichen Einstellungen das Debuggen wie erwartet.
Die exe- und auch rsm-Datei werden auf den Remoterechner übertragen.
Ich weiß jetzt leider nicht weiter....
  Mit Zitat antworten Zitat
Alt 9. Apr 2021, 05:54     Erstellt von trexgameaz
Dieser Beitrag wurde von Daniel gelöscht. - Grund: Verdacht auf SPAM und den damit verbundenen verschwenderischen Umgang von wertvollen Bits und Bytes
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
8.156 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: Remote Debugging PAServer - keine Haltepunkte

  Alt 9. Apr 2021, 06:07
Hallo,
kopier die Projektdatei des kleinen Projektes
und binde dort deine neuen Units ein.

Irgendwas stimmt mit der Projektdatei des nicht funktionierenden Projektes nicht.
Heiko
  Mit Zitat antworten Zitat
Alt 15. Apr 2021, 09:28     Erstellt von AartiSingh
Dieser Beitrag wurde von TBx gelöscht. - Grund: Verdacht auf SPAM und den damit verbundenen verschwenderischen Umgang von wertvollen Bits und Bytes
DukeM

Registriert seit: 1. Feb 2011
20 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#3

AW: Remote Debugging PAServer - keine Haltepunkte

  Alt 24. Nov 2022, 15:32
Hallo, ich habe mittlerweile das gleiche Problem!

Und es ist auch nicht sichergestellt, das ein kleines/neues Projekt unbedingt funktioniert mit PA.

Die Projektdatei von einem anderen Projekt übernehmen wäre erstmal zu viel Aufwand.

Ich nutze D10.1 Berlin
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
40.477 Beiträge
 
Delphi 11 Alexandria
 
#4

AW: Remote Debugging PAServer - keine Haltepunkte

  Alt 24. Nov 2022, 17:14
Solche Probleme haben leider Mehrere ... gab auch schon aktuelle Threads/Posts hier im Forum dazu, sowie Bugreports beim Hersteller.

* Win32 "lokal" geht meistens
* Win64 (nutzt intern den Repotedebugger) ... hält auch nach F7/F8 öfters nicht mehr an
* und im Android ebenfalls öfters keine Haltepunkte

z.B. https://quality.embarcadero.com/browse/RSP-39820



Du könntest es alternativ mal mit dem kleinen RemoteDebugger versuchen.
C:\Program Files (x86)\Embarcadero\Studio\**.0\bin\rmtdbg280.exe
* Beschreibung in der Delphi-Hilfe (docwiki)
* Dateien manuell rüberkopieren, drüben deb RemoteDebugger starten, Programm manuell starten (Start > Mit Prozess verbinden) oder über den Debugger starten lassen (Start > Prozess laden) und dann mit der IDE mit dem Debugger und zum Prozess verbinden
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
my Delphi wish list

Geändert von himitsu (24. Nov 2022 um 21:58 Uhr)
  Mit Zitat antworten Zitat
DenkDirNix

Registriert seit: 13. Dez 2018
54 Beiträge
 
Delphi 10.4 Sydney
 
#5

AW: Remote Debugging PAServer - keine Haltepunkte

  Alt 24. Nov 2022, 19:40
Eine mögliche Ursache dieses Problems ist die Veränderung des Output-Directorys in den Projekt-Optionen.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 07:25 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf