AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke SMTP-Problem, Indy und TLS 1.3 oder ICS

SMTP-Problem, Indy und TLS 1.3 oder ICS

Ein Thema von HappyJoe · begonnen am 12. Aug 2021 · letzter Beitrag vom 16. Aug 2021
Antwort Antwort
Seite 2 von 3     12 3   
Delphi.Narium

Registriert seit: 27. Nov 2017
1.907 Beiträge
 
Delphi 7 Professional
 
#11

AW: SMTP-Problem, Indy und TLS 1.3 oder ICS

  Alt 13. Aug 2021, 11:40
Ggfls. musst Du all "alten" .DCU von Indy, wo immer auch bei Deinen Projekten der Ausgabepfad dafür sein mag, löschen.

Kompilieren alleine reicht nicht zwingend, eventuell mal "alles neu erstellen".

Das Package mit der 160 im Namen gehört wohl zu Delphi 8.

Dann mal in der IDE nachschauen, welche Packages da so alles installiert sind und auch hier für Ordnung sorgen. Ggfls. dort mal alle momentan installierten Packages von Indy entfernen und dann nur die für Dein Delphi relevanten installieren.

Da solltest Du mal gründlich aufräumen und sicherstellen, dass Du nur die zu Deiner Delphiversion gehörenden Packages nutzt. Mal aus dem Verzeichnis mit den kompilieren Packages (*.bpl) alles entfernen, was zu alten Indyversionen gehört. Vorher die IDE zumachen. Beim Neustart der IDE wird sie Dich dann darüber informieren, was da so schiefgeht, z. B. Dich informieren, dass "alte" Indypackages nicht mehr geladen werden können ... (was ja durchaus erwünscht ist).

Du kannst dazu auch im "neuen Indyverzeichnis" mal alles "wegwerfen", was nicht zu Deiner Delphiversion gehört, das dürften vermutlich alle Dateien unter \Lib\Core\ sein, die am Ende eine Zahl im Namen haben, die aber nicht 230 ist. So ungefähr alles von dclIndyCore100.* bis dclIndyCore220.* und alles ab dclIndyCore240.* bis dclindycorelaz.*, analog dann auch noch für IndyCore*.*, unter \Lib\Protocols\ sieht es ähnlich aus, ebenso unter \Lib\System\.

Für Dein Delphi dürftest Du wohl alles benötigen, was in Indy230.groupproj aufgeführt ist. Die Projektgruppe zu verwenden, wäre eventuell auch keine schlechte Idee. Damit sollte eigentlich alles für Dein Delphi korrekt kompiliert und installiert werden können.

Mal in allen Pfaden nach dem Package IndySystem160 suchen.
  Mit Zitat antworten Zitat
HappyJoe

Registriert seit: 14. Nov 2006
37 Beiträge
 
Delphi XE2 Professional
 
#12

AW: SMTP-Problem, Indy und TLS 1.3 oder ICS

  Alt 13. Aug 2021, 18:42
Jetzt habe ich deine Ratschläge befolgt und alles ist installiert und ich kann mein Prog sogar compilieren. Dein ausführlicher Post war echt super, danke.
Leider geht der Verbindungsaufbau zu strato trotzdem nicht. Je nachdem, welche Version ich einstelle, kommen unterschiedliche Fehlermeldung (s. Grafik). Vermutlich fehlen nur noch ein paar Einstellungen. Würdest du mal einen kurzen Blick auf meine Routine werfen? Vielleicht springt dir der Fehler ja sofort ins Auge. Brauche ich eine spezielle Version von libeay32.dll oder ssleay32.dll?

Delphi-Quellcode:
procedure TMainForm.Btn_TESTMAILClick(Sender: TObject);
var
  idAttachment : TIdAttachmentFile;
  Mail : TIdMessage;
  SMTP : TIdSMTP;
  SSL : TIdSSLIOHandlerSocketOpenSSL;
  MBHTML: TIdMessageBuilderHTML;
  MailText : string;

begin
  SMTP := TIdSMTP.Create;
  SSL := TIdSSLIOHandlerSocketOpenSSL.Create(SMTP);
  SSL.SSLOptions.SSLVersions := [sslvTLSv1_2]; //XXX

  Mail := TIdMessage.Create;

  try
    MBHTML := TIdMessageBuilderHTML.Create;
    try
      with MBHTML do
      begin
        HTML.Text := 'Die ist eine Testmail.';
        HtmlCharSet := 'utf-8';
        FillMessage(Mail);
      end;
    finally
      MBHTML.Free;
    end;

    with Mail do
    begin
      From.Address := ... ;
      From.Name := ... ;
      Recipients.EMailAddresses := ... ;
      Subject := 'Test-Mail';
    end;

    with SMTP do
    begin
      Host := 'smtp.strato.de';
      Username := ... ;
      Password := ... ;
      Port := 465;
      AuthType := satDefault;
      IOHandler := SSL;
      UseTLS := utUseImplicitTLS;

      try
        Connect;
        Send(Mail);
      finally
        Disconnect;
      end;
    end;
  finally
    Mail.Free;
    SMTP.Free;
  end;
end;
Miniaturansicht angehängter Grafiken
vers1.jpg  
  Mit Zitat antworten Zitat
Benutzerbild von Union
Union

Registriert seit: 18. Mär 2004
Ort: Luxembourg
3.347 Beiträge
 
Delphi 7 Enterprise
 
#13

AW: SMTP-Problem, Indy und TLS 1.3 oder ICS

  Alt 13. Aug 2021, 19:16
Welche Versionen der OpenSSL dll verwendest Du?
Ibi fas ubi proxima merces
sudo /Developer/Library/uninstall-devtools --mode=all
  Mit Zitat antworten Zitat
HappyJoe

Registriert seit: 14. Nov 2006
37 Beiträge
 
Delphi XE2 Professional
 
#14

AW: SMTP-Problem, Indy und TLS 1.3 oder ICS

  Alt 13. Aug 2021, 19:23
Version 0.9.8.14
  Mit Zitat antworten Zitat
Benutzerbild von Union
Union

Registriert seit: 18. Mär 2004
Ort: Luxembourg
3.347 Beiträge
 
Delphi 7 Enterprise
 
#15

AW: SMTP-Problem, Indy und TLS 1.3 oder ICS

  Alt 13. Aug 2021, 19:31
DIe Version sollte > 1 sein. Ich setze hier u.a. 1.0.2.12 ein. Zum Herumspielen unter Erhaltung der Interoperabilität empfiehlt es sich, die dlls jeweils gezielt von Indy laden zu lassen.
IdSSLOpenSSLHeaders.IdOpenSSLSetLibPath(<Pfad der ssl dll>);
Ibi fas ubi proxima merces
sudo /Developer/Library/uninstall-devtools --mode=all
  Mit Zitat antworten Zitat
HappyJoe

Registriert seit: 14. Nov 2006
37 Beiträge
 
Delphi XE2 Professional
 
#16

AW: SMTP-Problem, Indy und TLS 1.3 oder ICS

  Alt 13. Aug 2021, 19:41
DANKE DANKE an alle, die mir hier geholfen haben.

ES FUNKTIONIERT ALLES !!!
  Mit Zitat antworten Zitat
Benutzerbild von Union
Union

Registriert seit: 18. Mär 2004
Ort: Luxembourg
3.347 Beiträge
 
Delphi 7 Enterprise
 
#17

AW: SMTP-Problem, Indy und TLS 1.3 oder ICS

  Alt 13. Aug 2021, 19:51
Hört sich schon mal gut an. Um für die Zukunft gerüstet zu sein, solltest du einmal die TIdSMTP.SASLMechanisms Collection anschauen und ggf. alle reinaddieren. Dann wird die AUTH response Indy dazu bewegen, das korrekte Verfahren zu verwenden.
Ibi fas ubi proxima merces
sudo /Developer/Library/uninstall-devtools --mode=all
  Mit Zitat antworten Zitat
HappyJoe

Registriert seit: 14. Nov 2006
37 Beiträge
 
Delphi XE2 Professional
 
#18

AW: SMTP-Problem, Indy und TLS 1.3 oder ICS

  Alt 13. Aug 2021, 21:53
Das sagt mir jetzt alles noch nichts, aber da werde ich hier im Forum mal etwas stöbern. Meinst du, das wäre besser als die ICS-Routinen?
  Mit Zitat antworten Zitat
Benutzerbild von Union
Union

Registriert seit: 18. Mär 2004
Ort: Luxembourg
3.347 Beiträge
 
Delphi 7 Enterprise
 
#19

AW: SMTP-Problem, Indy und TLS 1.3 oder ICS

  Alt 15. Aug 2021, 00:09
ICS habe ich bisher nicht eingesetzt. Ich verwende möglichst das Winhttp und wenn dort etwas nicht verfügbar ist, die Indy.
Ibi fas ubi proxima merces
sudo /Developer/Library/uninstall-devtools --mode=all
  Mit Zitat antworten Zitat
freimatz

Registriert seit: 20. Mai 2010
1.032 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#20

AW: SMTP-Problem, Indy und TLS 1.3 oder ICS

  Alt 16. Aug 2021, 11:10
DIe Version sollte > 1 sein. Ich setze hier u.a. 1.0.2.12 ein. Zum Herumspielen unter Erhaltung der Interoperabilität empfiehlt es sich, die dlls jeweils gezielt von Indy laden zu lassen.
IdSSLOpenSSLHeaders.IdOpenSSLSetLibPath(<Pfad der ssl dll>);
Ist das nötig wenn die DLLs im Programmverzeichnis liegen?
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 10:54 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf