AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

MSDE Fehler

Ein Thema von HomerGER · begonnen am 12. Jul 2007 · letzter Beitrag vom 15. Jul 2007
Antwort Antwort
Seite 1 von 2  1 2   
Benutzerbild von HomerGER
HomerGER

Registriert seit: 9. Jun 2003
390 Beiträge
 
Delphi 7 Professional
 
#1

MSDE Fehler

  Alt 12. Jul 2007, 20:41
Datenbank: MDSE • Zugriff über: Enterprise Manager + MSSEE
Hallo
auf ein Windows 2000 Server läuft ne MSDE

nun versuche ich sie von ein Client anzusprechen.
tcp/ip ist aktiviert

diese Meldung erhalte ich
Miniaturansicht angehängter Grafiken
fehlersql_328.jpg  
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.651 Beiträge
 
Delphi 10.4 Sydney
 
#2

Re: MSDE Fehler

  Alt 12. Jul 2007, 20:45
Wenn ich die Fehlermeldung richtig deute, versuchst du eine Verbindung mit einem SQL2005-Server aufzubauen, auf dem Server läuft aber eine MSDE (also SQL2000). Kannst du in die Richtung was im Client konfigurieren?
Markus Kinzler
  Mit Zitat antworten Zitat
Benutzerbild von HomerGER
HomerGER

Registriert seit: 9. Jun 2003
390 Beiträge
 
Delphi 7 Professional
 
#3

Re: MSDE Fehler

  Alt 12. Jul 2007, 21:03
über den SQL Server Management Studio Express was ja auch local auf den Server funktioniert

auf den Client kommt die Fehlermeldung
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.651 Beiträge
 
Delphi 10.4 Sydney
 
#4

Re: MSDE Fehler

  Alt 12. Jul 2007, 21:06
-Kann man im Client das Protokoll (SQL2000/SQL2005) einstellen?
-Hast du, wie auch in der Fehlermeldung steht, den Zugriff von außen auf den Server erlaubt?
Markus Kinzler
  Mit Zitat antworten Zitat
Benutzerbild von Flocke
Flocke

Registriert seit: 9. Jun 2005
Ort: Unna
1.172 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#5

Re: MSDE Fehler

  Alt 12. Jul 2007, 21:13
So weit ich weiß funktioniert die MSDE nur lokal, sich von einem anderen Client mit dem Server zu verbinden sollte daher schon aus Prinzip nicht klappen.
Volker
Besucht meine Garage
Aktuell: RtfLabel 1.3d, PrintToFile 1.4
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.651 Beiträge
 
Delphi 10.4 Sydney
 
#6

Re: MSDE Fehler

  Alt 12. Jul 2007, 21:14
Nein die MSDE kann auch externe Anfragen beantworten. Die Performance wird aber bei mehr als 5 Verbindungen gedrosselt.
Markus Kinzler
  Mit Zitat antworten Zitat
Benutzerbild von HomerGER
HomerGER

Registriert seit: 9. Jun 2003
390 Beiträge
 
Delphi 7 Professional
 
#7

Re: MSDE Fehler

  Alt 12. Jul 2007, 21:55
Zitat von mkinzler:
-Kann man im Client das Protokoll (SQL2000/SQL2005) einstellen?
Wo?

Zitat von mkinzler:
-Hast du, wie auch in der Fehlermeldung steht, den Zugriff von außen auf den Server erlaubt?
Meinst du RemoteServerVerbindung mit Hilfe von RPC? Ja!
  Mit Zitat antworten Zitat
alzaimar
(Moderator)

Registriert seit: 6. Mai 2005
Ort: Berlin
4.956 Beiträge
 
Delphi 2007 Enterprise
 
#8

Re: MSDE Fehler

  Alt 12. Jul 2007, 22:57
Soweit ich mich erinnere, installiert sich die MSDE per default ohne Netzwerkunterstützung. Ich würde die MSDE deinstallieren, dann schauen, wie das mit der Netzwerkunterstützung genau geht (ich glaube, ein Kommandozeilenparameter), und dann nochmal installieren.

Hat bei mir (vor Jahren) funktioniert.
"Wenn ist das Nunstruck git und Slotermeyer? Ja! Beiherhund das Oder die Flipperwaldt gersput!"
(Monty Python "Joke Warefare")
  Mit Zitat antworten Zitat
Benutzerbild von HomerGER
HomerGER

Registriert seit: 9. Jun 2003
390 Beiträge
 
Delphi 7 Professional
 
#9

Re: MSDE Fehler

  Alt 13. Jul 2007, 02:03
Meinste du
DISABLENETWORKPROTOCOLS und SECURITYMODE?

Die Protokolle kannst du nachträglich einstellen.
Habe ich mit Enterprise Manager gemacht.


Und den Mode auch.
  Mit Zitat antworten Zitat
Benutzerbild von Ralf Kaiser
Ralf Kaiser

Registriert seit: 21. Mär 2005
Ort: Wuppertal
914 Beiträge
 
Delphi 10.3 Rio
 
#10

Re: MSDE Fehler

  Alt 13. Jul 2007, 08:34
Zitat von HomerGER:
nun versuche ich sie von ein Client anzusprechen.
tcp/ip ist aktiviert
Hi,

läuft da eine Firewall? (da es ja W2K ist, gibt es ja keine "Standard"-Firewall aber hast du eine installiert oder gibt es zwischen Client und Server einen Router mit Firewall?)

Es muss der TCP-Port 1433 (in der Standardeinstellung) freigeschaltet sein. Ausserdem muss der SQL-Browserdienst laufen und als Ausnahme (sqlbrowser.exe) in der Firewall eingetragen sein. Das Executeable "sqlserver.exe" sollte in der Firewall ebenfalls als Ausnahme eingetragen sein. Und das auf allen beteiligten Systemen (also Client UND Server).

Ciao,
Ralf

[Edit:] noch ein Tipp: schmeiss am besten MSDE raus und installier SQLEXPRESS 2005 (den Nachfolger)
Ralf Kaiser
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 12:55 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf