AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Delphi-PRAXiS - Lounge Betriebssysteme Vista (Internet-Explorer): Problem mit Internet-Verbindung

Vista (Internet-Explorer): Problem mit Internet-Verbindung

Ein Thema von Helmi · begonnen am 29. Jul 2007 · letzter Beitrag vom 1. Aug 2007
Antwort Antwort
Benutzerbild von Helmi
Helmi

Registriert seit: 29. Dez 2003
Ort: Erding, Republik Bayern
3.304 Beiträge
 
Delphi XE2 Professional
 
#1

Vista (Internet-Explorer): Problem mit Internet-Verbindung

  Alt 29. Jul 2007, 20:14
Hallo,

mein Internet-Explorer unter Vista meldet hin und wieder, dass keine Internetverbindung bestünde und bringt das Fenster ob man Wiederholen soll oder offline laufen will.

Das kann aber nicht sein, denn...

1. meldet z. B. der MSN-Messanger nicht, dass er keine Verbindung habe,
2. der Rechner an einem Router mit Flatrat hängt

WEnn ich auf wiederholen klicke, dann funktioniert alles ohne Probleme.


Was mir auch auffällt, dass andere Programme sagen, es gäbe grundsätzlich kein I-net-Verbindung.
Mir scheint so, als gäbe Vista den Programmen nicht mit, dass eine I-net-Verbindung vorhanden sei.

An was könnte das liegen?
mfg
Helmi

>> Theorie ist Wissen, dass nicht funktioniert - Praxis ist, wenn alles funktioniert und keiner weiss warum! <<
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.991 Beiträge
 
Delphi XE4 Professional
 
#2

Re: Vista (Internet-Explorer): Problem mit Internet-Verbindu

  Alt 1. Aug 2007, 11:34
Hallo,

vielleicht schaltet die Netzkarte wegen Power-Management ab ?
Dass der MSN nicht mechkert, könnte daran liegen, dass er die Verbindung selbständig
wieder aufbaut und von MS$ ist ... .

Das Powermanagement stellt man direkt bei der Netzwerkkarte ein
(Gerätemanager)

Heiko
Heiko
  Mit Zitat antworten Zitat
OregonGhost

Registriert seit: 8. Jun 2002
Ort: Lübeck
1.216 Beiträge
 
Delphi 3 Professional
 
#3

Re: Vista (Internet-Explorer): Problem mit Internet-Verbindu

  Alt 1. Aug 2007, 11:45
Was MSN angeht, ist meine Erfahrung mit den meisten Instant Messengern, dass sie relativ gutmütig mit Verbindungsabbrüchen umgehen und erst nach einiger Zeit den Fehler melden. Wenn bis dahin die Verbindung wieder steht, juckt den IM das nicht sonderlich. Daran würde ich also eine beständige Verbindung nicht gerade ausmachen.

Zitat:
2. der Rechner an einem Router mit Flatrat hängt
Also, erstens gibt es keine "Flatrate", mit der du rund um die Uhr online bist. Die meisten Provider schalten nach spätestens 24 Stunden ab (der Router wählt sich dann normalerweise selbstständig neu ein). Aber auch so kann der Router durchaus nach kurzer Inaktivität die Verbindung beenden, z.B. nach 5 Minuten. Dann braucht er gegebenenfalls eine Zeitlang, um sich wieder einzuwählen und zumindest theoretisch könnte ein Programm in dieser Zeit mitbekommen, dass die Verbindung gerade weg ist (z.B. TCP/IP-Verbindungen werden recht schnell unterbrochen). Schau also mal in die Konfiguration des Routers, ob da nicht sowas zu finden ist.

Bei Vista kannst du übrigens am Netzwerk-Symbol in der TNA sehen, ob du online bist. Wenn ja, ist da noch eine kleine Weltkugel vor den Monitoren. Bei Routern sollte das funktionieren (bei Proxys wird man z.B. korrekterweise als nicht online angezeigt). Ist die Weltkugel bei dir in so einer Situation weg?
Oregon Ghost
---
Wenn NULL besonders groß ist, ist es fast schon wie ein bisschen eins.
  Mit Zitat antworten Zitat
Benutzerbild von Helmi
Helmi

Registriert seit: 29. Dez 2003
Ort: Erding, Republik Bayern
3.304 Beiträge
 
Delphi XE2 Professional
 
#4

Re: Vista (Internet-Explorer): Problem mit Internet-Verbindu

  Alt 1. Aug 2007, 17:54
Zitat von OregonGhost:
Ist die Weltkugel bei dir in so einer Situation weg?
Nein, die Weltkugel (jetzt weiss ich endlich was das darstellen soll ) ist zu diesem Zeitpunkt vorhanden.
mfg
Helmi

>> Theorie ist Wissen, dass nicht funktioniert - Praxis ist, wenn alles funktioniert und keiner weiss warum! <<
  Mit Zitat antworten Zitat
Benutzerbild von Phoenix
Phoenix
(Moderator)

Registriert seit: 25. Jun 2002
Ort: Hausach
7.529 Beiträge
 
#5

Re: Vista (Internet-Explorer): Problem mit Internet-Verbindu

  Alt 1. Aug 2007, 18:30
Mir passiert das immer, wenn ich längere Zeit EVE spiele.

Ein Neustart der betroffenen Anwendung (z.B. Firefox, Skype, Trillian) behebt das Problem für diese. Das heisst selbst wenn die Verbindung wegbricht -> Anwendung neu starten und es geht wieder.

Problematisch ist das nur beim IE: Da der Windows Explorer (der ja als Taskleiste mit Startmenü z.B. immer läuft) und der IE so eng verzahnt sind kann man den IE nicht vollständig beenden. Ein Neustart hilft hier leider nicht.

Ein abmelden und neu anmelden des Users hilft hier. Ist allerdings tatsächlich nervig.
Sebastian P.R. Gingter
不死鳥 Visit my Blog.
Do not argue with an idiot. They lower you to their level and then try to beat you with experience.
  Mit Zitat antworten Zitat
kleiner Unwissender

Registriert seit: 24. Jul 2005
Ort: Rostock
188 Beiträge
 
Delphi 6 Personal
 
#6

Re: Vista (Internet-Explorer): Problem mit Internet-Verbindu

  Alt 1. Aug 2007, 20:00
Zitat von Phoenix:
Problematisch ist das nur beim IE: Da der Windows Explorer (der ja als Taskleiste mit Startmenü z.B. immer läuft) und der IE so eng verzahnt sind kann man den IE nicht vollständig beenden. Ein Neustart hilft hier leider nicht.
auch nicht, wenn man über den Taskmanager den (Windows-) Explorer abschießt und neu startet? Ich hab das Problem zwar nicht, könnte mir aber vorstellen, das das schneller geht als sich neu anzumelden.
never change a running system
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 17:29 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf