AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Problem mit Align

Ein Thema von Fussball-Robby · begonnen am 8. Apr 2010 · letzter Beitrag vom 8. Apr 2010
Antwort Antwort
Benutzerbild von Fussball-Robby
Fussball-Robby

Registriert seit: 22. Okt 2007
Ort: Nähe Köln
1.063 Beiträge
 
Delphi 7 Enterprise
 
#1

Problem mit Align

  Alt 8. Apr 2010, 15:39
Hey,

ich habe im Moment ein Problem mit der Ausrichtung von Komponenten auf dem Formular.. Im Anhang ein Screenshot.
Beim TreeView ist Align alLeft, beim Splitter daneben auch. Die ListView ist alClient. Das PageControl unten hat alBottom.

So weit, so gut, bis hierhin klappt alles. Jetzt möchte ich aber noch ein Panel hinzufügen, welches rechts neben dem PageControl liegt und die gleiche Höhe hat. Mit alBottom liegt es aber über dem PageControl und mit alRight ebenfalls drüber und rechts am Rand.
Wie bekomme ich es einfach rechts daneben? (Alle anderen Threads dazu sind immer Einzellösungen in denen ne Menge rumgebastelt wurde )
Hoffe, mir kann jemand helfen!
Miniaturansicht angehängter Grafiken
align_190.png  
Robert L.
Der folgende Satz ist richtig!
Der vorherige Satz ist falsch!

Paradox
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.553 Beiträge
 
Delphi 10.3 Rio
 
#2

Re: Problem mit Align

  Alt 8. Apr 2010, 15:43
Ein Panel nehmen in das das PageControl und Deine zusätzliche Komponente kommt. Fertig.

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
Benutzerbild von Fussball-Robby
Fussball-Robby

Registriert seit: 22. Okt 2007
Ort: Nähe Köln
1.063 Beiträge
 
Delphi 7 Enterprise
 
#3

Re: Problem mit Align

  Alt 8. Apr 2010, 15:47
Ebenso einfach wie genial
Da hätt ich auch selber drauf kommen können Danke!
Robert L.
Der folgende Satz ist richtig!
Der vorherige Satz ist falsch!

Paradox
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.553 Beiträge
 
Delphi 10.3 Rio
 
#4

Re: Problem mit Align

  Alt 8. Apr 2010, 15:47
Gerne geschehen.

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
Benutzerbild von Matze
Matze
(Co-Admin)

Registriert seit: 7. Jul 2003
Ort: Schwabenländle
14.987 Beiträge
 
Turbo Delphi für Win32
 
#5

Re: Problem mit Align

  Alt 8. Apr 2010, 15:50
Als Ergänzung: Nicht immer, aber oft hilft auch die Eigenschaft "Anchors" weiter.
  Mit Zitat antworten Zitat
Benutzerbild von Fussball-Robby
Fussball-Robby

Registriert seit: 22. Okt 2007
Ort: Nähe Köln
1.063 Beiträge
 
Delphi 7 Enterprise
 
#6

Re: Problem mit Align

  Alt 8. Apr 2010, 16:05
Zitat von Matze:
Als Ergänzung: Nicht immer, aber oft hilft auch die Eigenschaft "Anchors" weiter.
Das hatte ich mir schon gedacht, konnte mir die Funktion dieser Eigenschaft aber nicht ganz erschließen.. Bei Gelegenheit schaue ich mir das auch mal an, danke.
Robert L.
Der folgende Satz ist richtig!
Der vorherige Satz ist falsch!

Paradox
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 02:55 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf