AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Sprachen und Entwicklungsumgebungen Die Delphi-IDE Merkwürdiges Öffnen einzelner Projekte

Merkwürdiges Öffnen einzelner Projekte

Ein Thema von Piro · begonnen am 2. Jul 2010 · letzter Beitrag vom 2. Jul 2010
Antwort Antwort
Seite 1 von 2  1 2   
Benutzerbild von Piro
Piro

Registriert seit: 14. Jul 2003
Ort: Flintbek
810 Beiträge
 
Delphi XE2 Professional
 
#1

Merkwürdiges Öffnen einzelner Projekte

  Alt 2. Jul 2010, 12:37
Moin zusammen,

vielleicht kennt einer das Problem. Ich habe eine TurboDelphi Pro Version.

Problem spielt sich in der IDE ab.
Seit einiger Zeit, wird das Hauptformular einiger Projekte nicht mehr geöffnet. Anstelle des Hauptformular wird nur noch der Quelltext des Projektes angezeigt. Siehe Anhang.

Ich muss dann erst auf den Button Formular anzeigen klicken, um dann mein Hauptformular zu sehen. Und dann kann ich los legen. Zur Info, die betroffenen Projekte haben mehre Formulare.
Ab und zu kommt es aber auch vor, dass er dann sagt, dass das Formular noch in Benutzung ist und ich es erst später aufrufen kann.
Es hat aber keiner das Formular auf. Delphi ist zum 1. Mal gestartet und es ist noch nichts offen.

Habe ich vielleicht irgendetwas verstellt bei den Projekten? Ich würde gerne eine Neuinstallation aufgrund zahlreicher PlugIns vermeiden.

Vielen Dank im Voraus.
Miniaturansicht angehängter Grafiken
ide.png  
  Mit Zitat antworten Zitat
Benutzerbild von Piro
Piro

Registriert seit: 14. Jul 2003
Ort: Flintbek
810 Beiträge
 
Delphi XE2 Professional
 
#2

AW: Merkwürdiges Öffnen einzelner Projekte

  Alt 2. Jul 2010, 12:47
Ich habe folgendes durch Zufall herausgefunden. Es liegt an meiner Projektquelldatei:

Delphi-Quellcode:
program KECSystemManagement;

uses
  Windows,
  SysUtils,
  Forms,
  Dialogs,
  MSXML2_TLB,
  Registry,

  uMain in 'uMain.pas{frm_main},
  uService in 'uService.pas{frm_service},
  MpuWinNT in 'MpuWinNT.pas',
  CheckUser in 'CheckUser.pas',
  ActiveDs_TLB in 'ActiveDs_TLB.pas',
  adshlp in 'adshlp.pas',
  uLogin in 'uLogin.pas',
  uSystemEventlog in 'uSystemEventlog.pas{frm_systemeventlog},
  uPowerRemoteConsole in 'uPowerRemoteConsole.pas{frm_powerremoteconsole},
  StartOnce in 'StartOnce.pas',
  uHostAlive in 'uHostAlive.pas',
  uSystem in 'uSystem.pas{frm_system},
  uContact in 'uContact.pas{frm_contact};

{$R *.res}

function DoesXMLExist: boolean;
var
 reg : TRegistry;
 s : string;
begin
 Result := false;
 reg := TRegistry.Create(KEY_READ);
 if reg <> nil then
 begin
   with reg do
   try
     RootKey := HKEY_CLASSES_ROOT;
     if OpenKey('CLSID\' + GuidToString(CLASS_DOMDocument40)+ '\InProcServer32', false) then
     try
       s := ReadString('');
       s := StringReplace(s,'%SystemRoot%',GetEnvironmentVariable('SYSTEMROOT'),[rfReplaceAll]); // falls eine Systemvariable gesetzt ist
       Result := (s <> '') and (fileexists(s));
     finally
      CloseKey;
     end;
   finally
     Free;
   end;
 end;
end;

begin
  ReportMemoryLeaksOnShutdown := True;
  Application.Initialize;
  Application.Title := 'KECSystemManagement';
  if not DoesXMLExist then
  begin
    MessageDlg('MSXML 4.0 is required. ' + Application.Title + 'will be terminated.',mtInformation,[mbOK],0);
    Application.Terminate;
  end
  else
  begin
    Application.CreateForm(Tfrm_main, frm_main);
    Application.CreateForm(Tfrm_service, frm_service);
    Application.CreateForm(Tfrm_systemeventlog, frm_systemeventlog);
    Application.CreateForm(Tfrm_powerremoteconsole, frm_powerremoteconsole);
    Application.CreateForm(Tfrm_system, frm_system);
    Application.CreateForm(Tfrm_contact, frm_contact);
    Application.Run;
  end;
Wenn ich Application.CreateForm(Tfrm_main, frm_main); außerhalb der IF Anweisung setze, wird das Formular auch beim Start des Projektes auch gleich mitgeöffnet. Hat aber zur Folge, dass mein Programm zur Laufzeit erst das Formular erstellt und dann erst XML prüft. Das würde ich ungern machen wollen.

Gibt es noch einen anderen Weg?

Gruß, Sven
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
8.116 Beiträge
 
Delphi 10.4 Sydney
 
#3

AW: Merkwürdiges Öffnen einzelner Projekte

  Alt 2. Jul 2010, 12:47
Hallo,

F12 geht schneller.


Heiko
Heiko
  Mit Zitat antworten Zitat
Benutzerbild von Deep-Sea
Deep-Sea

Registriert seit: 17. Jan 2007
907 Beiträge
 
Delphi XE2 Professional
 
#4

AW: Merkwürdiges Öffnen einzelner Projekte

  Alt 2. Jul 2010, 12:55
Du solltest keinen eigenen Code in die Projektdatei packen. Nicht, weil es etwa unsauber wäre, sondern einfach weil Delphi es nicht mag - wie man sieht.
Um so etwas wie die Verfügbarkeit einer wichtigen Sache zu testen kannst du dies woanders tun, z.B. in initialization-Abschnitten oder im OnCreate der Hauptform.
Beim OnCreate kannst du dein Problem gut lösen, finde ich. Solltest du dich beenden wollen, setze vorher auch noch Application.ShowMainForm auf false.
Chris
Die Erfahrung ist ein strenger Schulmeister: Sie prüft uns, bevor sie uns lehrt.
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.824 Beiträge
 
Delphi 10.4 Sydney
 
#5

AW: Merkwürdiges Öffnen einzelner Projekte

  Alt 2. Jul 2010, 12:56
Ich hatte bisher keine Probleme mit Code im Projekt. Zudem kann man nicht allen Code ins Hauptformular packen
Markus Kinzler
  Mit Zitat antworten Zitat
Benutzerbild von Deep-Sea
Deep-Sea

Registriert seit: 17. Jan 2007
907 Beiträge
 
Delphi XE2 Professional
 
#6

AW: Merkwürdiges Öffnen einzelner Projekte

  Alt 2. Jul 2010, 12:59
Ich hatte bisher keine Probleme mit Code im Projekt.
Kommt halt auf den Code an ... aber wenn's nicht sein muss sollte man's IMHO lassen.

Zudem kann man nicht allen Code ins Hauptformular packen
Hat auch niemand behauptet. Aber das Problem von Piro z.B. schon.
Chris
Die Erfahrung ist ein strenger Schulmeister: Sie prüft uns, bevor sie uns lehrt.
  Mit Zitat antworten Zitat
Benutzerbild von Piro
Piro

Registriert seit: 14. Jul 2003
Ort: Flintbek
810 Beiträge
 
Delphi XE2 Professional
 
#7

AW: Merkwürdiges Öffnen einzelner Projekte

  Alt 2. Jul 2010, 20:57
Und wie wäre es am sinnvollsten?

Ich würde es ungern ins OnCreate Ereignis packen bzw. dort behandeln. Im OnCreate sind Sachen, die nicht unbedingt ausgeführt werden sollen, wenn kein XML installiert ist.

Also wie wäre es am besten?

Danke.
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#8

AW: Merkwürdiges Öffnen einzelner Projekte

  Alt 2. Jul 2010, 21:32
Um so etwas wie die Verfügbarkeit einer wichtigen Sache zu testen kannst du dies woanders tun, [..] oder im OnCreate der Hauptform.
Er macht es schon genau richtig. Im OnCreate ist es wie: "ich versuche mal mein Glück und wenn es nicht klappt, steige ich ein und gleichzeitig wieder aus." Da das nicht geht, kommen dann wieder so Konstrukte mit Timern und OnShow usw. Das ist Krux. Es ist schon richtig das Formular nur zu erstellen, wenn auch die nötigen Bedingungen erfüllt sind. Und man sollte sich nicht durch die Unzulänglichkeiten seines Werkzeugs dazu verleiten lassen schlechten Code zu produzieren.

Wenn du mit dem Auto wegfahren willst, stellst du ja auch vorher sicher, dass du den Schlüssel dabei hast und gehst nicht einfach so auf gut Glück aus den Haus oder?
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Benutzerbild von Piro
Piro

Registriert seit: 14. Jul 2003
Ort: Flintbek
810 Beiträge
 
Delphi XE2 Professional
 
#9

AW: Merkwürdiges Öffnen einzelner Projekte

  Alt 2. Jul 2010, 21:37
Vielen Dank für Bestätigung, dass es richtig programmiert ist. Heist es aber nun, dass ich akzeptieren muss, dass das Hauptformular beim Öffnen des Projektes nicht automatisch wird?

Wenn das so ist, dann weiß ich Bescheid und weiß, dass alles richtig ist.
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
37.621 Beiträge
 
Delphi 2006 Professional
 
#10

AW: Merkwürdiges Öffnen einzelner Projekte

  Alt 2. Jul 2010, 21:45
Jupp, musst du wohl akzeptieren, da die IDE beim Parsen der Projektdatei kein Hauptformular findet, weil die IDE den if-Block nicht auswerten kann.
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 00:14 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf