AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

DelphiTwain DXE2 V1.5

Ein Thema von Homie15 · begonnen am 31. Mär 2015 · letzter Beitrag vom 1. Apr 2015
Antwort Antwort
Seite 1 von 2  1 2   
Homie15

Registriert seit: 15. Aug 2013
8 Beiträge
 
#1

DelphiTwain DXE2 V1.5

  Alt 31. Mär 2015, 16:21
Hi,

wir haben folgendes Problem mit der DelphiTwain:
Damals hatten wir MultiTwain, da es dieses aber nicht mehr für XE2 gibt, sind wir nun auf DelphiTwain umgestiegen. Allerdings werden trotz des setzens auf den nativen Transfermodus keine WIA-Scanner mehr angezeigt.

Laut den Logs sollten diese aber ab Version 1.2 unterstützt und angezeigt werden.

Hat jemand einen Vorschlag wie man diese Scanner anzeigen kann und verwenden kann?
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
40.477 Beiträge
 
Delphi 11 Alexandria
 
#2

AW: DelphiTwain DXE2 V1.5

  Alt 31. Mär 2015, 16:27
DelphiTwain ... WIA

Was sagt denn der Hersteller? (Support)



Wie benutzten die Komponenten von www.imageen.com ... die können Beides.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
my Delphi wish list
  Mit Zitat antworten Zitat
Perlsau
(Gast)

n/a Beiträge
 
#3

AW: DelphiTwain DXE2 V1.5

  Alt 31. Mär 2015, 16:58
Allerdings werden trotz des setzens auf den nativen Transfermodus keine WIA-Scanner mehr angezeigt.
Kann ich hier mit XE7 nicht nachvollziehen, wie du an dieser Grafik sehen kannst.
  Mit Zitat antworten Zitat
Homie15

Registriert seit: 15. Aug 2013
8 Beiträge
 
#4

AW: DelphiTwain DXE2 V1.5

  Alt 1. Apr 2015, 08:18
Hallo,

mit Delphi 7 und MultTwain wurden bei der Auswahl der Scanner / Drucker
der Twain UND der Wia Treiber angezeigt.

Unser Kunde nutzte diese Version bis letzten Monat
und bei Auswahl des Wia Treiber funktionierte bei ihm der Scan mehrerer Seiten tadellos.

Mit Delphi Twain 1.5 und XE2 in unserer aktuellen Version wird nur der Twain Treiber zur Auswahl angezeigt und
der Scan mehrerer Seiten liefert nur die letzte Seite als Image.

Danke für die Hilfe im Vorraus -Marcello
  Mit Zitat antworten Zitat
HPB

Registriert seit: 2. Jun 2008
365 Beiträge
 
Delphi XE7 Professional
 
#5

AW: DelphiTwain DXE2 V1.5

  Alt 1. Apr 2015, 09:35
Allerdings werden trotz des setzens auf den nativen Transfermodus keine WIA-Scanner mehr angezeigt.
Kann ich hier mit XE7 nicht nachvollziehen, wie du an dieser Grafik sehen kannst.
Guten Tag,
an Hand der Grafik sehe ich dass Du das Scannen gelöst hast.
Kannst Du nicht mal den Quellcode hier einstellen????
Mit Gruß
HPB
  Mit Zitat antworten Zitat
Perlsau
(Gast)

n/a Beiträge
 
#6

AW: DelphiTwain DXE2 V1.5

  Alt 1. Apr 2015, 09:51
Der Quellcode steht bereits dort.
  Mit Zitat antworten Zitat
HPB

Registriert seit: 2. Jun 2008
365 Beiträge
 
Delphi XE7 Professional
 
#7

AW: DelphiTwain DXE2 V1.5

  Alt 1. Apr 2015, 11:09
Danke für Deine Antwort.
Der angezeigte Quellcode ist ja der Originalcode aus DelphiTwain.
Den benutze ich auch.
Mein Problem ist folgendes:
Wähle ich Scannen über WIA aus, dann wird mir das Vorschaufenster angezeigt
und ich kann die Vorschau scannen. Beim Übertragen des Scans wird nichts mehr angezeigt.
Wähle ich jedoch den Scanner aus scanne dann, wird auch das Ergebnis übertragen.
Ich habe schon ein kleines Projekt erzeugt, das nur scannen soll.
Im dem kleinen Projekt läuft alles so wie es sein soll, nur im Programm,
in der ich dann wirklich scannen will, klappt es einfach nicht und nun weiss ich mir
keinen Rat mehr.
Deshalb würde ich gerne in den Quellcode schauen um zu sehen wo ich den Fehler
mache.
Vilen Dank für Deine Hilfe
HPB
  Mit Zitat antworten Zitat
Perlsau
(Gast)

n/a Beiträge
 
#8

AW: DelphiTwain DXE2 V1.5

  Alt 1. Apr 2015, 11:18
Welchen Quellcode meinst du denn? Ich rufe die Twain-Schnittstelle auf. Mehr mache ich nicht. Du willst doch wohl nicht den Quellcode meines gesamten Projekts sehen?
  Mit Zitat antworten Zitat
HPB

Registriert seit: 2. Jun 2008
365 Beiträge
 
Delphi XE7 Professional
 
#9

AW: DelphiTwain DXE2 V1.5

  Alt 1. Apr 2015, 12:13
Welchen Quellcode meinst du denn? Ich rufe die Twain-Schnittstelle auf. Mehr mache ich nicht. Du willst doch wohl nicht den Quellcode meines gesamten Projekts sehen?
Nicht den gesamten Quellcode.
Aber kannst Du vielleicht den Code mit dem Scannformular bereitstellen?
Damit wäre doch bestimmt schon geholfen.
Vilen Dank
HPB
  Mit Zitat antworten Zitat
Perlsau
(Gast)

n/a Beiträge
 
#10

AW: DelphiTwain DXE2 V1.5

  Alt 1. Apr 2015, 14:05
Sorry, das gestattet mein Auftraggeber, an dessen Rechner und IDE ich gelegentlich arbeite, nicht, denn diese Unit ist projektspezifisch.

Wenn, wie du schreibst, deine Stand-Alone-Anwendung funktioniert und dein im Hauptprojekt eingebautes Formular nicht, sollte es dir doch ein Leichtes sein, die Unterschiede herauszufinden. Zeig doch mal, wie du die Übertragung des Scans gelöst hast: Wie sorgst du dafür, daß das gescannte Bild in einem TImage landet?
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 11:23 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf