AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

JEDI in GetIt?

Ein Thema von PeterPanino · begonnen am 3. Mai 2016 · letzter Beitrag vom 25. Okt 2016
Antwort Antwort
Seite 2 von 5     12 34     Letzte » 
Pfaffe

Registriert seit: 29. Jan 2009
250 Beiträge
 
Delphi 11 Alexandria
 
#11

AW: JEDI in GetIt?

  Alt 3. Mai 2016, 19:15
Dies Bild kann ich mit Seattle nachstellen, aber nicht mit Berlin?
  Mit Zitat antworten Zitat
PeterPanino

Registriert seit: 4. Sep 2004
1.344 Beiträge
 
Delphi 10.4 Sydney
 
#12

AW: JEDI in GetIt?

  Alt 3. Mai 2016, 19:22
Was habe ich dann für eine "abartige" 10.1 Berlin? Bei mir sind die Jedi's im GetIt-Manager enthalten....und wie man sieht auch installiert
Kannst du bitte die Build-Nummer von deinem Berlin posten? Meine ist: 24.0.22858.6822
  Mit Zitat antworten Zitat
mm1256

Registriert seit: 10. Feb 2014
Ort: Wackersdorf, Bayern
640 Beiträge
 
Delphi 10.1 Berlin Professional
 
#13

AW: JEDI in GetIt?

  Alt 3. Mai 2016, 19:29
oooops...bitte um Entschuldigung. Schei.. VM-Ware. Habe die verkehrte VM erwischt
Gruss Otto
Wenn du mit Gott reden willst, dann bete.
Wenn du ihn treffen willst, schreib bei Tempo 220 eine SMS
  Mit Zitat antworten Zitat
PeterPanino

Registriert seit: 4. Sep 2004
1.344 Beiträge
 
Delphi 10.4 Sydney
 
#14

AW: JEDI in GetIt?

  Alt 4. Mai 2016, 00:08
Deshalb hasse ich die manuelle JEDI-Installation:

jclerror.png

PS: Schuld sind natürlich die UNIX Zeilenendungen bei den extra heruntergeladenen Dateien jedi.inc und kylix.inc.

Und dann das hier:

Zitat:
[dcc32 Fatal Error] ClipLineDemo.dpr(3): F1026 File not found: 'jcl.inc'
Und das:

jediinstaller-220x161-dcdec26b6bd44298adf6a7ce3e7626b4.png

Und das:

jediinstaller-366x144-0e413ba3e36c48f18dcecb92707c1565.png

Geändert von PeterPanino ( 4. Mai 2016 um 00:44 Uhr)
  Mit Zitat antworten Zitat
PeterPanino

Registriert seit: 4. Sep 2004
1.344 Beiträge
 
Delphi 10.4 Sydney
 
#15

AW: JEDI in GetIt?

  Alt 4. Mai 2016, 01:16
Nach einer genervten Stunde:

Nach jcl-Installation keine Pfade in der IDE eingetragen (obwohl das im Installer angekreuzt war).

Nach manuellem Eintragen der Pfade versucht jcl Beispiel-Programme zu kompilieren, aber massive Fehler in den eingebundenen Units.

Habe für heute genug ...
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
8.178 Beiträge
 
Delphi 10.4 Sydney
 
#16

AW: JEDI in GetIt?

  Alt 4. Mai 2016, 07:18
PS: Schuld sind natürlich die UNIX Zeilenendungen bei den extra heruntergeladenen Dateien jedi.inc und kylix.inc.
Extra herunterladen muss man da nichts. Ein Submodule update reicht da, aber das sollte eigentlich vor dem Starten des Installers durch die install.bat passieren soweit ich weiß. Ich musste da nichts manuell machen.

Nach manuellem Eintragen der Pfade versucht jcl Beispiel-Programme zu kompilieren, aber massive Fehler in den eingebundenen Units.
Hast du die Pfade der Quelltexte vielleicht aus Versehen im Bibliothekspfad gesucht? Da gehören die nicht hin, nur in den Suchpfad.
Denn sonst kompilierst du bei deinen Projekten ja immer die JEDI Units mit.

bcc32.exe? Das ist doch der C++-Builder Compiler. Der sollte eigentlich gar nicht verwendet werden, ich wüsste jedenfalls nicht wofür. Oder ist das ein Tippfehler statt brcc32.exe, dann wäre das ein Bug.

Bei uns jedenfalls lief das ganze (auf drei Rechnern) so ab wie es sollte:
- Pullen
- jeweils install.bat starten, Lizenz annehmen, nur noch weiter klicken
- Delphi starten, lief
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
bkr

Registriert seit: 9. Mär 2006
6 Beiträge
 
#17

AW: JEDI in GetIt?

  Alt 5. Mai 2016, 22:38
Ich habe 10.1 vor einigen Tagen auf einem brandneuen Dell 7470 Win7, 64 bit, installiert, und schaffe es nicht (nach einer Zeit ohne Probleme in praktisch allen älteren Delphi-versionen) JEDI auf Delphi 10.1 zu installieren. Ich sehe im Getit Manager JCL und JVCL nicht (anders als aus dem Bild in diesem Thread). Download der jcl.zip und jvcl.zip von SourceForge (Sept. 2015) und update von *.inc in jcl/source/include/*.inc von 1.5.2016 aus jcl-master (in denen 10.1 explizit aufgeführt ist) aus github hilft nicht.

Instal.bat schliesst sofort nach dem dem Aufruf mit 'Installation finished', aber nichts ist installiert.
Wenn Delphi 10.1 in dieser Zeit läuft, kommt auch die Fehlermeldung, d.h. der Installer erkennt Delphi 10.1, aber ohne Delphi geschieht nichts.
(Im GetIt in XE 8 auf einem anderen PC sehe ich JCL und JVCL)

Hat das jemand in neuerer Zeit geschafft, und wie?

Jeder Rat wäre sehr willkommen, denn Delphi braucht JEDI

bkr
  Mit Zitat antworten Zitat
Benutzerbild von blawen
blawen

Registriert seit: 1. Dez 2003
Ort: Luterbach (CH)
521 Beiträge
 
Delphi 10.4 Sydney
 
#18

AW: JEDI in GetIt?

  Alt 6. Mai 2016, 00:22
Das Bild stammt noch von Delphi 10.0 Seattle.

Deine Version vom September 2015 kennt Delphi 10.1 nicht.

Entweder ladest Du die aktuelle Version von Github herunter oder nimmst ein "Daily packages" von http://jvcl.sourceforge.net/daily/, bzw. http://jcl.sourceforge.net/daily/
Roland
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
8.178 Beiträge
 
Delphi 10.4 Sydney
 
#19

AW: JEDI in GetIt?

  Alt 6. Mai 2016, 06:07
Wobei ich sehr raten würde TortoiseGit zu benutzen und das Repository direkt auszuchecken. Denn ansonsten kannst du dir keine Updates ziehen und musst bei der nächsten Delphiversion wieder das Zip suchen usw.
Wenn du TortoiseGit installiert hast, klickst du einfach mit rechts in dein Komponentenverzeichnis, rufst "Git clone..." auf und gibst dort https://github.com/project-jedi/jcl ein. Ein Klick auf Ok und du hast die aktuelle Version, dann machst du das noch mit https://github.com/project-jedi/jvcl und kannst beides installieren.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
bkr

Registriert seit: 9. Mär 2006
6 Beiträge
 
#20

AW: JEDI in GetIt?

  Alt 8. Mai 2016, 13:45
Vielen Dank für die beiden Tips, und (insbesondere mit tortoise) ist der Download einfach gewesen. Ich kämpfe aber jetzt seit Tagen damit, dass meien Lizenz nur Delphi, nich aber C++ beinhaltet und so auch auf dem neuen PC installiert ist.
Der JCL-Installer meldet aber bcc32.exe not found und bricht ab (gibt es in der Tat nicht),

Im RAD Studio 10.1 32bit.log steht aber im Kopf

JCL 2.8 Testing Build 5677
==========RAD Studio 10.1 32 bit=============================================== =
Installed personalities :
32 bit Delphi
64 bit Delphi
32 bit C++Builder

d.h. Delphi meldet offensichtlich eine nicht installiert personality. In JCLInstall.pas finde ich einen Kommentar, der die Möglichkeit erwähnt, dass nur Delphi, nich aber c++ installiert ist, aber da die Personality gemeldet wird, kommt diese Option wohl nicht zum Tragen.

Ich suche überall, wo ich diese Änderung im Profil von Delphi vornehmen könnte, finde aber nichts.

Hat jemand nochmal einen Rat?

Danke, Bernd
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 12:02 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf