AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke Sie verwenden eine veraltete Browserversion

Sie verwenden eine veraltete Browserversion

Ein Thema von Rued · begonnen am 1. Dez 2016 · letzter Beitrag vom 4. Dez 2016
Antwort Antwort
Seite 1 von 2  1 2   
Benutzerbild von Rued
Rued

Registriert seit: 14. Mai 2008
Ort: Dortmund => Münster => Dresden => Chemnitz=>Schleching
52 Beiträge
 
Delphi 2010 Professional
 
#1

Sie verwenden eine veraltete Browserversion

  Alt 1. Dez 2016, 22:39
Hallo!

Aus meinen Programmen heraus rufe ich PayPal auf und bekomme jüngst die Meldung "Sie verwenden eine veraltete Browserversion, die möglicherweise nicht sicher ist. Aktualisieren Sie Ihren Browser, um mit PayPal zu bezahlen."

Ich nutze Delphi 2010 und habe es vergeblich mit dem TWebBrowser und dem TEmbeddedWB probiert. Was muss ich ändern?

Gruß

Rüd
Rüdiger Droste
  Mit Zitat antworten Zitat
a.def
(Gast)

n/a Beiträge
 
#2

AW: Sie verwenden eine veraltete Browserversion

  Alt 1. Dez 2016, 22:53
Ich habe TWebBrowser nie benutzt. Aber soweit ich weiß nutzt TWebBrowser intern den Internet Explorer.
Viel machen außer aktualisieren kann man nicht.

Wenn PayPal den Internet Explorer nicht mag, kann man nur noch den Browser wechseln.
  Mit Zitat antworten Zitat
nahpets
(Gast)

n/a Beiträge
 
#3

AW: Sie verwenden eine veraltete Browserversion

  Alt 1. Dez 2016, 23:02
Der TWebBrowser meldet sich als etwas veraltete Version bei den Servern.

Dem kann man eventuell durch einen Eintrag in der Registry abhelfen:
Delphi-Quellcode:
procedure IERegFake(sProgName : String; dwVersion :DWord);
var
          reg : TRegistry;
begin
  // 10001 = Version 10.0
  // 8000 = Version 8.0 Build = 86001
  // 7000 = Version 7.0
  reg := TRegistry.Create;
  reg.RootKey := HKEY_CURRENT_USER;
  reg.OpenKey('Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION',true);
  reg.WriteInteger(sProgName,dwVersion);
  reg.Free;
end;
Aufruf z. B.: IERegFake(ExtractFileName(Application.ExeName),8000); Hab' das inzwischen im Initialisierungsteil einer Unit, die ich in jedes Programm einbinde, das den TWebBrowser nutzt.
  Mit Zitat antworten Zitat
EWeiss
(Gast)

n/a Beiträge
 
#4

AW: Sie verwenden eine veraltete Browserversion

  Alt 1. Dez 2016, 23:02
Zitat:
Wenn PayPal den Internet Explorer nicht mag, kann man nur noch den Browser wechseln.
Nun das hilft nicht wirklich..
Alternative API (Komponente) für gängige Webbrowser?

gruss
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.269 Beiträge
 
Delphi 10.4 Sydney
 
#5

AW: Sie verwenden eine veraltete Browserversion

  Alt 1. Dez 2016, 23:04
Warum machst du es denn nicht einfach richtig und nutzt z.B. die REST-API von Paypal?
https://developer.paypal.com/

Hab' das inzwischen im Initialisierungsteil einer Unit, die ich in jedes Programm einbinde, das den TWebBrowser nutzt.
Ich würde dein Programm da wohl eher bei den Antivirenherstellern anzeigen, wenn es ungefragt meine globalen Systemeinstellungen verstellt.

"Fake" ist bisschen bösse, denn es ist ja eine offizielle Einstellung.
Aber ich finde es krank, dass man sowas global machen muß und nicht als Einstellung "nur" in der jeweiligen Webbrowser-Instanz.
Denn dieses betrifft "alle" Programme im System, welche diese Komponente verwenden und andere Programme könnten durch unbedachte Änderungen nicht mehr funktionieren.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014

Geändert von himitsu ( 1. Dez 2016 um 23:10 Uhr)
  Mit Zitat antworten Zitat
a.def
(Gast)

n/a Beiträge
 
#6

AW: Sie verwenden eine veraltete Browserversion

  Alt 1. Dez 2016, 23:05
Warum machst du es denn nicht einfach richtig und nutzt z.B. die REST-API von Paypal?

https://developer.paypal.com/
Ganz davon abgesehen... wie viel Vertrauen und Sicherheit steckt wohl in irgendeinem Delphi-Programm mit TWebBrowser und PayPal-Zugriff?
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.269 Beiträge
 
Delphi 10.4 Sydney
 
#7

AW: Sie verwenden eine veraltete Browserversion

  Alt 1. Dez 2016, 23:20
wie viel Vertrauen und Sicherheit steckt wohl in irgendeinem Delphi-Programm mit TWebBrowser ...
Internet Explorer (der Große vor Edge)
Active Desktop
Explorer (der für die Dateien)
Startseite der Delphi-IDE
WinHelp (die alte Hilfe vom Delphi 7)
Microsoft Document Explorer (die alte Hilfe vom Visual Studio und Delphi XE)
die Hilfe vom aktuellen Delphi (k.A. was das ist, aber sieht optisch wie ein nachgebauter Document Explorer aus)
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
nahpets
(Gast)

n/a Beiträge
 
#8

AW: Sie verwenden eine veraltete Browserversion

  Alt 1. Dez 2016, 23:33
@himitsu

Die so gemachte Änderung gilt nur für das Programm, dass sie durchführt, und nicht global.
Es ist also eine persönliche Einstellungsänderung. Also nur die Instanz des Webbrowsers in dem Programm, dass den Eintrag in der Registry vornimmt, gibt vor, diese Internetexplorerversion zu sein.
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.847 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#9

AW: Sie verwenden eine veraltete Browserversion

  Alt 1. Dez 2016, 23:50
Hab' das inzwischen im Initialisierungsteil einer Unit, die ich in jedes Programm einbinde, das den TWebBrowser nutzt.
Ich würde dein Programm da wohl eher bei den Antivirenherstellern anzeigen, wenn es ungefragt meine globalen Systemeinstellungen verstellt.
Dieser HKEY_CURRENT_USER-Key ist die offizielle Schnittstelle von MS damit ein Programm definiert als welche IE-Version der hinter TWebBrowser hängende IE-Control sich melden und verhalten soll.
Gibt noch ein paar andere Keys die man in diesem Umfeld kennen muss.
M.E. hat es MS hier mit der Altkompatiblität übertrieben.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Benutzerbild von Rued
Rued

Registriert seit: 14. Mai 2008
Ort: Dortmund => Münster => Dresden => Chemnitz=>Schleching
52 Beiträge
 
Delphi 2010 Professional
 
#10

AW: Sie verwenden eine veraltete Browserversion

  Alt 2. Dez 2016, 10:29
Warum machst du es denn nicht einfach richtig und nutzt z.B. die REST-API von Paypal?
https://developer.paypal.com/

...
Ich arbeite mit den PayPal-Zahlungsbuttons und das klappte bisher auch wunderbar. Mein Programm erkennt, dass nach dem Bezahlen auf eine vorher eingestellte Seite weitergeleitet wird und schaltet frei.

Gruß

Rüd
Rüdiger Droste
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 05:31 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf