AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein GUI-Design mit VCL / FireMonkey / Common Controls Delphi DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenster

DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenster

Ein Thema von haentschman · begonnen am 2. Aug 2018 · letzter Beitrag vom 9. Aug 2018
Antwort Antwort
Seite 3 von 4     123 4   
Benutzerbild von EWeiss
EWeiss

Registriert seit: 16. Okt 2010
5.427 Beiträge
 
Delphi 2010 Architect
 
#21

AW: DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenste

  Alt 2. Aug 2018, 15:24
Nur noch eins!
Wenn alle stricke reißen installiere Eurekalog das hat mir bei solchen Sachen schon gute Dienste geleistet.
Wir selbst können wohl dabei nicht weiter helfen.

gruss
  Mit Zitat antworten Zitat
Benutzerbild von ULIK
ULIK

Registriert seit: 25. Sep 2006
Ort: Regensburg
336 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#22

AW: DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenste

  Alt 2. Aug 2018, 15:51
Sag mal, sehen die MadExcept-Reports immer gleich aus? Und tritt es immer bei dem DropDownEdit auf? Du kannst mir gerne per PN mal ein paar der Reports schicken und ich schau morgen mal, ob mir dabei noch was auffällt.

So vage kann ich mich daran erinnern, daß ich solche Fehler bei mir im Programm auch schon mal gesehen habe. Nur ohne Alpha-Controls. Allerdings hab ich nie die Ursache dafür finden können, geschweige es mal selbst nachstellen können.


Grüße,
Uli
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
3.895 Beiträge
 
Delphi 10.1 Berlin Professional
 
#23

AW: DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenste

  Alt 3. Aug 2018, 07:18
@ULIK
...sie haben Post. Danke.
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
3.895 Beiträge
 
Delphi 10.1 Berlin Professional
 
#24

AW: DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenste

  Alt 3. Aug 2018, 09:26
Moin...
Zitat:
Wenn alle stricke reißen installiere Eurekalog das hat mir bei solchen Sachen schon gute Dienste geleistet.
Was meinst du wo die Callstacks herkommen?
Zitat:
Also wenn es kracht und deine Anwendung läuft dein Fenster betrachten und versuchen zu ermitteln welches Child Window nicht erstellt wird.
Das war der erste Ansatz. Aber...Mit der Fehlermeldung bekomme ich immer ein Bild. Trotz fast identischem Callstack des Fehlers ist es immer wo anders... Und da sind Forms dabei die das betroffene Control "TcxCustomDropDownEdit" nicht enthalten.
Zitat:
Also die grundsätzliche Frage: Erzeugst oder löscht Du dynamisch Controls?
Alle Controls sind auf die Form gepappt.
Zitat:
So vage kann ich mich daran erinnern, daß ich solche Fehler bei mir im Programm auch schon mal gesehen habe. Nur ohne Alpha-Controls. Allerdings hab ich nie die Ursache dafür finden können, geschweige es mal selbst nachstellen können.
...das macht keinen Mut.

In eigener Sache:
Jeder der micht kennt weis, daß ich erst die Fehler bei mir suche, dann recherchiere, dem Support schreibe und dann externe Hilfe annehme. Ich hatte gehofft, daß man mich hier mit dem Fehler ernst nimmt. Dafür muß ich mich rechtfertigen was ich alles nicht gemacht habe! Einen der schon am Boden liegt noch nachtreten... ohne Worte.

Zitat:
In erster Linie liegt die Zuständigkeit bei dir.
Wieso sollte ich Fehler in einer Kaufkomponente fixen? Dafür habe ich keine Zeit. Wie soll ich das dem Chef erklären?
Zitat:
Ich sehe hier im Thread genügend Ansatzpunkte, die von dir offensichtlich nicht weiter verfolgt wurden
Welche Ansätze? Das Deaktivieren der AlphaControls für die DevExpress dauert... aber ich mache es. Was noch?
Zitat:
da wirkt es auf mich befremdlich, wenn den Herstellern pauschal mangelnde Bereitschaft zur Problemlösung unterstellt wird
Ist ein Scherz oder? Die Fehler begleiten mich seit 6 Monaten. Und ich bin nicht der einzige! https://www.google.de/search?biw=185...yxZi0xIhttp://
Was soll ich dem Support mehr geben als die Zeilennummer und die Unit. Die können es selbst nicht nachstellen. Das ist das Problem mit Minimaldemos. (siehe Bild)


Allen die sich mit der eigentlichen Thematik beschäftigt haben sage ich Danke...

So, jetzt bin ich raus...
Miniaturansicht angehängter Grafiken
error.png  
  Mit Zitat antworten Zitat
Benutzerbild von EWeiss
EWeiss

Registriert seit: 16. Okt 2010
5.427 Beiträge
 
Delphi 2010 Architect
 
#25

AW: DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenste

  Alt 3. Aug 2018, 10:33
Zitat:
Was meinst du wo die Callstacks herkommen
Von MadExcept

Im ScreenShot kann man sehen das es um die Combo geht.
Du müsstest doch eigentlich wissen welches Parent die Combo hat.
Prüfe ob GetParent vorhanden ist, wenn nicht dann mit SetParent das zuweisen das dir bekannt ist.
Eventuell hilft es.

PS:
Du weist ACombo, FCombo zu.. bist du 100% sicher das beides das gleiche Control ist?
Du bist 100% sicher das FCombo ein Parent hat?

FCombo.Parent := bla, bla ? ist es 0 oder mehr.

EDIT:
Sorry kann nicht sehen was FCombo ist.
Nur eine frage! Wäre das nicht besser wenn FCombo eine Combo ist?
ACombo := Assign(FCombo);

gruss

Geändert von EWeiss ( 3. Aug 2018 um 10:58 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von timog
timog

Registriert seit: 26. Sep 2006
Ort: Landkreis Oldenburg (Oldb)
86 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#26

AW: DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenste

  Alt 3. Aug 2018, 10:47
Vielleicht Offtopic, habe aber gerde den Blog Post zu DevExpress WinForms Problemen gesehen, unter Windows 1803 scheint es Probleme mit ShowFormsOnTaskbars zu geben. Ob das auch unter der VCL ein Thema ist, habe ich noch nicht rausbekommen.
Timo
Real Programmers are surprised when the odometers in their cars don't turn from 99999 to 9999A.
  Mit Zitat antworten Zitat
Benutzerbild von EWeiss
EWeiss

Registriert seit: 16. Okt 2010
5.427 Beiträge
 
Delphi 2010 Architect
 
#27

AW: DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenste

  Alt 3. Aug 2018, 10:49
Vielleicht Offtopic, habe aber gerde den Blog Post zu DevExpress WinForms Problemen gesehen, unter Windows 1803 scheint es Probleme mit ShowFormsOnTaskbars zu geben. Ob das auch unter der VCL ein Thema ist, habe ich noch nicht rausbekommen.
Nun das ist ein anderes Problem hat nichts mit den Controls und dessen parent auf der Form selbst zu tun.

gruss
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
3.895 Beiträge
 
Delphi 10.1 Berlin Professional
 
#28

AW: DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenste

  Alt 3. Aug 2018, 11:03
Zitat:
Du weist ACombo, FCombo zu.. bist du 100% sicher das beides das gleiche Control ist?
...das ist Originalcode aus der DevExpress Lib wo es klatscht.

PS: Ich gehe nicht an den Originalcode dran...
  Mit Zitat antworten Zitat
Benutzerbild von EWeiss
EWeiss

Registriert seit: 16. Okt 2010
5.427 Beiträge
 
Delphi 2010 Architect
 
#29

AW: DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenste

  Alt 3. Aug 2018, 11:06
Zitat:
Du weist ACombo, FCombo zu.. bist du 100% sicher das beides das gleiche Control ist?
...das ist Originalcode aus der DevExpress Lib wo es klatscht.

PS: Ich gehe nicht an den Originalcode dran...
Ach so das wusste ich nicht.. Sorry.

Nur noch eine frage!
Auf welchem Parent liegt die Combo? (TcxCustomDropDownEdit) gehört es zu den AlphaControls oder zu den der DevExpressControls
Ändert sich irgendetwas wenn du das Parent temporär mal änderst? Dafür sorge trägst das es ein parent der DevExpressControls ist.

Ich habe bald die Vermutung das dein Parent eines DevExpressControls zwingend das eines DevExpressControls sein muss.

gruss

Geändert von EWeiss ( 3. Aug 2018 um 11:58 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
3.895 Beiträge
 
Delphi 10.1 Berlin Professional
 
#30

AW: DevExpress + AlphaControls: Fehler #1 - Element '' hat kein übergeordnetes Fenste

  Alt 8. Aug 2018, 15:07
Hallöle...
...entschuldige die Verzögerung.
Zitat:
Auf welchem Parent liegt die Combo? (TcxCustomDropDownEdit) gehört es zu den AlphaControls oder zu den der DevExpressControls
Alle TcxCustomDropDownEdit´s liegen auf TdxLayoutItem. Das ist quasi immer die "Basis" und der Parent für ein Control.
Zitat:
Ich habe bald die Vermutung das dein Parent eines DevExpressControls zwingend das eines DevExpressControls sein muss.
...wenn du Recht hast, hast du Recht.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 19:01 Uhr.
Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2018 by Daniel R. Wolf